Fedora Linux Support Community & Resources Center
  #1  
Old 30th November 2016, 11:08 AM
Milentije Offline
Registered User
 
Join Date: Nov 2016
Location: Serbia
Posts: 3
linuxfedorafirefox
gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Hi everyone,
I tried to upgrade from Fedora 24 to Fedora 25, but I am getting this when I try to update.

[~]$ sudo dnf system-upgrade download --releasever=25
(download all packages, and..)
Code:
...
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/themes/Adwaita/gtk-3.0/gtk.css conflicts between attempted installs of gnome-themes-standard-3.22.2-1.fc25.x86_64 and gnome-themes-standard-3.22.2-1.fc25.x86_64

Error Summary
-------------
Same error, when I try with GUI.
Can some one help me with this?
Reply With Quote
  #2  
Old 30th November 2016, 02:17 PM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 652
windows_98_nt_2000chrome
Question Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Cao Milentije,

Probaj ovo/try this:

Uradi sledece/do the following: <CTRL> <ALT> <FX> gde je/where X = [2..6]

Molim te, please, enter getty 2 do getty6... And then do the following:
# dnf clean all
# dnf system-upgrade download --releasever=25

And tell us all, if this helps?

_nobody_/_niko_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
  #3  
Old 30th November 2016, 02:58 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 8,432
linuxfedorafirefox
Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

nobody.. This is an English only forum.

Please read the forum rules, especially number 11

Quote:
11). Don't post in languages other than English.
Fedora and FedoraForum.org are both* located in the USA. While we have an international membership, we must insist that English is used in all posts as questions and solutions must be standardized and the staff must be able to understand them. Threads and posts in other languages will be closed with instructions to post again in English. Please don't worry or apologize about imperfect English. Forum members understand this issue well and will compensate for English language errors. *(Note: FedoraForum.org itself is not officially connected with or sponsored by FedoraProject or Red Hat, Inc.).
http://www.fedoraforum.org/?view=guide
Reply With Quote
  #4  
Old 30th November 2016, 03:44 PM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 652
windows_98_nt_2000chrome
Talking Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Quote:
Originally Posted by DBelton View Post
nobody.. This is an English only forum. Please read the forum rules, especially number 11
Copy that, Belton!

_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
  #5  
Old 30th November 2016, 08:24 PM
Milentije Offline
Registered User
 
Join Date: Nov 2016
Location: Serbia
Posts: 3
linuxfedorafirefox
Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Zdravo Nobodi,
I tried, but same error persist.

Anyway, thanks for advice. Some new idea?
Reply With Quote
  #6  
Old 1st December 2016, 06:27 AM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 652
windows_98_nt_2000chrome
Arrow Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Quote:
Originally Posted by Milentije View Post
...file /usr/share/themes/Adwaita/gtk-3.0/gtk.css conflicts between attempted installs of gnome-themes-standard-3.22.2-1.fc25.x86_64 and gnome-themes-standard-3.22.2-1.fc25.x86_64
Hello Milentije,

Yes, you can try the following:

Quote:
[user@localhost ~]$ dnf provides */gtk-3.0
Last metadata expiration check: 8 days, 7:24:45 ago on Tue Nov 22 23:53:11 2016.
gnome-themes-standard-3.22.2-1.fc25.x86_64 : Standard themes for GNOME applications
Repo : @System

gtk3-3.22.4-1.fc25.x86_64 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo : @System

gtk3-devel-3.22.4-1.fc25.x86_64 : Development files for GTK+
Repo : @System
In RED, this is what I have as packages installed on my Fedora 25 Virtual Machine.

Now, you need to be very careful here, and bring your F24 up, and then go to getty 2 or getty 3 (<CTRL> <ALT> <F2> or <CTRL> <ALT> <F3>) and de-install all three packages (since you are using gnome).

Maybe you should de-install the whole gnome (even better idea):
https://ask.fedoraproject.org/en/que...-on-fedora-23/

But BEFORE upgrading to F25. Then, if upgrade to F25 commences as OK, you just need to again install (without shut down) gnome for F25.

Hope this helps!

_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
  #7  
Old 1st December 2016, 06:06 PM
Milentije Offline
Registered User
 
Join Date: Nov 2016
Location: Serbia
Posts: 3
linuxfedorafirefox
Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Nobody,
I have tried as you suggested. Removed Gnome and upgraded. Upgrade went ok, but when I tried to install Gnome afterwards it prompt me the same error about conflict with gnome-themes-standard.

I have reinstalled the system with Fedora 25.

It looks its a bug. https://bugzilla.redhat.com/show_bug.cgi?id=1387753

Thank you, anyway for a help.
Reply With Quote
  #8  
Old 1st December 2016, 07:02 PM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 652
windows_98_nt_2000chrome
Arrow Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Quote:
Originally Posted by Milentije View Post
Thank you for finding Bugzilla. Added myself to this one, as observer. Let us see what the outcome of this one could/should be?

If anything else, do not hesitate to post, we are here... Trying to help (not always easy)!
_______

Interesting... This comes directly from my F25 virtual machine!

Quote:
[root@localhost linux]# uname -a
Linux localhost.localdomain 4.8.10-300.fc25.x86_64 #1 SMP Mon Nov 21 18:59:16 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost linux]# uname -r
4.8.10-300.fc25.x86_64
[root@localhost linux]# dnf install gnome-themes-standard
Last metadata expiration check: 2:10:18 ago on Thu Dec 1 17:54:59 2016.
Package gnome-themes-standard-3.22.2-1.fc25.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost linux]#
http://www.forums.fedoraforum.org/sh...88&postcount=6 (I did not notice here that I already have it installed)! What the heck???

_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!

Last edited by nobody; 1st December 2016 at 07:29 PM. Reason: Package gnome-themes-standard-3.22.2-1.fc25.x86_64 is already installed...
Reply With Quote
  #9  
Old 1st December 2016, 07:34 PM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 652
windows_98_nt_2000chrome
Question Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Quote:
Originally Posted by Milentije View Post
Error: Transaction check error:
file /usr/share/themes/Adwaita/gtk-3.0/gtk.css conflicts between attempted installs of gnome-themes-standard-3.22.2-1.fc25.x86_64 and gnome-themes-standard-3.22.2-1.fc25.x86_64
Possible duplicates??? Must be reason for this... In my case it worked seamlessly!?

_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
  #10  
Old 1st December 2016, 07:41 PM
srakitnican Offline
Registered User
 
Join Date: Oct 2011
Posts: 1,265
linuxchrome
Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

What do you have currently installed?... "rpm -q gnome-themes-standard"

Do you have all packages up to date in your current system?


EDIT: Also what does following commands return:

Code:
$ file /usr/share/themes/Adwaita/gtk-3.0/gtk.css
$ file /usr/share/themes/gnome/gtk-3.0/gtk.css

Last edited by srakitnican; 1st December 2016 at 07:51 PM.
Reply With Quote
  #11  
Old 1st December 2016, 08:09 PM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 652
windows_98_nt_2000chrome
Question Re: gnome-themes-standard conflicts with it self and unabling upgrade to Fedora 25

Here is what system F25 VM on the top of WIN10 64 Pro/VMWorkstation 12.5.2 gives to me... srakitnican!

Quote:
[intel@localhost linux]$ rpm -q gnome-themes-standard
gnome-themes-standard-3.22.2-1.fc25.x86_64
[intel@localhost linux]$ file /usr/share/themes/Adwaita/gtk-3.0/gtk.css
/usr/share/themes/Adwaita/gtk-3.0/gtk.css: ASCII text
[intel@localhost linux]$ file /usr/share/themes/gnome/gtk-3.0/gtk.css
/usr/share/themes/gnome/gtk-3.0/gtk.css: cannot open `/usr/share/themes/gnome/gtk-3.0/gtk.css' (No such file or directory)

[intel@localhost linux]$ cd /usr/share/themes/
[intel@localhost themes]$ ls -al
total 44
drwxr-xr-x. 9 root root 4096 Oct 15 07:17 .
drwxr-xr-x. 316 root root 12288 Nov 30 07:28 ..
drwxr-xr-x. 5 root root 4096 Oct 15 07:17 Adwaita
drwxr-xr-x. 4 root root 4096 Oct 15 07:17 Adwaita-dark
drwxr-xr-x. 3 root root 4096 Oct 29 2015 Anaconda
drwxr-xr-x. 5 root root 4096 Nov 21 09:45 Default
drwxr-xr-x. 4 root root 4096 Nov 21 09:45 Emacs
drwxr-xr-x. 4 root root 4096 Oct 15 07:17 HighContrast
drwxr-xr-x. 3 root root 4096 Sep 15 15:05 Raleigh
[intel@localhost themes]$ cd Adwaita
[intel@localhost Adwaita]$ ls
gtk-2.0 gtk-3.0 index.theme qt
[intel@localhost Adwaita]$ cd gtk-3.0/
[intel@localhost gtk-3.0]$ ls -al
total 12
drwxr-xr-x. 2 root root 4096 Oct 15 07:17 .
drwxr-xr-x. 5 root root 4096 Oct 15 07:17 ..
-rw-r--r--. 1 root root 68 Oct 12 23:58 gtk.css
[intel@localhost gtk-3.0]$ cat gtk.css
/* Adwaita is the default theme of GTK+ 3, this file is not used */
[intel@localhost gtk-3.0]$
_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
Reply

Tags
conflicts, fedora, gnomethemesstandard, unabling, upgrade

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mate-themes package conflicts with adwaita in recent update WinonuX Using Fedora 0 4th November 2012 08:20 PM
[SOLVED] Window Themes in Fedora 17 gnome heolstor Using Fedora 2 7th September 2012 10:14 PM
Themes of gnome-shell Of fedora 16 Gooddy Using Fedora 10 16th November 2011 04:03 AM
Bisig Gnome Themes for Fedora TheBigRed Programming & Packaging 0 26th September 2010 03:13 PM
Fedora Icon themes, and the gnome standard index.theme licensedorchid Using Fedora 1 22nd August 2008 10:44 PM


Current GMT-time: 00:28 (Monday, 01-05-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat