Fedora Linux Support Community & Resources Center
  #1  
Old 14th March 2017, 10:42 PM
ppulgar Offline
Registered User
 
Join Date: Mar 2017
Location: Chile
Posts: 3
linuxfedorafirefox
Exclamation Can't install "Bully" on F25

Hi guys, i'm new here.

I'm having troubles installing Bully (as required by Fluxion)
whenever i try to compile the /bully/src/makefile my console looks like this.

[root@localhost src]# make
cc -I`pwd` -I`pwd`/utils/ -I`pwd`/tls/ -I`pwd`/wps/ -I`pwd`/crypto/ -I`pwd`/common/ -o bully bully.c -lpcap -lssl -lcrypto
In file included from bully.c:89:0:
80211.c: En la función ‘reassoc’:
80211.c:328:16: aviso: declaración implícita de la función ‘set_chan’ [-Wimplicit-function-declaration]
G->chanx = set_chan(G, tag->data[0]);
^~~~~~~~
80211.c:356:16: aviso: declaración implícita de la función ‘next_chan’ [-Wimplicit-function-declaration]
G->chanx = next_chan(G);
^~~~~~~~~
In file included from bully.c:91:0:
iface.c: En la función ‘set_chan’:
iface.c:28:9: aviso: declaración implícita de la función ‘set_chanx’ [-Wimplicit-function-declaration]
return set_chanx(G, G->index[chan]);
^~~~~~~~~
bully.c: En la función ‘main’:
bully.c:969:4: aviso: ‘return’ sin valores, en una función que no devuelve void
return;
^~~~~~
bully.c:95:5: nota: se declara aquí
int main(int argc, char *argv[])
^~~~
/usr/bin/ld: se salta el /usr/lib/gcc/x86_64-redhat-linux/6.3.1/../../../libpcap.so incompatible mientras se busca -lpcap
/usr/bin/ld: se salta el /lib/libpcap.so incompatible mientras se busca -lpcap
/usr/bin/ld: se salta el /usr/lib/libpcap.so incompatible mientras se busca -lpcap
/usr/bin/ld: no se puede encontrar -lpcap
collect2: error: ld devolvió el estado de salida 1
Makefile:19: fallo en las instrucciones para el objetivo 'bully'
make: *** [bully] Error 1

So im having all these errors but the main thing here is that it can't find "-lpcap".

Could anyone help me please, i'm really having a hard time here and i'm a newbie running a Linux distro. Thanks a lot
Reply With Quote
  #2  
Old 15th March 2017, 01:04 AM
bobx001 Offline
Registered User
 
Join Date: Dec 2012
Location: santa barbara, CA
Posts: 388
linuxfedorafirefox
Re: Can't install "Bully" on F25

type this as root (or with sudo)

dnf install libpcap-devel libpcap

once done installing those packages, try compiling bully again
Reply With Quote
  #3  
Old 15th March 2017, 01:28 AM
ppulgar Offline
Registered User
 
Join Date: Mar 2017
Location: Chile
Posts: 3
linuxfedorafirefox
Re: Can't install "Bully" on F25

Quote:
Originally Posted by bobx001 View Post
type this as root (or with sudo)

dnf install libpcap-devel libpcap

once done installing those packages, try compiling bully again

Did it, and still got the same error
Reply With Quote
  #4  
Old 15th March 2017, 01:55 AM
bobx001 Offline
Registered User
 
Join Date: Dec 2012
Location: santa barbara, CA
Posts: 388
linuxfedorafirefox
Re: Can't install "Bully" on F25

Hmmm, then I think your linker is finding a 64bit version of libpcap, but the program may require the 32bit version.

do this:
rpm -qa | grep pcap
libpcap-1.7.4-2.fc24.x86_64
libpcap-1.7.4-2.fc24.i686

can you see both types like I have ?
Reply With Quote
  #5  
Old 15th March 2017, 03:14 AM
ppulgar Offline
Registered User
 
Join Date: Mar 2017
Location: Chile
Posts: 3
linuxfedorafirefox
Re: Can't install "Bully" on F25

Quote:
Originally Posted by bobx001 View Post
Hmmm, then I think your linker is finding a 64bit version of libpcap, but the program may require the 32bit version.

do this:
rpm -qa | grep pcap
libpcap-1.7.4-2.fc24.x86_64
libpcap-1.7.4-2.fc24.i686

can you see both types like I have ?
rpm -qa | grep pcap
pcapdiff-0.1-16.fc24.noarch
libpcap-devel-1.7.4-2.fc24.i686
pcapy-0.10.8-9.fc25.x86_64
libpcap-1.7.4-2.fc24.x86_64
libpcap-1.7.4-2.fc24.i686

that's what i got. Thanks for replying!
Reply With Quote
  #6  
Old 15th March 2017, 07:52 AM
bobx001 Offline
Registered User
 
Join Date: Dec 2012
Location: santa barbara, CA
Posts: 388
linuxfedorafirefox
Re: Can't install "Bully" on F25

missing devel 64 bit

Try:
dnf install libpcap-devel.x86_64

then try make again.

Here is what I did:
Code:
su -
# dnf install libpcap-devel.x86_64
# dnf install openssl-devel
exit
wget https://github.com/aanarchyy/bully/archive/master.zip
unzip master.zip
cd bully-master
cd src
make

that's it.
./bully --version
v1.1
Reply With Quote
Reply

Tags
bully, fc25, fluxion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
unpredictable "delete" "move to trash" or "cut" file menu option dorianrenato Using Fedora 1 21st November 2011 03:09 AM
F14 - attempt to install XAMPP, run "chmod 764 /opt", get "ERROR: ld.so..." Irfan_A EOL (End Of Life) Versions 3 27th October 2011 12:37 AM
F9 & F8 freeze on "transferring install image..." AND F9 "insufficient disk space" fashionhat Installation, Upgrades and Live Media 4 1st July 2008 02:04 PM
Fglrx driver install - "direct rendering: No", Xlib: extension "XFree86-DRI" missing Squeaks Hardware & Laptops 9 21st October 2006 12:10 PM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM


Current GMT-time: 16:48 (Friday, 26-05-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat