Fedora Linux Support Community & Resources Center
  #1  
Old 13th May 2017, 08:52 AM
MrVideo Offline
Registered User
 
Join Date: Mar 2007
Posts: 87
linuxchrome
Where to set MATE so that workspace is saved

When I logged out of MATE in order to bring the system down to install new RAM, I discovered that my workspace's contents were not saved, specifically all of the terminals that I had up and running. I do not know if the MATE system monitor would be restarted or not.

I looked at the Arch-Linux wiki entry for MATE and there was nothing there.

Just where is the setting for saving the workspaces when I log out?

Thanks.
Reply With Quote
  #2  
Old 13th May 2017, 03:41 PM
MrVideo Offline
Registered User
 
Join Date: Mar 2007
Posts: 87
linuxchrome
Re: Where to set MATE so that workspace is saved

Found it where I least expected it.
Reply With Quote
  #3  
Old 15th May 2017, 12:48 PM
HaydnH Offline
Registered User
 
Join Date: Feb 2005
Location: London, UK
Posts: 398
windows_7chrome
Re: Where to set MATE so that workspace is saved

Quote:
Originally Posted by MrVideo View Post
Found it where I least expected it.
I don't use Mate, but it might be nice to post "where you least expected it" for other people finding this post at a later date.
Reply With Quote
  #4  
Old 18th May 2017, 07:46 AM
MrVideo Offline
Registered User
 
Join Date: Mar 2007
Posts: 87
linuxchrome
Re: Where to set MATE so that workspace is saved

Quote:
Originally Posted by HaydnH View Post
I don't use Mate, but it might be nice to post "where you least expected it" for other people finding this post at a later date.
Here is the sequence of menu selections:
Code:
System->Preferences->Personal->Startup Applications
Option tab
Being located in Startup Applications is really strange, because most of the programs that I started, were not a result of being in this startup list. Things like terminals. I start them by clicking on the icon on the top bar.

IMHO, a better place for the option is when you are actually logging out. A check box can be placed in the logout GUI, that is remembered.

have not tested that this actually works yet.
Reply With Quote
  #5  
Old 18th May 2017, 05:39 PM
antikythera Offline
Administrator
 
Join Date: Dec 2013
Location: United Kingdom
Posts: 4,307
linuxchrome
Re: Where to set MATE so that workspace is saved

That does seem counter-intuitive. I recall seeing such a tickbox to remember running programs within the logout dialogue of another desktop environment. It was either XFCE or LXDE. Either way it isn't something I'd use personally but I can see the value. You can request the addition of it upstream via the IRC
__________________
Latest survey shows that 3 out of 4 people make up 75% of the world's population - Stephen Hawking
Download, Install and Share Fedora
- Official ISO Torrents
| Live ISO Respins containing post-release updates
Reply With Quote
  #6  
Old 18th May 2017, 09:13 PM
topiwala Offline
Registered User
 
Join Date: Aug 2011
Location: India
Age: 31
Posts: 339
linuxfedorafirefox
Re: Where to set MATE so that workspace is saved

I think it is because it is gnome2 session properties.
Reply With Quote
  #7  
Old 19th May 2017, 05:34 AM
MrVideo Offline
Registered User
 
Join Date: Mar 2007
Posts: 87
linuxchrome
Re: Where to set MATE so that workspace is saved

Quote:
Originally Posted by topiwala View Post
I think it is because it is gnome2 session properties.
Another reason to not like GNOME2.

Edit. Oops, gotta learn to read. It is GNOME3 I do not like.

Last edited by MrVideo; 10th June 2017 at 11:06 PM.
Reply With Quote
  #8  
Old 10th June 2017, 11:05 PM
MrVideo Offline
Registered User
 
Join Date: Mar 2007
Posts: 87
linuxfedorachrome
Re: Where to set MATE so that workspace is saved

Well, guess what, that didn't work. I had to shut down all of my systems because we had a power outage, which last almost three hours. My UPS boxes certainly were not going to keep everything up that long.

After restarting the F25 box and logging in, I discovered not one of the terminals restarted. The only thing that start was pan and I think that was because I put it in the applications to start. I'm going to have to remove it, as there is a particular workspace I want it to start it.

So, back to square one. I need to find out how to save at least the terminals and what workspaces/directories they were in when I logged off. It worked great using GNOME2 under F14.
Reply With Quote
  #9  
Old 11th June 2017, 12:25 AM
dd_wizard Online
Registered User
 
Join Date: Sep 2009
Posts: 2,015
linuxfedorafirefox
Re: Where to set MATE so that workspace is saved

It works for me in fc25. I tested it with four mate-terminal windows running in four different directories. The only caveat is, I rebooted after changing the setting in Startup Applications before opening the windows. Logging out may have been enough. And the location seems intuitive to me, you want the applications running when you rebooted to be "Startup Applications."

dd_wizard
Reply With Quote
  #10  
Old 11th June 2017, 02:56 AM
MrVideo Offline
Registered User
 
Join Date: Mar 2007
Posts: 87
linuxfedorachrome
Re: Where to set MATE so that workspace is saved

I'll try it again. Maybe I didn't really get logged out when the UPS that powered the wallwart for the KVM died. I thought for sure that I started the process.

Thanks for the response.
Reply With Quote
Reply

Tags
mate, saved, set, workspace

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 23, MATE and compiz-mate-emerald biuro74 Using Fedora 2 8th February 2016 10:25 PM
F23 - Mate Menu Editing - mate-panel doesn't display on next login pressanykey Desktop Environments / Window Managers 2 1st January 2016 01:53 AM
using mate and trying to launch multiple mate-terminals... picasso_1.2.13 Using Fedora 15 16th October 2015 07:52 PM
[SOLVED] Fedora 20 change number of workspaces in MATE - Workspace Switcher issue julia2009 Using Fedora 9 13th December 2014 09:37 PM
Launching firefox in any workspace other than workspace 1, triggers overview expectATIon F18 Development 3 5th December 2012 09:11 PM


Current GMT-time: 22:35 (Wednesday, 28-06-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat