Fedora Linux Support Community & Resources Center
  #1  
Old 4th June 2012, 09:25 PM
akiross Offline
Registered User
 
Join Date: Feb 2010
Location: Italy
Age: 32
Posts: 73
linuxfirefox
Icons and images disappeared, can't login in gnome shell

Hello!
I just installed F17, fresh install on my new laptop.
It worked great, but after some customization it started to do something bizarre: all icons of programs, such firefox, nautilus, etc, started to vanish (and a nice red X appeared instead), then the background image (default one) disappeared, leaving a nice blue screen.

In the login screen, wallpaper is vanished too, so I *guess* that is something system-wide and not realted to my user home directory. I didn't try to create another user and check if it worked for it.

Anyway, I guess that gnome-tweak-tool did something undesirable, as it was one of the last things I installed before starting to get this issue.

Now, when I log in, I can't see anything but the top bar. Trying to launch any program, will cause a fail message to appear (unrecoverable error), forcing to close the session.

I watched my .xsession-errors and contains things like

Gtk-WARNING **: Error loading theme icon 'image-missing' for stock: Unrecognized file format

I attached the full file in this thread if it may be useful.

I can't use the desktop in this situation, so any help is appreciated.

Thanks!
~Aki
Attached Files
File Type: txt xsession-errors.txt (9.6 KB, 411 views)
Reply With Quote
  #2  
Old 5th June 2012, 05:40 AM
tashirosgt Offline
Registered User
 
Join Date: Aug 2004
Posts: 4,019
linuxfirefox
Re: Icons and images disappeared, can't login in gnome shell

I don't use the gnome spin so I can't be much help. But since the messages show that *.svg files are considered an "unrecognized format" and *.svg probably should be a known format, I think you should investigate this problem first.

One possibility is that whatever library is supposed to be use to deal wih svg files is missing or corrupt. I think a greater possibility is that there is a file somewhere that tells the desktop manager (or things it uses like Gtk) what libraries it should use for various file formats and this file has gone bad. Here is an old discussion that is probably not accurate for current configurations but it suggests (post #2) that this type of problem can happen: https://bugs.launchpad.net/ubuntu/+s...rd/+bug/799505
__________________
"Never let the task you are trying to accomplish distract you from the study of computers."
Reply With Quote
  #3  
Old 5th June 2012, 09:00 AM
Da1hammer Offline
Registered User
 
Join Date: Jun 2009
Location: NM
Posts: 2
linuxfirefox
Wink Re: Icons and images disappeared, can't login in gnome shell

Akiross,
I had what seems to be a similar problem today, and it turned out that my mime types became corrupted. Anyway, I found another persons thread on another forum site (http://www.spinics.net/linux/fedora/...msg417967.html) that mentioned what might be the problem, and how to solve!

As root (or sudo as I do ):
>#update-mime-database /usr/share/mime
>#chmod 664 /usr/share/applications/mimeinfo.cache

(note: Please don't copy and paste the fake root prompt! and don't forget to re-boot!)

I hope this helps!

Da1hammer
__________________
:)David:)
Reply With Quote
  #4  
Old 5th June 2012, 09:53 AM
akiross Offline
Registered User
 
Join Date: Feb 2010
Location: Italy
Age: 32
Posts: 73
linuxfirefox
Re: Icons and images disappeared, can't login in gnome shell

Quote:
Originally Posted by Da1hammer View Post
Akiross,
I had what seems to be a similar problem today, and it turned out that my mime types became corrupted. Anyway, I found another persons thread on another forum site (http://www.spinics.net/linux/fedora/...msg417967.html) that mentioned what might be the problem, and how to solve!

As root (or sudo as I do ):
>#update-mime-database /usr/share/mime
>#chmod 664 /usr/share/applications/mimeinfo.cache

(note: Please don't copy and paste the fake root prompt! and don't forget to re-boot!)

I hope this helps!

Da1hammer
Great! It solved, thanks
Now, question is: how did this happen? It would be great to understand what caused this to avoid or fix the cause... But I've no idea. :S
Only things I did was to install gnome-tweak-tool, inkscape and synfigstudio. After launching synfig, I noted broken icons so I removed it, but the problem where elsewhere so everything else started to go bad.

As said tashirosgt, it seemed to be a svg-related problem, so... May it be that Inkscape or synfigstudio broke the mime database?

Anyway, thanks for the help. I'll wait a bit before marking the thread as solved, better to find a cause before closing the issue

Thanks again!
Reply With Quote
  #5  
Old 5th June 2012, 10:27 AM
Da1hammer Offline
Registered User
 
Join Date: Jun 2009
Location: NM
Posts: 2
linuxfirefox
Thumbs up Re: Icons and images disappeared, can't login in gnome shell

Akiross,
How it happened for me is that I was updating several packages like gthumb and synfigstudio, and b4 it finished with the updates, pics and icons started disappearing!, and so, I tried to get into Gnome 3 after a re-boot only to see the frownie face computer dialog each time, and, although XFCE4 still worked, it was a mess! Finally, I used KDE4, which uses a different set-up in many parts, but backgrounds, and many icons were just gone or had question mark icons in their place.

So, I think that it is faulty script in the synfigstudio rpm that is to blame, as the affected files in /usr/share/mime had a time stamp of when I updated the several pkgs. Here are the exact rpms I updated:

Jun 4 19:17:08 yum[9757]: Updated: openssl-1.0.0j-1.fc16.x86_64
Jun 4 19:22:11 yum[9757]: Updated: synfigstudio-0.63.05-3.1.fc16.x86_64
Jun 4 19:22:17 yum[9757]: Updated: synfigstudio-devel-0.63.05-3.1.fc16.x86_64
Jun 4 19:22:40 yum[9757]: Updated: openssl-devel-1.0.0j-1.fc16.x86_64
Jun 4 19:22:54 yum[9757]: Updated: gthumb-2.14.4-1.fc16.x86_64
Jun 4 19:22:59 yum[9757]: Updated: python-crypto-2.3-6.fc16.x86_64
Jun 4 19:23:18 yum[9757]: Updated: childsplay-1.6-6.fc16.noarch
Jun 4 19:23:24 yum[9757]: Updated: uhd-3.4.2-1.fc16.x86_64
Jun 4 19:23:28 yum[9757]: Updated: openssl-1.0.0j-1.fc16.i686

The mime types therefore have to be updated as said in my above post, which is what solved it for me!

Now it is back to wonderful wood on my XFCE desktop, as Gnome isn't doing textures at the moment.

Da1hammer
__________________
:)David:)
Reply With Quote
  #6  
Old 5th June 2012, 09:55 PM
akiross Offline
Registered User
 
Join Date: Feb 2010
Location: Italy
Age: 32
Posts: 73
linuxfirefox
Re: Icons and images disappeared, can't login in gnome shell

Quote:
Originally Posted by Da1hammer View Post
How it happened for me is that I was updating several packages like gthumb and synfigstudio, and b4 it finished with the updates, pics and icons started disappearing!, and so, I tried to get into Gnome 3 after a re-boot only to see the frownie face computer dialog each time, and, although XFCE4 still worked, it was a mess! Finally, I used KDE4, which uses a different set-up in many parts, but backgrounds, and many icons were just gone or had question mark icons in their place.
Uhm, interesting... We both had the issue after installing synfigstudio.
Shall we open a bug?

Meanwhile I'll close this thread as solved
Reply With Quote
  #7  
Old 6th June 2012, 01:34 AM
Finalzone Offline
Community Manager
 
Join Date: Mar 2004
Location: Vancouver, Canada
Posts: 2,619
linuxfirefox
Re: Icons and images disappeared, can't login in gnome shell

Quote:
Originally Posted by akiross View Post
Uhm, interesting... We both had the issue after installing synfigstudio.
Shall we open a bug?

Meanwhile I'll close this thread as solved
No need. synfigstudio-0.63.05-1 was at fault. The reason was the bundled mime that was not removed prior on installation resulting an overwriting of mime data. Sorry about that.

https://bugzilla.redhat.com/show_bug.cgi?id=821740
__________________
Desktop CPU: AMD Phenom II(tm) X4 Processor 940 AM2+ - Memory: 8GB DDR2-RAM - GPU: Nvidia Geforce GTX 460 v2 - OS: Fedora 24 Workstation x86-64 and Windows 10 Pro 64-bit
Laptop ASUS X550ZE - APU: AMD Quad Core A10 7400P + Dual Radeon R5 230, R7 M265DX - Memory: 16GB DDR3-RAM - OS: Fedora 25 Design Suite x86-64
Reply With Quote
  #8  
Old 7th April 2015, 10:31 AM
mikkeljohnsen Offline
Registered User
 
Join Date: Apr 2015
Location: Denmark
Posts: 3
macosfirefox
Re: Icons and images disappeared, can't login in gnome shell

Had I just read a bit more careful. The solution is as written:

Quote:
update-mime-database /usr/share/mime
Reply With Quote
  #9  
Old 18th May 2017, 11:04 PM
foxdoismil Offline
Registered User
 
Join Date: May 2007
Posts: 12
linuxfirefox
Re: Icons and images disappeared, can't login in gnome shell

I had a lot of trouble till I found this solution.
I am posting to this old thread because the solution also worked well for the problem I had with a Centos 7 KDE workstation.

In order to generate enough material for search engines to find this thread I will make a short description of the problem:

I issued a "sudo yum update" on my Centos 7 Workstation desktop and after rebooting I could not see the Centos logo on the bottom of the screen nor the "user logo" on the login.

Click on the password box and it closes. Click on the user name again and I got a blank screen with the following text on the Center:

Oh no! something has gone wrong. A problem has occurred and the system can't recover. Please call the system administrator. some people may see as Please log out and try again.

What to do:
Check the boot log:
vi /var/log/messages

In my case I see lots of messages similar to the these:
May 18 17:01:05 username gnome-session: (gnome-shell:1472): St-WARNING **: Failed to load /usr/share/gnome-shell/theme/noise-texture.png: Unrecognized image file format
May 18 17:01:05 username gnome-session: (gnome-shell:1472): St-WARNING **: Failed to load /usr/share/gnome-shell/theme/message-tray-background.png: Unrecognized image file format
...
...
May 18 17:01:28 username gnome-session: (gnome-shell:1472): GLib-GIO-CRITICAL **: g_task_return_error: assertion 'error != NULL' failed
May 18 17:01:28 username gnome-session: (gnome-shell:1472): GLib-GIO-CRITICAL **: g_task_propagate_pointer: assertion 'task->result_set == TRUE' failed
May 18 17:01:28 username gnome-session: **
May 18 17:01:28 username gnome-session: Gtk:ERROR:gtkicontheme.c:4915:gtk_icon_info_load_s ymbolic_finish: assertion failed: (pixbuf != NULL)
May 18 17:01:28 username abrt-hook-ccpp: Process 1472 (gnome-shell) of user 42 killed by SIGABRT - dumping core
...
...
May 18 17:01:31 username gnome-session: (gnome-shell:1703): mutter-WARNING **: Failed to load background '/usr/share/backgrounds/gnome/adwaita-lock.jpg': Failed to open file '/usr/share/backgrounds/gnome/adwaita-lock.jpg': file or directory not found
May 18 17:01:31 username gnome-session: (gnome-shell:1703): mutter-WARNING **: Failed to load background '/usr/share/gnome-shell/theme/noise-texture.png': Couldn't recognize the image file format for file '/usr/share/gnome-shell/theme/noise-texture.png'


The solution as presented above as follows:
As soon as you get the non-working login screen use the Ctrl-Alt-F2 (or whatever combination is used on your distro) to open a plain text console login screen. Login as root and issue the following commands:

update-mime-database /usr/share/mime
chmod 644 /usr/share/applications/mimeinfo.cache
reboot


I hope this may help someone.
Reply With Quote
Reply

Tags
disappeared, gnome, icons, images, login, shell

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME Shell 3.0.1 Duplicate App Icons jtfolden F15 Development 9 1st May 2011 03:28 AM
Fedora 7 - gnome 2.18.3 - Desktop icons have disappeared rambat Using Fedora 6 16th October 2007 07:38 PM
login pic disappeared from happy gnome browser imdeemvp Using Fedora 11 14th February 2006 08:38 PM
All icons disappeared from KDE apps in Gnome in FC3 TheBelush EOL (End Of Life) Versions 0 17th April 2005 08:54 PM
Login screen disappeared/no gnome benso37 Using Fedora 3 3rd March 2005 01:13 AM


Current GMT-time: 21:20 (Saturday, 27-05-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat