Fedora Linux Support Community & Resources Center
  #1  
Old 13th May 2011, 06:14 PM
shduff Offline
Registered User
 
Join Date: May 2011
Posts: 4
windows_7firefox
Hal Daemon Fails to Start

I recently updated one of our Fedora 14 boxes with the latest round of updates (including kernel 2.6.35.13-91.fc14.x86_64).
After rebooting, the Hal Daemon service will not start. Here is the error in the messages log: May 13 11:12:42 phoenix kernel: [ 27.946993] hald[1677]: segfault at 0 ip 00000000004106eb sp 00007fffd14780f0 error 4 in hald[400000+52000

The Messagebus service is running (saw a post somewhere about this). Being a noob, I could use all the help I can get. Thanks in advance
  #2  
Old 18th May 2011, 04:54 PM
shduff Offline
Registered User
 
Join Date: May 2011
Posts: 4
windows_7firefox
Re: Hal Daemon Fails to Start

Any thoughts on this? I tried on a test machine as well and I get the same issue. I was able to run /usr/sbin/hald on my test machine and the service will start and after a reboot the issue has seemed to disappear. I tried this on the server in question and had no such luck.

If I am not in the right forum, please direct me to the right area. I am all Googled out of suggestions. Thanks.
  #3  
Old 18th May 2011, 05:22 PM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,799
linuxfedorafirefox
Re: Hal Daemon Fails to Start

Are you having any usability problems with the server that hal is crashing on? I just looked and the only packages that depend on hal are hal-info, smolt, and smolt-firstboot. Doesn't seem to be used by the desktop at all.
  #4  
Old 18th May 2011, 05:25 PM
shduff Offline
Registered User
 
Join Date: May 2011
Posts: 4
windows_7firefox
Re: Hal Daemon Fails to Start

None that i can tell. Just getting the triangle that states that there were booting issues. Also, PC\SC Smart card daemon fails to start as well, but I think that is because of HAL.
  #5  
Old 18th May 2011, 05:35 PM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,799
linuxfedorafirefox
Re: Hal Daemon Fails to Start

I am not running the pcsc-lite daemon on my system, but it might depend on hal. Anyway, the next place to check would be to search Fedora bugzilla for recent hal package bug reports, and if none are there add a bug report.
  #6  
Old 18th May 2011, 05:38 PM
shduff Offline
Registered User
 
Join Date: May 2011
Posts: 4
windows_7firefox
Re: Hal Daemon Fails to Start

I have looked there, but nothing as of yet. I may have to create a new bug. Thanks for your help.
  #7  
Old 25th November 2013, 06:49 PM
srikrish85 Offline
Registered User
 
Join Date: Nov 2013
Location: India
Posts: 2
linuxchrome
Re: Hal Daemon Fails to Start

same here. Once I log in and start systemctl start haldaemon.service it displays the message

Loaded: loaded (/usr/lib/systemd/system/haldaemon.service; enabled)
Active: active (running) since Tue 2013-11-26 00:12:56 IST; 6min ago
Main PID: 2359 (hald)
CGroup: name=systemd:/system/haldaemon.service
├─2359 /usr/sbin/hald --daemon=no --use-syslog
├─2360 hald-runner
├─2395 hald-addon-input: Listening on /dev/input/event4 /dev/input...
├─2408 /usr/libexec/hald-addon-acpi
└─2423 hald-addon-storage: polling /dev/sr0 (every 2 sec)

Nov 26 00:12:57 bajranghost hald[2359]: ! full path is '/usr/libexec/hald-p...'
Nov 26 00:12:57 bajranghost hald[2359]: pid 2409: rc=0 signaled=0: /usr/libe...e
Nov 26 00:12:57 bajranghost hald[2359]: pid 2410: rc=0 signaled=0: /usr/libe...e
Nov 26 00:12:57 bajranghost hald[2359]: pid 2411: rc=0 signaled=0: /usr/libe...e
Nov 26 00:12:57 bajranghost hald[2359]: pid 2413: rc=0 signaled=0: /usr/libe...e
Nov 26 00:12:57 bajranghost hald[2359]: Run started hald-probe-volume (20000...)
Nov 26 00:12:57 bajranghost hald[2359]: ! full path is '/usr/libexec/hald-p...'
Nov 26 00:12:57 bajranghost hald[2359]: pid 2412: rc=0 signaled=0: /usr/libe...e
Nov 26 00:12:57 bajranghost hald[2359]: pid 2414: rc=0 signaled=0: /usr/libe...e
Nov 26 00:12:59 bajranghost hald[2359]: Run started hwoohoo


I'm just wondering why it fails at startup.
  #8  
Old 25th November 2013, 07:36 PM
srikrish85 Offline
Registered User
 
Join Date: Nov 2013
Location: India
Posts: 2
linuxchrome
Re: Hal Daemon Fails to Start

After updating kernel to 3.11.9-200.fc19.i686.PAE it works.
Let's see.
Display Manager lightdm. desktop MATE.
  #9  
Old 25th November 2013, 08:48 PM
Dan Offline
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 24,099
linuxfirefox
Re: Hal Daemon Fails to Start

And with that ... and because the thread is very old ... thread closed.

Start a new one if need be.

Thanks.
Closed Thread

Tags
daemon, fails, hal, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hal daemon fails to start after F12 yum update kilgor Using Fedora 0 18th November 2009 10:08 PM
Boot up fails. Avahi-Daemon fails. flyingpengwin Using Fedora 6 26th November 2008 03:46 AM
Hal Daemon Fails militiaware Using Fedora 38 5th August 2008 08:33 PM
Hal daemon fails to start mukiwa Using Fedora 3 9th December 2006 06:49 PM
HAL Daemon fails - is this an issue boyd98 Using Fedora 0 22nd March 2006 03:32 PM


Current GMT-time: 00:09 (Sunday, 25-06-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat