Fedora Linux Support Community & Resources Center
  #16  
Old 30th July 2013, 04:21 PM
Gareth Jones Offline
Official Gnome 3 Sales Rep. (and Adminstrator)
 
Join Date: Jul 2011
Location: Leamington Spa, UK
Age: 31
Posts: 2,750
linuxfirefox
Re: Fedora 19, Black screen instead of user login screen

You could be using software rendering without hardware acceleration. If Settings->Details->Overview->Graphics mentions LLVMpipe, then you’re using software rendering.
Reply With Quote
  #17  
Old 1st August 2013, 09:05 PM
mclloyd Offline
Registered User
 
Join Date: Nov 2006
Posts: 16
windows_7firefox
Re: Fedora 19, Black screen instead of user login screen

Quote:
Originally Posted by Gareth Jones View Post
You could be using software rendering without hardware acceleration. If Settings->Details->Overview->Graphics mentions LLVMpipe, then you’re using software rendering.
It might be my problem too. I can see llvmpipe (LLVM 3.3, 128 bits) in my setup. How can I fix it?

After digging a little bit more into this I found out I do not have the xorg.conf file and cannot create one due to the "Number of created screens does not match number of detected devices" error.

Finally, I think I know what it is. My system is too old. Is there a way to disable software acceleration?

1.3.2.1. Minimum Hardware for Accelerated Desktops
Fedora 19 supports most display adapters. Modern, feature-rich desktop environments like GNOME3 and KDE Plasma Workspaces use video devices to provide 3D-accelerated desktops. Older graphics hardware may not support acceleration:
Intel prior to GMA9xx
NVIDIA prior to NV30 (GeForce FX5xxx series)
Radeon prior to R300 (Radeon 9500)

1.3.2.2. CPU Accelerated Graphics
Systems with older or no graphics acceleration devices can have accelerated desktop environments using LLVMpipe technology, which uses the CPU to render graphics. LLVMpipe requires a processor with SSE2 extensions. The extensions supported by your processor are listed in the flags: section of /proc/cpuinfo

Last edited by mclloyd; 1st August 2013 at 10:45 PM.
Reply With Quote
  #18  
Old 1st August 2013, 11:03 PM
Gareth Jones Offline
Official Gnome 3 Sales Rep. (and Adminstrator)
 
Join Date: Jul 2011
Location: Leamington Spa, UK
Age: 31
Posts: 2,750
linuxfirefox
Re: Fedora 19, Black screen instead of user login screen

Quote:
Originally Posted by mclloyd View Post
My system is too old. Is there a way to disable software acceleration?
If there isn’t a graphics driver available for your hardware which can accelerate the graphics, then you are stuck with software rendering—there is no alternative.

However, you can use a desktop shell which doesn’t tax the graphics system so heavily, to minimize the CPU usage by graphics. GNOME Shell (even with Classic Session in F19) and Cinnamon both use OpenGL so are out. In F18 there is the option of forced fall-back mode. Otherwise you’ll need to use an alternative desktop environment: e.g. KDE(?), MATE (fork of GNOME 2), Xfce or LXDE. Or Enlightenment, in case Dan’s reading this.
Reply With Quote
  #19  
Old 5th August 2013, 09:29 PM
mclloyd Offline
Registered User
 
Join Date: Nov 2006
Posts: 16
windows_7firefox
Re: Fedora 19, Black screen instead of user login screen

I've installed MATE, ran yum distro-sync -y, configured mate as my default session and now it works as it used to.
Reply With Quote
  #20  
Old 12th August 2013, 08:56 AM
rossman_2 Offline
Registered User
 
Join Date: Dec 2008
Posts: 57
linuxchrome
Re: Fedora 19, Black screen instead of user login screen

Quote:
Originally Posted by Colors View Post
At boot, in the Grub menu, add acpi_backlight=vendor. If ok, edit /etc/defaut/grub and rebuild grub.conf:

# grub2-mkconfig -o /boot/grub2/grub.cfg.
Tried updating to 3.10.4-300 kernel just to see if that would work out of the box. It didn't.

So I tried the above fix and lo-and-behold, it worked! Thanks for the fix!

P.S. It also worked for the 3.10.5 kernel so it must just be a necessary option now.
Reply With Quote
  #21  
Old 17th August 2013, 12:20 PM
lasj Offline
Registered User
 
Join Date: Feb 2009
Location: Denmark
Posts: 5
linuxfirefox
Re: Fedora 19, Black screen instead of user login screen

There are more issues related to blank screen and missing backlight on kernel 3.10.

On Asus Zenbook/Intel HD4000 and/or UEFI boot it is blank screen (backlight is Ok)
The issue is related to kernel bug: https://bugzilla.kernel.org/show_bug.cgi?id=59841

CSM don't work in secure boot mode on my Asus Zenbook UX32VD.
Workaround: Disable secure boot and then enable Launch CSM:
  1. Disable: Boot > Secure Boot
  2. Enable: Boot > Launch CSM.
Lars
See also: https://bugzilla.redhat.com/show_bug.cgi?id=989763
Reply With Quote
Reply

Tags
black, fedora, login, screen, user

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot login into X window(screen turn to black before login screen) yeyeming Using Fedora 5 26th February 2011 06:45 AM
Fedora 9 X broken black screen upon login larry_s Using Fedora 4 16th September 2008 02:28 AM
black screen after loading befor login screen DemonGodKid Using Fedora 3 31st May 2007 08:42 PM
fedora 5 login errors / black screen help please Lizard_king825 Using Fedora 5 27th July 2006 02:37 PM
My screen was black before user login screen pxingg Hardware & Laptops 4 22nd May 2006 04:22 PM


Current GMT-time: 05:45 (Sunday, 20-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat