Fedora Linux Support Community & Resources Center
  #1  
Old 10th June 2012, 03:31 AM
hakova Offline
Registered User
 
Join Date: Jun 2011
Posts: 56
linuxfirefox
Question unable to install/update kmod 7-2.fc17

Hi all,

An update just showed up in the apper for kmod7-2.fc17, and that was when I realized that itwasn't installed in my system. Instead I had kmod 7-1.fc17. `yum install kmod' returns:
Code:
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package kmod.x86_64 0:7-1.fc17 will be updated
---> Package kmod.x86_64 0:7-2.fc17 will be an update
--> Processing Dependency: /sbin/depmod for package: 1:kmod-nvidia-3.3.7-1.fc16.x86_64-295.53-1.fc16.1.x86_64
Package module-init-tools-3.16-5.fc17.x86_64 is obsoleted by kmod-7-1.fc17.x86_64 which is already installed
--> Finished Dependency Resolution
Error: Package: 1:kmod-nvidia-3.3.7-1.fc16.x86_64-295.53-1.fc16.1.x86_64 (installed)
           Requires: /sbin/depmod
           Removing: kmod-7-1.fc17.x86_64 (@anaconda-0)
               Not found
           Updated By: kmod-7-2.fc17.x86_64 (updates)
               Not found
           Available: module-init-tools-3.16-5.fc17.x86_64 (fedora)
               Not found
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
1:texlive-pdftex-bin-2012-svn23498.0.1.20120510_r26283.fc16.x86_64 has missing requires of libpoppler.so.18()(64bit)
1:texlive-pdftools-bin-2012-svn22859.0.1.20120510_r26283.fc16.x86_64 has missing requires of libpoppler.so.18()(64bit)
I am kind of lost and any suggestions will be greatly appreciated.
Reply With Quote
  #2  
Old 10th June 2012, 02:56 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: unable to install/update kmod 7-2.fc17

You will have to remove kmod-nvidia-3.3.7-1.fc16.x86_64-295.53-1.fc16.1.x86_64 (if you have newer kernels to boot from, of course).
Reply With Quote
  #3  
Old 10th June 2012, 05:04 PM
hakova Offline
Registered User
 
Join Date: Jun 2011
Posts: 56
linuxfirefox
Re: unable to install/update kmod 7-2.fc17

That did it, thanks. I just didin't want to do it before asking.
Reply With Quote
  #4  
Old 18th June 2012, 09:02 PM
itsjustarumour Offline
Registered User
 
Join Date: Jul 2009
Posts: 60
linuxubuntufirefox
Re: unable to install/update kmod 7-2.fc17

That did it for me too - cheers!
Reply With Quote
Reply

Tags
72fc17, install or update, kmod, unable

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't boot after update FC17 darkside Using Fedora 2 3rd June 2012 12:26 PM
Fresh FC17 Install : gnome_control_control-center-3.4.2-1.fc17.i686 CORE DUMP reflex Installation, Upgrades and Live Media 1 2nd June 2012 03:05 AM
Installer doesn't install bootloader, fc17 djeikyb Installation, Upgrades and Live Media 0 30th May 2012 07:21 PM
navit install on fc17 oystercatcher Guides & Solutions (No Questions) 0 29th May 2012 07:01 PM
Unable to update/re-install kmod-wl Fedora 13 Unlimited Using Fedora 8 20th September 2010 04:29 PM


Current GMT-time: 04:01 (Wednesday, 01-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat