Fedora Linux Support Community & Resources Center
  #1  
Old 5th July 2012, 01:33 PM
17twenty Offline
Registered User
 
Join Date: Jul 2012
Location: UK
Posts: 2
linuxfirefox
Can no longer use Fedora NFS to boot remote device

I have a development board connected over ethernet such that my desktop is 10.0.0.1 and my dev board is 10.0.0.3.

The remote device is set to boot from an NFS share and the kernel is told as so:
Code:
console=ttyO0,115200n8 root=/dev/nfs rw nfsroot=10.0.0.1:/home/nick/Dev/git-rootfs ip=10.0.0.3:::::eth0,nfsvers=3
I booted my desktop this morning after applying updates before shutting down last night and tried to start it all up this morning. Sadly my board hangs with the following:

Code:
[  108.951477] VFS: Unable to mount root fs via NFS, trying floppy.
[  108.958831] VFS: Cannot open root device "nfs" or unknown-block(2,0)
[  108.965606] Please append a correct "root=" boot option; here are the available partitions:
[  108.996002] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
I've checked that /etc/export hasn't been broken which reads as follows:
Code:
/home/nick/Dev/git-rootfs	*(rw,sync,no_subtree_check,no_root_squash)
but I did notice that if I try and mount the nfs share locally it also fails:

Code:
[nick@slimtop tftpboot]$ sudo mount -v  10.0.0.1:/home/nick/Dev/git-rootfs /media/
mount.nfs: timeout set for Thu Jul  5 11:06:59 2012
mount.nfs: trying text-based options 'vers=4,addr=10.0.0.1,clientaddr=10.0.0.1'
mount.nfs: mount(2): Permission denied
I can make this work by issuing:
Code:
sudo mount -v -o vers=3 10.0.0.1:/home/nick/Dev/git-rootfs /media/
But I have no idea on how to do the same to the kernel - I thought specifying the version with nfsvers would work but I can't find a changelog for the nfs-utils that would explain what's broken/changed.

Any ideas?
Reply With Quote
  #2  
Old 5th July 2012, 02:23 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,835
linuxfirefox
Re: Can no longer use Fedora NFS to boot remote device

NFS version 4 is now the default, but your only supports v3 I think. Not clear why you get permission denied.

According to the kernel docs, the nfs options go on the nfsroot= parameter, not the ip= one.
Like this ...

Quote:
console=ttyO0,115200n8 root=/dev/nfs rw nfsroot=10.0.0.1:/home/nick/Dev/git-rootfs,nfsver=3 ip=10.0.0.3:::::eth0
So I imagine the kernel is trying to mount nfsv4 and failing b/c you didn't spec the version correctly.


Maybe try the nfsrootdebug kernel parameter too if the above fails to help.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #3  
Old 5th July 2012, 06:45 PM
17twenty Offline
Registered User
 
Join Date: Jul 2012
Location: UK
Posts: 2
linuxfirefox
Re: Can no longer use Fedora NFS to boot remote device

Hey Steve,

I'm not sure if that ordering made a difference but I managed to get it working with a reboot (desktop and board) and changing the boot parameters to:

Code:
console=ttyO0,115200n8 root=/dev/nfs rw nfsroot=10.0.0.1:/home/nick/Dev/git-rootfs,ver=3 ip=10.0.0.3:::::eth0
I also had to redisable iptables using:
Code:
systemctl stop iptables.service
systemctl disable iptables.service
Not sure if that will help anyone - I got a bit desperate as I hate wasting time on things that break for no real reason so lots of things were tried as a hail mary move!.

Thanks for the reply though - it helped me focus a bit on what it could be.
Reply With Quote
Reply

Tags
boot, device, fedora, kernel, longer, nfs, remote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Media Center Remote (MCE) (from china shop) as lirc device in Fedora 16 coozoo Hardware & Laptops 1 17th April 2012 04:34 PM
reboot and select proper boot device or insert boot device and press a key rojo2000r Installation, Upgrades and Live Media 7 1st April 2012 01:15 AM
Smtp no longer accepting remote connections. yungblood Servers & Networking 0 27th January 2010 01:48 AM
Sound no longer works after changing PCM device spfdz Hardware & Laptops 7 17th May 2006 12:13 AM


Current GMT-time: 01:54 (Saturday, 20-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat