Fedora Linux Support Community & Resources Center
  #46  
Old 24th December 2016, 12:21 PM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxfedorafirefox
Re: F25: nVidia M2000M kmod driver

Unfortunately, even with the 4.8.15 version installed, it still picks the former version.
Also, when I search for the 4.8.14 directories:

ls /lib/modules/4.8.14-300.fc25.x86_64/source
/lib/modules/4.8.14-300.fc25.x86_64/source
[huub@Klerksdorp ~]$ ls -l /lib/modules/4.8.14-300.fc25.x86_64/source
lrwxrwxrwx. 1 root root 5 Dec 12 17:49 /lib/modules/4.8.14-300.fc25.x86_64/source -> build
[huub@Klerksdorp ~]$ ls -l /lib/modules/4.8.14-300.fc25.x86_64/build
lrwxrwxrwx. 1 root root 39 Dec 12 17:49 /lib/modules/4.8.14-300.fc25.x86_64/build -> /usr/src/kernels/4.8.14-300.fc25.x86_64
[huub@Klerksdorp ~]$ ls -l /usr/src/kernels/4.8.14-300.fc25.x86_64+debug/

Also, for 4.8.15, I find this:

ls -l /lib/modules/4.8.15-300.fc25.x86_64/source
lrwxrwxrwx. 1 root root 5 Dec 16 00:29 /lib/modules/4.8.15-300.fc25.x86_64/source -> build
[huub@Klerksdorp ~]$ ls -l /lib/modules/4.8.15-300.fc25.x86_64/build
lrwxrwxrwx. 1 root root 39 Dec 16 00:29 /lib/modules/4.8.15-300.fc25.x86_64/build -> /usr/src/kernels/4.8.15-300.fc25.x86_64
[huub@Klerksdorp ~]$ ls -l /usr/src/kernels/4.8.15-300.fc25.x86_64
4.8.15-300.fc25.x86_64/ 4.8.15-300.fc25.x86_64+debug/

Why doesn't the script take the correct one?
Reply With Quote
  #47  
Old 24th December 2016, 03:12 PM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 616
windows_98_nt_2000chrome
Talking Re: F25: nVidia M2000M kmod driver

I decided to build nvidia -v 375.26 driver myself. And tune my system to have ONLY one (latest) kernel: 4.8.15-300.fc25.x86_64 in both forms: normal and debug, with all headers.

Please, could you provide to me pointers which www page for the driver you are using, so I can be in sync with you and this development?

Thank you,
_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
  #48  
Old 24th December 2016, 03:27 PM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxfedorafirefox
Re: F25: nVidia M2000M kmod driver

Quote:
Originally Posted by nobody View Post
I decided to build nvidia -v 375.26 driver myself. And tune my system to have ONLY one (latest) kernel: 4.8.15-300.fc25.x86_64 in both forms: normal and debug, with all headers.

Please, could you provide to me pointers which www page for the driver you are using, so I can be in sync with you and this development?

Thank you,
_nobody_
The official download page: http://www.nvidia.com/download/drive...x/112992/en-us selected by criterium Quadro M2000M.

Another thing is that, although the driver has the dkms status "added" instead of "installed", the menu item NVIDIA X Server Settings is present. After running "nvidia-xconfig" as root, it complains that it can't find xorg server but if does create the xonf.conf file in /etc/X11. As long as the xorg.conf is there, graphics won't start. Renamed to e.g. xonf.conf.nv, graphics at once starts.
Reply With Quote
  #49  
Old 24th December 2016, 08:02 PM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxfedorafirefox
Re: F25: nVidia M2000M kmod driver

Did another reboot, reinstalled nvidia v. 26 and see:

dkms status
nvidia, 375.26, 4.8.15-300.fc25.x86_64, x86_64: installed

only thing that failed was:

ERROR: Unable to load the 'nvidia-drm' kernel module.

Apart from this success: still on 800x600 mode.

xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
800x600 75.00*

While I know that full HD is possible and I'll probably have to wait for Intel.

Last edited by hvniekerk; 24th December 2016 at 08:15 PM.
Reply With Quote
  #50  
Old 24th December 2016, 09:16 PM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 616
windows_98_nt_2000chrome
Talking Re: F25: nVidia M2000M kmod driver

Hello hvniekerk,

I completely broke complete Fedora 25 VM on my PC, while trying to install Nvidia 375.26...

I de-install EVERYTHING I could, but still, I am not able to get rid of damned nvidia... I even de-installed xorg (complete), but it does NOT allow me to reinstall it back!

Now... I need help! So, please, be patient until I restore the state of my F25 VM machine, since I am in deep sh@t (S.H.I.T), now.

If you do not break it, you do not learn.

_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
  #51  
Old 25th December 2016, 07:33 AM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxubuntufirefox
Re: F25: nVidia M2000M kmod driver

Quote:
Originally Posted by nobody View Post
Hello hvniekerk,

I completely broke complete Fedora 25 VM on my PC, while trying to install Nvidia 375.26...

I de-install EVERYTHING I could, but still, I am not able to get rid of damned nvidia... I even de-installed xorg (complete), but it does NOT allow me to reinstall it back!

Now... I need help! So, please, be patient until I restore the state of my F25 VM machine, since I am in deep sh@t (S.H.I.T), now.
Good luck

Quote:
If you do not break it, you do not learn.
Had a learning occasion myself: I installed xfce, and found out that my login was f@cked up and let me with a vague error lading back to an old unfixed(?) bug. Deinstalling xfce led to auto-removing of lots of packages that weren't installed by xfce. So I had to carefully reinstall and test a lot. Some still mysteriously don't work, but 90% is ok again now. YUCK.
Reply With Quote
  #52  
Old 25th December 2016, 11:30 AM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 616
windows_98_nt_2000chrome
Talking Re: F25: nVidia M2000M kmod driver

Quote:
Originally Posted by hvniekerk View Post
Had a learning occasion myself: I installed xfce, and found out that my login was f@cked up and let me with a vague error lading back to an old unfixed(?) bug. Deinstalling xfce led to auto-removing of lots of packages that weren't installed by xfce. So I had to carefully reinstall and test a lot. Some still mysteriously don't work, but 90% is ok again now. YUCK.
YUCK, F@CK... Saved by the bell (still I was damn all cool and patient)!

http://www.forums.fedoraforum.org/sh...d.php?t=312741

_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
  #53  
Old 25th December 2016, 11:43 AM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxubuntufirefox
Re: F25: nVidia M2000M kmod driver

In the process I also find out that OpenGL and nVidia Optimus likely don't go together unless you use nouveau of bumblebee !? Info is from F23. but I assume it's still true.
Reply With Quote
  #54  
Old 5th January 2017, 07:47 AM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxubuntufirefox
Re: F25: nVidia M2000M kmod driver

It remains strange to me: dkms status reports that the nvidia driver is installed but th NVIDIA X Server Settings tool reports:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file and restart the X server.

However, I'm using LXDE which doesn't use xorg.conf. So how should I invoke or start using the NVIDIA driver?

I also found this:

$ inxi -xG
Graphics: Card-1: Intel HD Graphics 530 bus-ID: 00:02.0
Card-2: NVIDIA GM107GLM [Quadro M2000M] bus-ID: 01:00.0
Display Server: Fedora X.org 119 drivers: fbdev,intel (unloaded: modesetting,vesa)
Resolution: 800x600@75.00hz
GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Reply With Quote
  #55  
Old 5th January 2017, 05:08 PM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 616
windows_98_nt_2000chrome
Question Re: F25: nVidia M2000M kmod driver

hvniekerk, after what I have read here, you should try to install GNOME (also), and try to use Nvidia with Gnome (on Xserver, also on Wayland). And see if this will work in conjunction with your Nvidia driver?!

_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
  #56  
Old 5th January 2017, 07:18 PM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxubuntufirefox
Re: F25: nVidia M2000M kmod driver

Quote:
Originally Posted by nobody View Post
hvniekerk, after what I have read here, you should try to install GNOME (also), and try to use Nvidia with Gnome (on Xserver, also on Wayland). And see if this will work in conjunction with your Nvidia driver?!

_nobody_
And this has lead to the infamous "Oh no, something has gone wrong" login error. Putting xorg.conf back into /etc/X11 again causes X to fail/ Sigh. On to the next problem solving.
Reply With Quote
  #57  
Old 6th January 2017, 12:40 PM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxubuntufirefox
Re: F25: nVidia M2000M kmod driver

I also installed the MATE desktop for test and I can login. However, still the 800x600 resolution and putting xorg.conf in place ruins the graphics again. Apart from that, I didn't find a solution for the GNOME login problem that works for me, so I'm inclined to remove GNOME.
Reply With Quote
  #58  
Old 10th January 2017, 03:34 PM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxubuntufirefox
Re: F25: nVidia M2000M kmod driver

Update: I managed to install AND login into gnome. When trying to set the display resolution, it reported Unknown Display, Aspect Ratio 4:3, Resolution 800x600 (4:3).
I already put a question at 01.org (Intel Graphics Update Tool forum) when it will be released for F25. This is really annoying.

Update: from the Intel forum comes info that the Intel driver would not be to blame since the latest Intel 530 driver is already in the F25 kernel. What would be to blame is the cause of "ERROR: Unable to load the 'nvidia-drm' kernel module" with which the nVidia installation ends. Suggested is that the secure boot is to blame.

Last edited by hvniekerk; 10th January 2017 at 07:40 PM. Reason: Update
Reply With Quote
  #59  
Old 6th March 2017, 08:42 PM
hvniekerk Offline
Registered User
 
Join Date: Mar 2006
Posts: 243
linuxubuntufirefox
Re: F25: nVidia M2000M kmod driver

I found the solution (for now)...

after "quiet splash", add "nouveau.modeset=0". Now I have full HD: 1920x1080. For this, I had to reinstall nouveau. But then again, the nvidia driver never showed working although it was fully installed. So I might just uninstall it.
Reply With Quote
  #60  
Old 7th March 2017, 09:23 AM
nobody Offline
Registered User
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 616
windows_98_nt_2000chrome
Thumbs up Re: F25: nVidia M2000M kmod driver

Quote:
Originally Posted by hvniekerk View Post
I found the solution (for now)...

after "quiet splash", add "nouveau.modeset=0". Now I have full HD: 1920x1080. For this, I had to reinstall nouveau. But then again, the nvidia driver never showed working although it was fully installed. So I might just uninstall it.
Hello hvniekerk,

I almost forgot about this thread... Good that you solved this problem.

Could you, please, do me a favor? Could you post for me your Xorg.0.log file for inspection, AFTER adding nouveau.modeset=0 option in kernel command line (BEFORE de-installing proprietary Nvidia driver)?

Thank you,
_nobody_
__________________
I am nobody, and nobody is perfect, therefore I am perfect!
Reply With Quote
Reply

Tags
driver, f25, kmod, m2000m, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Driver (kmod-nvidia or akmod-nvidia) not working on GT555M soumen Hardware & Laptops 3 29th January 2012 01:28 PM
kmod nvidia driver quad-sli Smokemare Hardware & Laptops 6 9th March 2008 06:53 PM
NV driver and kmod-nvidia coyoteboy Using Fedora 2 2nd September 2007 01:28 PM
FC6 And Kmod-nvidia-legacy Driver oll EOL (End Of Life) Versions 3 1st December 2006 11:54 AM
Is it necessary to install kmod-nvidia driver? shawnrgr Using Fedora 3 11th April 2006 01:33 PM


Current GMT-time: 07:39 (Saturday, 25-03-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat