Fedora Linux Support Community & Resources Center
  #1  
Old 20th June 2010, 06:39 PM
chris53 Offline
Registered User
 
Join Date: Jun 2010
Posts: 4
linuxfedorafirefox
updater issues and yum issues

Another fairly newb here. The issue is the updater and yum. I'm using fed13 64 bit on one puter and fed13 32 on another. The updater isn't working on either. This happened at about the same time.
it says
[root@Fed13 Christopher]# yum update
Loaded plugins: presto, refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: InstallMedia. Please verify its path and try again
in terminal.
it says
Error Type: <type 'exceptions.ValueError'>
Error Value: invalid literal for int() with base 10: 'ALL'
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3398, in <module>
main()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3395, in main
backend.dispatcher(sys.argv[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 723, in dispatcher
self.dispatch_command(args[0], args[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 606, in dispatch_command
self.get_distro_upgrades()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2482, in get_distro_upgrades
self._check_init()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2971, in _check_init
root = self.yumbase._media_find_root(repo.mediaid)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3301, in _media_find_root
disc_number_tmp = int(lines[3].strip())
in gui

anyone else get this issue? I'm learning on the fly about linux, so help would be awesome.
Reply With Quote
  #2  
Old 20th June 2010, 07:32 PM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,549
linuxfedorafirefox
Re: updater issues and yum issues

Hello chris53,

I would try it with that InstallMedia repo disabled...
Code:
su
yum --disablerepo=InstallMedia update
If that works to update the system, then maybe your front-end will work after that. It's happened before anyway. Then I would permanently disable the InstallMedia repo. You don't need that enabled for updates.
Reply With Quote
  #3  
Old 21st June 2010, 05:40 AM
chris53 Offline
Registered User
 
Join Date: Jun 2010
Posts: 4
linuxfedorafirefox
Re: updater issues and yum issues

ty for that. now I get this in the gui...

Error Type: <type 'exceptions.ValueError'>
Error Value: invalid literal for int() with base 10: 'ALL'
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3398, in <module>
main()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3395, in main
backend.dispatcher(sys.argv[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 723, in dispatcher
self.dispatch_command(args[0], args[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 610, in dispatch_command
self.get_updates(filters)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2547, in get_updates
self._check_init()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2971, in _check_init
root = self.yumbase._media_find_root(repo.mediaid)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3301, in _media_find_root
disc_number_tmp = int(lines[3].strip())
thats fior updater, I get this for pakage installer

Error Type: <type 'exceptions.ValueError'>
Error Value: invalid literal for int() with base 10: 'ALL'
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3398, in <module>
main()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3395, in main
backend.dispatcher(sys.argv[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 723, in dispatcher
self.dispatch_command(args[0], args[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 593, in dispatch_command
self.get_repo_list(filters)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2669, in get_repo_list
self._check_init()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2971, in _check_init
root = self.yumbase._media_find_root(repo.mediaid)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3301, in _media_find_root
disc_number_tmp = int(lines[3].strip())
which looks the same to me.

in terminal I get
[root@Fed13 Christopher]# yum update
Loaded plugins: presto, refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: InstallMedia. Please verify its path and try again
[root@Fed13 Christopher]#
I've seen this before on other posts, but I haven't found a cure yet. I'm terminal dysfunctional still and rely on what I learn here.
Reply With Quote
  #4  
Old 21st June 2010, 06:44 AM
CSchwangler Offline
Registered User
 
Join Date: Feb 2009
Posts: 2,747
linuxfedorafirefox
Re: updater issues and yum issues

Can you try in a terminal as root

Quote:
yum clean all
yum --disablerepo=InstallMedia update
Reply With Quote
  #5  
Old 21st June 2010, 09:04 AM
glennzo Offline
Un-Retired Administrator
 
Join Date: Mar 2004
Location: In your closet
Posts: 15,520
linuxfedorafirefox
Re: updater issues and yum issues

Looking at the Bugzilla reports specific to yum it appears that you can add, to the bottom of the repo file, skip_if_unavailable=True. This will skip this repo if there is no disk inserted or if the repo is otherwise not available. Might be worth a try. Open a terminal and type
Code:
su -c nano /etc/yum.repos.d/InstallMedia.repo'
Add that line to the bottom of the file
Code:
skip_if_unavailable=True
Save and exit. Try yum again.
__________________
Glenn
The Bassinator
© ®
Reply With Quote
  #6  
Old 21st June 2010, 06:06 PM
chris53 Offline
Registered User
 
Join Date: Jun 2010
Posts: 4
linuxfedorafirefox
Re: updater issues and yum issues

this is what I get on term as root.

[root@Fed13 Christopher]# -c nano /etc/yum.repos.d/InstallMedia.repo
Command not found. The transaction failed: internal-error, Error Type: <type 'exceptions.ValueError'>
Error Value: invalid literal for int() with base 10: 'ALL'
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3398, in <module>
main()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3395, in main
backend.dispatcher(sys.argv[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 723, in dispatcher
self.dispatch_command(args[0], args[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 662, in dispatch_command
self.search_file(options, values)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 726, in search_file
self._check_init(lazy_cache=True)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2971, in _check_init
root = self.yumbase._media_find_root(repo.mediaid)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3301, in _media_find_root
disc_number_tmp = int(lines[3].strip())

[root@Fed13 Christopher]#

I tried both suggestions here but the only change is that now the package manager doesn't work either. I have reinstalled twice now in the last 2 days. After a fresh install, it works ok, but after an update it fails.
Reply With Quote
  #7  
Old 22nd June 2010, 07:29 AM
CSchwangler Offline
Registered User
 
Join Date: Feb 2009
Posts: 2,747
linuxfedorafirefox
Re: updater issues and yum issues

Could you please enter the commands exactly as they are posted.

This is your command:

Quote:
[root@Fed13 Christopher]# -c nano /etc/yum.repos.d/InstallMedia.repo
and this is how glennzo posted it:

Quote:
su -c nano /etc/yum.repos.d/InstallMedia.repo'
Reply With Quote
  #8  
Old 22nd June 2010, 07:35 AM
forkbomb Offline
Registered User
 
Join Date: May 2007
Location: U.S.
Posts: 4,851
linuxfirefox
Re: updater issues and yum issues

Glenn also omitted an opening apostrophe.

Code:
su -c 'nano /etc/yum.repos.d/InstallMedia.repo'
If it were my rodeo I'd disable the InstallMedia repo entirely. Once your system is up to date yum won't care about what's on the disks because what's in the online repository mirrors will be far newer anyway.
__________________
- Tom
"What is freedom? To have the will to be responsible for one's self." - Stirner
Reply With Quote
  #9  
Old 22nd June 2010, 08:36 AM
glennzo Offline
Un-Retired Administrator
 
Join Date: Mar 2004
Location: In your closet
Posts: 15,520
linuxfedorafirefox
Re: updater issues and yum issues

Quote:
Originally Posted by forkbomb View Post
Glenn also omitted an opening apostrophe.

Code:
su -c 'nano /etc/yum.repos.d/InstallMedia.repo'
If it were my rodeo I'd disable the InstallMedia repo entirely. Once your system is up to date yum won't care about what's on the disks because what's in the online repository mirrors will be far newer anyway.
Dang! I hate typos! My bad.

I agree with you Forkbomb. Disable and / or get rid of the thing entirely. However, I think I recall seeing a comment or two about how this repo reproduces itself under certain circumstances so it may not be as simple to get rid of as you would think.
__________________
Glenn
The Bassinator
© ®
Reply With Quote
  #10  
Old 22nd June 2010, 02:11 PM
forkbomb Offline
Registered User
 
Join Date: May 2007
Location: U.S.
Posts: 4,851
linuxfirefox
Re: updater issues and yum issues

Oh. I didn't know that. I'm sure the FP says that that's a "feature."
__________________
- Tom
"What is freedom? To have the will to be responsible for one's self." - Stirner
Reply With Quote
  #11  
Old 22nd June 2010, 09:41 PM
matknny
Guest
 
Posts: n/a
windows_7safari
Re: updater issues and yum issues

I have a issue where the update is extremely slow. Using Fedora 13 x86_64 fresh installed. Is anyone else having trouble updating?
Reply With Quote
  #12  
Old 23rd June 2010, 07:02 AM
CSchwangler Offline
Registered User
 
Join Date: Feb 2009
Posts: 2,747
linuxfedorafirefox
Re: updater issues and yum issues

Quote:
Originally Posted by matknny View Post
I have a issue where the update is extremely slow. Using Fedora 13 x86_64 fresh installed. Is anyone else having trouble updating?
Maybe its a mirror problem? Did you install the fastestmirror plugin for yum? I don't have any problems with mirror speed at the moment.
Reply With Quote
  #13  
Old 23rd June 2010, 11:36 AM
matknny
Guest
 
Posts: n/a
linuxsafari
Re: updater issues and yum issues

Quote:
Originally Posted by CSchwangler View Post
Did you install the fastestmirror plugin for yum?
It help a little. Think I found the problem though, my new computer has a Atheros wireless chip . Always had problems with them.
Reply With Quote
Reply

Tags
issues, updater, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Two different issues bendib Using Fedora 7 20th November 2009 06:59 AM
Help please with yum issues njpcX Using Fedora 1 16th November 2009 06:58 PM
fedora 9 issues - nVIDIA issues. Help please! pinoyboy Using Fedora 8 12th June 2008 11:04 AM
software updater having issues. keeler1 Using Fedora 4 16th March 2007 05:48 AM
My FC6 T3 Issues Sarthan Using Fedora 2 6th October 2006 03:48 PM


Current GMT-time: 19:31 (Saturday, 27-05-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat