Fedora Linux Support Community & Resources Center
  #1  
Old 23rd February 2012, 09:24 PM
jakebpg Offline
Registered User
 
Join Date: Feb 2009
Location: Northeast
Posts: 292
linuxfirefox
Unhappy Samba NOT working

Has any one gotten samba working?
I can't log into SWAT. All of the typical samba services are running smb,nmb and xinetd.
I can't even run system-config-samba from the menu but it does run if I start it from a terminal but it shows errors when doing so.
here's the error as shown in the terminal:
WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

I'm using the KDE spin from a couple of nights ago.

Is this a bug that needs to be reported?

Swap is enabled, selinux is enabled with all samba bolleeans set to allow samba communication and the firewall is set to allow samba through.

Stumped!!
Reply With Quote
  #2  
Old 25th February 2012, 09:26 AM
EvilRedHorse Offline
Registered User
 
Join Date: Feb 2012
Location: London, Ontario, Canada
Posts: 32
windows_7firefox
Re: Samba NOT working

yum -y install samba samba-common samba-client samba-windbind-clients
systemctl enable smb.service
systemctl enable nmb.service

# samba-swat is really not needed if you are familiar with smb.conf
yum -y remove samba-swat

# edit your /etc/samba/smb.conf file appropriately or post it so someone can analyze it.
vi /etc/samba/smb.conf
# or
nano /etc/samba/smb.conf

# restart daemons
systemctl restart smb.service
systemctl restart nmb.service
Reply With Quote
  #3  
Old 25th February 2012, 07:31 PM
jakebpg Offline
Registered User
 
Join Date: Feb 2009
Location: Northeast
Posts: 292
linuxfirefox
Re: Samba NOT working

Already have all the stuff. See my original post. SMB, NMB are running and all selinux stuff is set to allow smaba to work.
Quote:
Originally Posted by EvilRedHorse View Post
yum -y install samba samba-common samba-client samba-windbind-clients
systemctl enable smb.service
systemctl enable nmb.service

# samba-swat is really not needed if you are familiar with smb.conf
yum -y remove samba-swat

# edit your /etc/samba/smb.conf file appropriately or post it so someone can analyze it.
vi /etc/samba/smb.conf
# or
nano /etc/samba/smb.conf

# restart daemons
systemctl restart smb.service
systemctl restart nmb.service
Already have all the stuff. See my original post. SMB, NMB are running and all selinux stuff is set to allow smaba to work.

I know swat is not needed but it makes things simple. Did you see the rror that I mentioned.?

Even after reinstalling all of the samba software I still get the same errors!

Thanks anyhow.
Reply With Quote
  #4  
Old 25th February 2012, 09:38 PM
EvilRedHorse Offline
Registered User
 
Join Date: Feb 2012
Location: London, Ontario, Canada
Posts: 32
windows_7firefox
Re: Samba NOT working

Can you post your smb.conf file, please?
Reply With Quote
  #5  
Old 25th February 2012, 10:04 PM
jakebpg Offline
Registered User
 
Join Date: Feb 2009
Location: Northeast
Posts: 292
linuxfirefox
Re: Samba NOT working

Quote:
Originally Posted by EvilRedHorse View Post
Can you post your smb.conf file, please?
Well I can but that will not correct the errors that are listed in my original post.

Just an FYI.
Workgroup = xxxx = my domain.
testx = my home directory.

Oh and I did create a bug report on the errors.
Attached Files
File Type: conf smb.conf (11.3 KB, 154 views)
Reply With Quote
  #6  
Old 25th February 2012, 10:18 PM
EvilRedHorse Offline
Registered User
 
Join Date: Feb 2012
Location: London, Ontario, Canada
Posts: 32
windows_7firefox
Re: Samba NOT working

# have you opened tcp port 901 for swat?
# This is my smb.conf
[global]
workgroup = MSHOME
server string = Samba Server Version %v
force user = smc
force group = smc
force create mode = 0755
follow symlinks = yes
netbios name = F16Server
interfaces = lo eth0 192.168.1.105/24
hosts allow = 127. 192.168. 169.254.
log file = /var/log/samba/log.%m
max log size = 50
security = share
passdb backend = smbpasswd
domain master = yes
local master = yes
os level = 65
preferred master = yes
wins support = yes
; wins server = 192.168.1.95
wins proxy = yes
dns proxy = yes
load printers = yes
cups options = raw

[home]
path = /home
comment = Home Directories
browseable = yes
writable = yes
public = yes

[printers]
comment = All Printers
path = /var/spool/samba
browseable = yes
guest ok = yes
writable = yes
printable = yes
Reply With Quote
  #7  
Old 25th February 2012, 11:22 PM
jakebpg Offline
Registered User
 
Join Date: Feb 2009
Location: Northeast
Posts: 292
linuxfirefox
Re: Samba NOT working

Quote:
Originally Posted by EvilRedHorse View Post
# have you opened tcp port 901 for swat?
# This is my smb.conf
[global]
workgroup = MSHOME
server string = Samba Server Version %v
force user = smc
force group = smc
force create mode = 0755
follow symlinks = yes
netbios name = F16Server
interfaces = lo eth0 192.168.1.105/24
hosts allow = 127. 192.168. 169.254.
log file = /var/log/samba/log.%m
max log size = 50
security = share
passdb backend = smbpasswd
domain master = yes
local master = yes
os level = 65
preferred master = yes
wins support = yes
; wins server = 192.168.1.95
wins proxy = yes
dns proxy = yes
load printers = yes
cups options = raw

[home]
path = /home
comment = Home Directories
browseable = yes
writable = yes
public = yes

[printers]
comment = All Printers
path = /var/spool/samba
browseable = yes
guest ok = yes
writable = yes
printable = yes
Yes it is open. I believe that the error has a lot to do with the error in my first post. When I run testparm everything is OK.

That's why I was wondering if anyone else was able to get samba working.

I've had samba working on all of my fedora machines way back to F12. In fact in F12 samba was my domain controller with homes directories created on the fly, roaming profiles, you name it, samba did it. But for some reason samba just doesn't want to cooperate unless it really isn't a samba problem at all and is something in the underlying system that is causing the problem, hence the posted error I mentioned and submitted as a bug.

I run the KDE desktop as Gnome is garbage in my opinion, always has been and always will be. I don't even think the desktop that I liked the most is even around, it was in the second release of redhat way before they became RHEL. I think the version was like 2. something. Now I'm just dating myself with that last tidbit. I use to buy the box set every new release. The last release I bought was redhat 6 and that was before RHEL.

Last edited by jakebpg; 25th February 2012 at 11:57 PM. Reason: Yes it is open. I believe that the error has a lot to do with the error in my first post
Reply With Quote
  #8  
Old 27th February 2012, 10:37 PM
jakebpg Offline
Registered User
 
Join Date: Feb 2009
Location: Northeast
Posts: 292
linuxfirefox
Smile Re: Samba NOT working

This problem was fixed by installing:
Kernel 3.3.0-0.rc5.git0.3.fc17.x86_64 from koji.

However, the error that I posted still exists but at least samba is up and running!

And this was the only change to the system. I tried many things from reinstalling samba, removing samba and reinstalling again and to no avail samba just would NOT be available.
I installed this new kernel, rebooted and samba works.

Only problem is it's back to configuring samba the hard way, through a text editor!
Reply With Quote
  #9  
Old 26th May 2012, 02:44 PM
lmcogs Offline
Registered User
 
Join Date: Dec 2007
Posts: 249
linuxfirefox
Re: Samba NOT working

Although a few months after the last reply, I am in th same boat. I have 3.3.7-1.fc17.x86_64 on Kde. No matter what I try I can't seem to get samba share recognise by my asus O!play. I can ping it's address and telnet to O!player but no matter what I try I can't get samba share up on player.

sudo smbclient -U leonc -L localhost
Enter leonc's password:
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.5-86.fc17]

Sharename Type Comment
--------- ---- -------
Shares Disk
IPC$ IPC IPC Service (localhost.localdomain)
leonc Printer Home Directories
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.5-86.fc17]

Server Comment
--------- -------
LOCALHOST localhost.localdomain

Workgroup Master
--------- -------
WORKGROUP

I have selinux on permissive mode and I have even done sudo setsebool -P samba_export_all_rw on. I have tried selinux off.


sudo testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[HOMES]"
Processing section "[Shares]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
server string = localhost.localdomain
smb passwd file = /etc/samba/smbpasswd
username map = /etc/samba/smbusers
log file = /var/log/samba/log.%m
max log size = 50
name resolve order = bcast hosts lmhosts wins
load printers = No
local master = No
idmap config * : backend = tdb
cups options = raw

[HOMES]
comment = Home Directories
valid users = %S
read only = No
printable = Yes
print ok = Yes
browseable = No

[Shares]
path = /disk/
valid users = %S

Is there anything I can do. I had it up on f16, unfortunatley disk crashed.
Reply With Quote
  #10  
Old 27th May 2012, 11:20 PM
lmcogs Offline
Registered User
 
Join Date: Dec 2007
Posts: 249
linuxfirefox
Re: Samba NOT working

In my case it is firewalld. When I stopped firewalld Samba worked. I don't know how to allow samba ports in firewalld or set rules, instructions are a bit unclear. I am also a bit confused is firewalld going to be in f17 or will it use iptables and if not should I remove it?
Reply With Quote
  #11  
Old 28th May 2012, 09:10 AM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,368
linuxopera
Re: Samba NOT working

Hello lmcogs

There's been some talk of "firewalld" on the forum centered on the lack of a gui configuration tool and whether it is going to be the default in F17.

I'm using samba on a couple of F17 machines at the moment with firewalld and so I can tell you that the command line way to enable samba with firewalld is:

Code:
firewall-cmd --add --service=samba
Hope that helps.
Reply With Quote
  #12  
Old 28th May 2012, 12:59 PM
lmcogs Offline
Registered User
 
Join Date: Dec 2007
Posts: 249
linuxfirefox
Re: Samba NOT working

thanks that did the trick
Reply With Quote
  #13  
Old 29th May 2012, 06:14 AM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,204
linuxfirefox
Re: Samba NOT working

note, you'll only have firewalld if you installed from F17 Alpha or Beta (or a nightly around that time). Shortly after Beta, we switched back to iptables by default.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
Reply

Tags
samba, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA not working quovadisnp Servers & Networking 2 13th October 2011 08:38 PM
Samba Not Working davidedwardgill Using Fedora 1 20th August 2007 10:20 PM
Samba not working OralDeckard Servers & Networking 10 19th January 2007 09:29 PM
Samba Not Working notorious Servers & Networking 16 5th June 2005 05:15 AM
samba was working, now its not, please help rayber2000 Servers & Networking 10 1st March 2005 03:56 AM


Current GMT-time: 21:13 (Monday, 20-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Elizabethtown - Adirampattinam Photos on Instagram - Sunrise Travel Photos