Fedora Linux Support Community & Resources Center
  #1  
Old 6th December 2009, 04:24 AM
pranasblk Offline
Registered User
 
Join Date: Sep 2009
Posts: 16
linuxfedorafirefox
Question Ldoce4

I want use LDOCE4 program from Pearson Longman, but getting error during start-up:

./ldoce4-bin: error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory

Searched for problem solutions and found only for Ubuntu by installing GTK-1.2 ...

Is is possible to install GTK-1.2 on FC12? How?

Thanks
Reply With Quote
  #2  
Old 13th December 2009, 04:17 AM
tashirosgt Offline
Registered User
 
Join Date: Aug 2004
Posts: 3,963
linuxfedorafirefox
You could look for an rpm for it on rpm.pbone.net. I think you can install it, but it might not be wise to install it since the installation might make links to it that would cause programs other than LDOCE4 to use it.

We need an gtk expert to explain the current status of the libraries. On my FC12, I have libraries named libgtk-vnc, libgtk-x11, libgtkhtml etc. but no plain libgtk.
__________________
"Never let the task you are trying to accomplish distract you from the study of computers."
Reply With Quote
  #3  
Old 28th March 2010, 01:38 AM
lovenemesis Offline
Registered User
 
Join Date: Apr 2008
Location: Leeds, UK
Posts: 305
linuxmozilla
Re: Ldoce4

Of course you can have gtk in Fedora 12.

Code:
su -c 'yum install gtk+'
Most of the cases when someone claims fedora does not have package while ubuntu has is caused by the different package naming conventions.
__________________
Fedora Ambassador & Translator
Editor of LinuxTOY
Smolts Profile


Take a Deep Breath out of Windows
Reply With Quote
  #4  
Old 28th March 2010, 03:13 AM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,515
linuxopera
Re: Ldoce4

Yes, but if the package is written for Ubuntu/Debian, at times, one has to symlink libraries to the new name. At any rate, one way to find out exactly what you need is to use the provides option

yum provides */ libgtk-1.2.so.0

In this case, lovenemesis has given the answer, but it's a handy option to have for future reference.
Reply With Quote
  #5  
Old 3rd April 2012, 11:57 AM
pahlevanzadeh Offline
Registered User
 
Join Date: Apr 2012
Location: Tehran, Iran
Posts: 1
linuxfirefox
Re: Ldoce4

Hi ,
I solved it without installing this library.
Please create a file in /etc/ld.so.conf.d/ directory such as /etc/ld.so.conf.d/ldoce5.conf
put path of your ldoce5 in above file, then run as super user:
Code:
ldconfig -v
Then restart your compouter, Your problem will be solved!!!
Reply With Quote
Reply

Tags
ldoce4

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Current GMT-time: 16:18 (Wednesday, 01-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat