Fedora Linux Support Community & Resources Center
  #1  
Old 12th October 2009, 08:12 PM
Jongi Offline
Registered User
 
Join Date: Oct 2005
Posts: 1,952
linuxdebianmozilla
initramfs created instead of initrd - can't boot new kernel

I have the following grub.conf

Code:
default=0
timeout=5
splashimage=(hd0,13)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31.1-56.fc12.x86_64)
	root (hd0,13)
	kernel /boot/vmlinuz-2.6.31.1-56.fc12.x86_64 ro root=UUID=887364f0-20ea-4439-b3db-88df548aa180 rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /boot/initramfs-2.6.31.1-56.fc12.x86_64.img
title Fedora (2.6.31-0.125.4.2.rc5.git2.fc12.x86_64)
	root (hd0,13)
	kernel /boot/vmlinuz-2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 ro root=UUID=887364f0-20ea-4439-b3db-88df548aa180 rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /boot/initrd-2.6.31-0.125.4.2.rc5.git2.fc12.x86_64.img
The git2 kernel with initrd boots. The latest rawhide kernel does not..When I try to enter my root password the skewed messages repeat with key press.

When I try to run mkinitrd, I get the following error

Code:
# mkinitrd /boot/initrd-2.6.31.1-56.img 2.6.31.1-56
No modules available for kernel "2.6.31.1-56".
Any ideas how I can fix this?
__________________
Desktop (64-bit) - F12, Debian Sid, OpenSUSE 11.2, ArchLinux
  #2  
Old 12th October 2009, 09:02 PM
SlowJet Offline
Registered User
 
Join Date: Jan 2005
Posts: 5,048
linuxfedorafirefox
initrd has been replaced by dracut and initramfs.

reboot into older kernel with initrd.
then
rpm -e kernel 56
then yum install
dracut dracut-kernel
then yum install
perf kernel-firmware(from noarch of kernel 56.), , kernel 56, (optionally kernel-headers kernel-devel as needed)

It will take while to and you will see a couple of missing fireware messages, then another minute.

For best results, these need to be sync'd with xorg, plymouth, and your video drv also.

SJ
__________________
Do the Math

Last edited by SlowJet; 13th October 2009 at 04:14 AM.
  #3  
Old 12th October 2009, 11:00 PM
Demz
Guest
 
Posts: n/a
windows_98_nt_2000firefox
kerenl 56 typo SJ?
  #4  
Old 13th October 2009, 04:21 AM
SlowJet Offline
Registered User
 
Join Date: Jan 2005
Posts: 5,048
linuxfedorafirefox
Fixed.

<deleted>
(Never mind, they trimmed the kernel logs. )


SJ
__________________
Do the Math

Last edited by SlowJet; 13th October 2009 at 04:37 AM. Reason: Fixed spelling of kernel.
  #5  
Old 13th October 2009, 05:49 AM
Zanpactou Offline
Banned
 
Join Date: Oct 2009
Posts: 358
linuxopera
Quote:
Originally Posted by Jongi View Post
The git2 kernel with initrd boots. The latest rawhide kernel does not..When I try to enter my root password the skewed messages repeat with key press.
I know what's going on here and I think that we should collaborate in a bug report.
I also know how you can fix this.

Boot up and get to grub.
Press any key to show the menu. press e when grub appears and press the down key and then e again to edit the kernel command line. You'll see a long string that goes off to the left. Press down the left key and scroll the cursor to the left until you get to the rhgb quiet part. Now delete rhgb quiet. Press the end key and make sure that there is a space right at the end of the line and type nomodeset. Press enter.

The line should look something like this :
Code:
kernel /boot/vmlinuz-2.6.31.1-56.fc12.x86_64 ro root=UUID=887364f0-20ea-4439-b3db-88df548aa180 LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us nomodeset
Now press b.

When you are asked for your root password, you will be able to enter it without the text scroll looping.
So enter your root password and press enter. Then type fdisk -l and press enter which will list your hard disk partitions.
(Note : On my system at this point I have to press each key twice, like this : ffddiisskk --ll to input fdisk -l
but not for the password. Does that happen to you too?)
Now you can see your partitions, workout which one is your root partition and then do :
fsck /dev/sd??
(If your root partition is sda3 then change sd?? above to that. Mine is sdb2, for example.)
Again you may need to press each key twice to make the input to screen.
If you are asked to fix/repair anything press the y key (Maybe even twice.)
The check/repair will finish and you'll be back at the prompt in the shell.
Type reboot. Press enter and boot back in without modifying the command line in grub.
(You can press esc to drop plymouth down to see the output like you did in the screen shot you took to see if it boots ok.)

Good luck! (That's how I sorted mine, in fact many times so far. Especially when trying moblin, which did not work.)

Last edited by Zanpactou; 13th October 2009 at 06:09 AM. Reason: Typo...
  #6  
Old 13th October 2009, 06:14 AM
diamond_ramsey Offline
Registered User
 
Join Date: Aug 2009
Posts: 789
windows_98_nt_2000mozilla
Jongi, is this on a multi-core system? :)

Quote:
Originally Posted by Jongi View Post
I have the following grub.conf
...
The git2 kernel with initrd boots. The latest rawhide kernel does not..When I try to enter my root password the skewed messages repeat with key press.

When I try to run mkinitrd, I get the following error

Code:
# mkinitrd /boot/initrd-2.6.31.1-56.img 2.6.31.1-56
No modules available for kernel "2.6.31.1-56".
Any ideas how I can fix this?
Jongi, is this on a multi-core system?
__________________
2 dual cores, 11 GB RAM, F18 Spherical Cow - 3.11.10-100.fc18.x86_64 / i686
2 dual cores, 11 GB RAM, F19 Schrödinger's Cat - 3.14.17-100.fc19.x86_64 / i686
2 dual cores, 11 GB RAM, F20 Heisenbug - 3.15.10-200.fc20.x86_64 / i686
2 dual cores, 11 GB RAM, F21 TBD - 3.16.1-301.fc21.x86_64 / i686
80 x86_64 computing cores, 144 GB RAM & 8 SATA Seagate 7200.12 500 GB harddisks
  #7  
Old 13th October 2009, 07:56 AM
Jongi Offline
Registered User
 
Join Date: Oct 2005
Posts: 1,952
windows_xp_2003ie
So I did the following

Remove kernel 56 related packages:
Code:
yum remove kernel- 2.6.31.1-56.fc12.x86_64 kernel-headers- 2.6.31.1-56.fc12.x86_64 kernel-devel-2.6.31.1-56.fc12.x86_64 kernel-firmware-2.6.31.1-56.fc12.x86_64 perf
There were some dependency issues with trying to install dracut kernel:
Code:
yum remove dracut
Clear everything for good measure:
Code:
yum clean all
Reinstalled dracut:
Code:
yum install dracut dracut-kernel
Reinstalled kernel 56 and related packages:
Code:
yum install kernel kernel-headers kernel-devel kernel-firmware perf
As you say it takes a short while during the kernel install and shows some modules missing messages.

Reboot into new kernel. Same problem.

---------------------------

Zanpactou – I’ll try that. But why would it have that problem under the new kernel but as son as I boot into the old one it boots with out an issue (doesn’t even run fsck under the old kernel).
__________________
Desktop (64-bit) - F12, Debian Sid, OpenSUSE 11.2, ArchLinux
  #8  
Old 13th October 2009, 11:04 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Well the screenshot in post #1 is clear

give root password then run fsck to fix the superblock error

Change dev address to suit

Code:
fsck -f -y /dev/****
  #9  
Old 13th October 2009, 11:29 AM
SlowJet Offline
Registered User
 
Join Date: Jan 2005
Posts: 5,048
linuxfedorafirefox
What screenshot? Oh the one in the link labeled blah, blah blah. Show the errors plainly, please.
Liegh could have answered you 12 hours ago.

If you already had dracut installed there was no need to redo it. dah!
Just rpm -e kernel and rpm -ivh kernel and initramfs would be rebuilt.

And I did not notice it was 64 bit although it probably doesn't make any difference (Because the file system is screwed up.)
No more soup for you!

SJ
__________________
Do the Math
  #10  
Old 13th October 2009, 05:54 PM
Zanpactou Offline
Banned
 
Join Date: Oct 2009
Posts: 358
linuxopera
Quote:
Originally Posted by Jongi View Post
Zanpactou – I’ll try that. But why would it have that problem under the new kernel but as son as I boot into the old one it boots with out an issue (doesn’t even run fsck under the old kernel).
I wouldn't like to speculate at this point because I really don't know. I believe there's some problem with plymouthd and the kms settings code but that's mere speculation.

I have a much easier way to do what I said will let you do an fsck without the text scroll looping.
Just boot into the old kernel and duplicate the entry for the new kernel in /boot/grub/menu.lst so that it has no rhgb quiet and has nomodeset. Then select it when you boot. That way you can avoid the time it takes to modify grub manually. (Sorry I didn't recommend this first, I have a cold.)

So you edit /grub/menu.lst as root and change what you posted above to this :
Code:
default=0
timeout=5
splashimage=(hd0,13)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31.1-56.fc12.x86_64)
	root (hd0,13)
	kernel /boot/vmlinuz-2.6.31.1-56.fc12.x86_64 ro root=UUID=887364f0-20ea-4439-b3db-88df548aa180 rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /boot/initramfs-2.6.31.1-56.fc12.x86_64.img

title Fedora (2.6.31.1-56.fc12.x86_64) Rescue
	root (hd0,13)
	kernel /boot/vmlinuz-2.6.31.1-56.fc12.x86_64 ro root=UUID=887364f0-20ea-4439-b3db-88df548aa180 LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us nomodeset
	initrd /boot/initramfs-2.6.31.1-56.fc12.x86_64.img

title Fedora (2.6.31-0.125.4.2.rc5.git2.fc12.x86_64)
	root (hd0,13)
	kernel /boot/vmlinuz-2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 ro root=UUID=887364f0-20ea-4439-b3db-88df548aa180 rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /boot/initrd-2.6.31-0.125.4.2.rc5.git2.fc12.x86_64.img
  #11  
Old 13th October 2009, 06:06 PM
Zanpactou Offline
Banned
 
Join Date: Oct 2009
Posts: 358
linuxopera
Quote:
Originally Posted by leigh123linux View Post
Well the screenshot in post #1 is clear

give root password then run fsck to fix the superblock error

Change dev address to suit

Code:
fsck -f -y /dev/****
Hi leigh,
The problem is that when you go to press the first letter of your root password, the "Give root password" Message appears again and for every time you press a key. So it won't take input correctly and it's kind of looping. Normally the screen does not change until you input the password and press enter.
It totally prevents you from putting in your root password to get to the rescue shell.
The only way round it here was to boot without plymouth and without kernel mode settings.
What's fustrating is that I can't use that as a default whilst testing because nomodeset means no x here. It just hangs.
It's a very strange error.
  #12  
Old 13th October 2009, 06:18 PM
Jongi Offline
Registered User
 
Join Date: Oct 2005
Posts: 1,952
linuxdebianmozilla
zanpactou - as soon as i booted (after following your instructions) the maintence mode prompt didn't even appear. like you x did not run.

slowjet - what's with the stroppiness?
__________________
Desktop (64-bit) - F12, Debian Sid, OpenSUSE 11.2, ArchLinux
  #13  
Old 9th November 2009, 01:17 AM
Zanpactou Offline
Banned
 
Join Date: Oct 2009
Posts: 358
linuxopera
@Jongi in response to your pm
I think that this problem is all fixed now with updates to plymouth, etc.
I haven't tried to reproduce the x not starting from init 3 problem recently. I probably should.
[EDIT]Yes it is fixed and so is the starting x from init 3 issue, however it pushes my install straight into a root kde desktop session instead of starting kdm and it's chooser with no auto login.
dracut is being used to generate initramfs as of Fedora 12 and it works like :
Code:
dracut [OPTION]... <image>  <kernel-version>
So like :
Code:
dracut /boot/initramfs-2.6.31.1-56.fc12.x86_64.img 2.6.31.1-56.fc12.x86_64
As root.
The only problem with using dracut like that is that I'm sure other options are supposed to be set (man dracut) So that only the modules to mount the rootfs are added. Using that produces an initramfs that takes a loooooong time to get to udev.[/EDIT]

Last edited by Zanpactou; 9th November 2009 at 02:49 PM. Reason: I saw a flying monkey in the sky...
 

Tags
boot, created, initramfs, initrd, kernel

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
0 byte initrd file in kernel kernel-2.6.27.25-170.2.72.fc10.x86_64 marko Using Fedora 2 13th July 2009 08:29 PM
New kernel/initrd doesn't ask for password during boot Wilfred Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 0 31st October 2008 12:21 PM
Boot to initrd.img/vmlinuz under Windows Boot Loader Guess_Who Installation, Upgrades and Live Media 0 22nd June 2006 01:15 AM
kernel panic with initrd=initrd.img in loadlin jules Installation, Upgrades and Live Media 4 8th July 2004 11:17 AM


Current GMT-time: 19:14 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat