Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 14th May 2012, 06:41 PM
edwinexil Offline
Registered User
 
Join Date: Oct 2011
Posts: 12
linuxfirefox
Exclamation missing libcrypto.so.6, libssl.so.6 and libgnutls.so.13

Hello all, please help if you can, this is time sensitive

I am trying to update theses files Updated Packages

libssh2.i386 1.2.9-1.el5.rf rpmforge
openvpn.i386 2.2.2-1.el5.rf rpmforge
pkcs11-helper.i386 1.08-1.el5.rf rpmforge



When I run yum update I get:

Error: Package: openvpn-2.2.2-1.el5.rf.i386 (rpmforge)
Requires: libcrypto.so.6
Error: Package: pkcs11-helper-1.08-1.el5.rf.i386 (rpmforge)
Requires: libgnutls.so.13
Error: Package: pkcs11-helper-1.08-1.el5.rf.i386 (rpmforge)
Requires: libgnutls.so.13(GNUTLS_1_3)
Error: Package: openvpn-2.2.2-1.el5.rf.i386 (rpmforge)
Requires: libssl.so.6

I have tried several things to install those packages but nothing is working, I need this resolved ASAP.

uname -a
Linux localhost.localdomain 2.6.43.2-6.fc15.i686.PAE #1 SMP Sat Apr 21 13:15:51 UTC 2012 i686 i686 i386 GNU/Linux



if anything is needed or if you can help please let me know
Reply With Quote
  #2  
Old 14th May 2012, 07:14 PM
Fenrin Offline
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 894
linuxopera
Re: missing libcrypto.so.6, libssl.so.6 and libgnutls.so.13

There is not a point in using RHEL 5 repos on Fedora 15. This does not work. Remove the package rpmforge-release and use the Fedora packages. If you already installed packages from this repo, it will uninstall these as well. You should find all or most of the packages in the default Fedora repositories as well. So it should be pretty easy to reinstall these packages afterwards.
Or if you want to use RHEL, replace your Fedora with a RHEL based distro (like CentOS or Scientific Linux).

Last edited by Fenrin; 14th May 2012 at 07:16 PM.
Reply With Quote
  #3  
Old 14th May 2012, 07:23 PM
Dan Offline
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 23,250
linuxfedorafirefox
Re: missing libcrypto.so.6, libssl.so.6 and libgnutls.so.13

Moved to general support
Reply With Quote
  #4  
Old 14th May 2012, 07:34 PM
edwinexil Offline
Registered User
 
Join Date: Oct 2011
Posts: 12
linuxfirefox
Re: missing libcrypto.so.6, libssl.so.6 and libgnutls.so.13

Can you let me know how to Remove the package rpmforge-release and use the Fedora package?
Reply With Quote
  #5  
Old 14th May 2012, 07:41 PM
Fenrin Offline
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 894
linuxopera
Re: missing libcrypto.so.6, libssl.so.6 and libgnutls.so.13

ok sure to remove the rpmforge repo:
su
Code:
yum remove rpmforge-release
I think the fedora-release-15 package should be installed already. If not, you can download it from here and then install it via "yum install fedora-release-15*.rpm"

It could be that it will remove some dependency package, when you remove rpmforge-release. Afterward you have to reinstall these packages via "yum install PACKAGE1 PACKAGE2...", if you need these packages.

Last edited by Fenrin; 14th May 2012 at 07:45 PM.
Reply With Quote
Reply

Tags
libcryptoso6, libgnutlsso13, libsslso6, missing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
running neorouter, trouble with symbolic links libssl and libcrypto originalsurfmex Using Fedora 5 20th June 2010 04:36 PM
error: Failed dependencies: libcrypto.so.4 and libssl.so.4 tonjg Using Fedora 1 28th November 2009 12:24 AM
Help With AT&T VPN Installation - libssl.so.4,libcrypto.so.4,libcurl.so.3 nitinkoka Using Fedora 0 31st August 2008 05:51 PM


Current GMT-time: 13:44 (Friday, 22-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat