Fedora Linux Support Community & Resources Center
  #1  
Old 23rd April 2013, 03:01 PM
KroniKlepto Offline
Registered User
 
Join Date: Sep 2011
Posts: 3
linuxchrome
AMD driver installation problem

So, I tried installing the ATI driver on Fedora 18 and I'm stuck at step 3: Make sure radeon is removed from initramfs.

Code:
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-radeon.img
returns this error:

mv: cannot stat ‘/boot/initramfs-3.8.8-202.fc18.x86_64.img’: No such file or directory

These files are in /boot:

initramfs-3.8.1-201.fc18.x86_64.img
initramfs-3.8.2-206.fc18.x86_64.img
initramfs-3.8.8-202.fc18.x86_64-radeon.img


The reason I'm trying to install the driver is a performance downgrade after a video card upgrade. Previous card was 6850... just upgraded to 7770. With the new card, video is choppy and the card is heating up much more than it should be.

initramfs-3.8.8-202.fc18.x86_64.img does not exist.... but, I have no idea why, or how to resolve this. Help?
Reply With Quote
  #2  
Old 23rd April 2013, 05:11 PM
droidhacker Offline
Registered User
 
Join Date: Oct 2009
Posts: 827
linuxfirefox
Re: AMD driver installation problem

You'd probably be better off updating your kernel and mesa to F19 versions, which should work a lot better with your "southern islands" GPU.

However, if you insist on running the blob driver, please note that the command is failing because the FIRST time you ran it, it worked. Subsequent runs of it will not work. "mv" means "move" or "rename". The first time you ran that command, it RENAMED the file to the "-radeon" one, so its done.
Reply With Quote
  #3  
Old 23rd April 2013, 08:55 PM
KroniKlepto Offline
Registered User
 
Join Date: Sep 2011
Posts: 3
linuxchrome
Re: AMD driver installation problem

Wow, how did I not see that? Thank you.

So I completed the process, rebooted, and it hung at the Fedora logo, which looks to be fairly common. Uninstalled AMD.

Trying to take your advice on the kernel and mesa... got the kernel updated, but am having trouble with updating mesa to 9.1-6.fc19. Pulled the rpm from here, but now I'm getting a NOKEY error. Tried to force, it looked like it installed, but didn't verify.

Code:
rpm -i mesa-9.1-6.fc19.src.rpm
warning: mesa-9.1-6.fc19.src.rpm: Header V3 RSA/SHA256 Signature, key ID fb4b18e6: NOKEY

rpm -Uhv mesa-9.1-6.fc19.src.rpm
warning: mesa-9.1-6.fc19.src.rpm: Header V3 RSA/SHA256 Signature, key ID fb4b18e6: NOKEY
Updating / installing...
   1:mesa-9.1-6.fc19                  ################################# [100%]

rpm -V mesa-9.1-6.fc19.src.rpm
package mesa-9.1-6.fc19.src.rpm is not installed
glxinfo isn't very helpful, but it's showing everything is slow or none.

Code:
glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
Code:
 glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.2, 256 bits)
OpenGL version string: 2.1 Mesa 9.1
OpenGL shading language version string: 1.20
OpenGL extensions:
It looks like I've found part of the problem... but, I have no idea where to go from here.
Reply With Quote
Reply

Tags
amd, driver, installation, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 9300M G Fedora driver installation problem can't install the driver. forumero Installation, Upgrades and Live Media 2 11th February 2011 06:06 PM
Installation problem -Fedora 9 on AMD Phenom 9550 Quadcore renjithgnair Installation, Upgrades and Live Media 4 7th September 2008 11:30 AM
F8 New Installation - Driver problem satimis Installation, Upgrades and Live Media 3 28th January 2008 03:08 AM
Installation problem. Installation keeps asking for driver. dutchmanjay Installation, Upgrades and Live Media 2 1st June 2007 06:54 PM


Current GMT-time: 20:52 (Tuesday, 29-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat