Fedora Linux Support Community & Resources Center
  #1  
Old 30th August 2012, 08:01 PM
Kaya Saman Offline
Registered User
 
Join Date: Dec 2004
Posts: 114
linuxfirefox
HDMI Audio in Gnome3 F17

Hi,

finally I've managed to get 'a display working' and in addition the displays looking exactly the way I want them!

Now another issue has arrived; my displays have built in speakers which work via audio 3.5mm stereo cable or HDMI digital input.

The HDMI digital input was working fine while I had Fedora 15 installed but now with the upgrade it is gone

The normal procedure I use (works on my Lenovo X220 running F16) is to go to the sound settings at the top of the panel and change that from Analog to HDMI digital.

This is the output from lspci:

Code:
03:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device 841f
	Physical Slot: 34
	Flags: bus master, fast devsel, latency 0, IRQ 18
	Memory at fbcfc000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Kernel driver in use: snd_hda_intel
For some reason however, running F17 and changing to HDMI produces no sound??

I have of course checked the screens input and volume settings and additionally the output and volume on the F17 box too. - all are fine!

I tried to even start a video using Mplayer:

Code:
-ao alsa:device=hw=0.0
-ao alsa:device=hw=0.1
which is suggested by the mplayer man page. This yields nothing however, even with trying different drivers...

I don't see anything in dmesg or any other logs outside of this:

Code:
[ 1253.447666] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[ 1402.353851] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.

Has anyone encountered this issue before or do I simply need to wait for a driver update?


Thanks

---------- Post added at 09:36 PM ---------- Previous post was at 07:22 PM ----------

Well.... I've managed to get audio but it seems through ALSA and not Pulse which of now is heavily tied into Gnome and Fedora.

Using ALSAMIXER and system information I got these device nodes:

Code:
  ┌─────── /proc/asound/devices ───────┐                                                                                      │
│                                                                                     │  2: [ 0- 2]: digital audio capture │                                                                                      │
│                                                                                     │  3: [ 0- 1]: digital audio playback│                                                                                      │
│                                                                                     │  4: [ 0- 0]: digital audio playback│                                                                                      │
│                                                                                     │  5: [ 0- 0]: digital audio capture │                                                                                      │
│                                                                                     │  6: [ 0- 0]: hardware dependent    │                                                                                      │
│                                                                                     │  7: [ 0]   : control               │                                                                                      │
│                                                                                     │  8: [ 1- 9]: digital audio playback│                                                                                      │
│                                                                                     │  9: [ 1- 8]: digital audio playback│                                                                                      │
│                                                                                     │ 10: [ 1- 7]: digital audio playback│                                                                                      │
│                                                                                     │ 11: [ 1- 3]: digital audio playback│                                                                                      │
│                                                                                     │ 12: [ 1- 3]: hardware dependent    │                                                                                      │
│                                                                                     │ 13: [ 1- 2]: hardware dependent    │                                                                                      │
│                                                                                     │ 14: [ 1- 1]: hardware dependent    │                                                                                      │
│                                                                                     │ 15: [ 1- 0]: hardware dependent    │                                                                                      │
│                                                                                     │ 16: [ 1]   : control               │                                                                                      │
│                                                                                     │ 33:        : timer
which is telling me that the HDMI is at:

Code:
hw:1,3
hw:1,7
hw:1,8
hw:1,9

Now finding and following these guides:


http://en.wikibooks.org/wiki/Configu...roubleshooting

http://unix.stackexchange.com/questi...mi-doesnt-work

loosely I **am** able to get sound if I run from terminal using Mplayer:

Code:
mplayer -ao alsa:device=hw=1.7 file.ext
As for the Gnome GUI sound tool however, the above command totally bypasses it so there is absolutely to volume control or any other capability at all.


I wonder how to integrate these things so that Pulse will basically just work with the HDMI or give the ability to pick to correct channel as HDMI seems to be configured to 7.1 surround????


Would anyone be able to suggest anything or should I just wait for some updates and carry on with semi-sound?

---------- Post added at 10:01 PM ---------- Previous post was at 09:36 PM ----------

I've made a bit more progress hacking away at the system.....

I shall start from the beginning incase someone runs across this post with a similar problem.

First list the devices using 'aplay -l'

Code:
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887 Analog [ALC887 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887 Digital [ALC887 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
The good thing about the above is that it shows the device ID's per HDMI output!

Cross correlating with the above 'ALSAMIXER' output, test each output using the 'mplayer -ao' command then edit the /etc/asound.conf file ->


This is the /etc/asound.conf file:

Code:
# cat asound.conf
#
# Place your global alsa-lib configuration here...
#

pcm.hdmi1 {
        type hw
        card 1
        device 7 }

pcm.!default {
        type  plug
        slave.pcm "hdmi1"
}

Setting Gnome-Mplayer to use ALSA as the driver will get volume setting from the front end at least though the Gnome Master volume control using Pulse still doesn't work :-(


I have a funny feeling that it is working however just on the wrong channel...... so I have no idea how to change it as the GUI seems quite limited on my system at this point but we'll see if someone can come up with any thing other then what I've got or if driver adn software updates will fix the issue.

Rhythem Box most likely won't work as one can't select the input/output driver to use like Gnome of old where it was pure ALSA with overrides inplace for Pulse etc....


Oh well at least this is a start!
Reply With Quote
  #2  
Old 2nd September 2012, 12:16 PM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,077
linuxfirefox
Re: HDMI Audio in Gnome3 F17

If everything else fails just connect your internal sound card to one of your monitors or even better use some external speakers if you want to watch movies or something ;-)
Reply With Quote
  #3  
Old 2nd September 2012, 02:50 PM
Kaya Saman Offline
Registered User
 
Join Date: Dec 2004
Posts: 114
linuxfirefox
Re: HDMI Audio in Gnome3 F17

That normally would work but I have a custom install where the cables are inlaid for the screens....

They are 10 meters away from the desktop (DVI-D, HDMI, PS/2).


The desktop is actually an ASUS Mini-ITX ION5T system board sitting in a 19" rack enclosure all racked up in a Sun Microsystems 72" Rack Cabinet quite a bit away from the desk which is the main 'office/computer' system.


But thanks anyway for the suggestion!
Reply With Quote
  #4  
Old 2nd September 2012, 11:43 PM
CronoCloud Offline
Registered User
 
Join Date: May 2010
Location: Midwest USA
Posts: 451
linuxfirefox
Re: HDMI Audio in Gnome3 F17

Try this:

In file /etc/pulse/default.pa

add this line:

Code:
load-module module-alsa-sink device=hw:1,3
Then restart pulse or restart machine if necessary.

CronoCloud
Reply With Quote
  #5  
Old 4th September 2012, 05:00 PM
Kaya Saman Offline
Registered User
 
Join Date: Dec 2004
Posts: 114
linuxfirefox
Re: HDMI Audio in Gnome3 F17

Thank you!

This worked, but I had to put:

Code:
load-module module-alsa-sink device=hw:1,7
To get the proper channel ;-)
Reply With Quote
Reply

Tags
audio, f17, gnome3, hdmi

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] HDMI Audio Not Working Kissell Using Fedora 4 20th May 2012 12:26 PM
Audio over HDMI ColonelPenguin Hardware & Laptops 0 29th July 2011 04:32 AM
[SOLVED] Nvidia HDMI audio/sound jtang613 Hardware & Laptops 6 23rd September 2010 07:19 PM
No HDMI audio from Radeon HD in F10 AndyW Using Fedora 0 3rd August 2009 11:35 PM
HDMI or spdif audio F10 kupo Hardware & Laptops 2 28th July 2009 04:27 PM


Current GMT-time: 11:46 (Friday, 22-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat