Fedora Linux Support Community & Resources Center
  #1  
Old 9th July 2012, 08:36 AM
noobusinglinux Offline
Registered User
 
Join Date: Oct 2008
Location: canada alberta
Posts: 219
linuxunknown
Question error missing requires of?

hi guys i just upgraded to fedora 16 with the dvd and im haveing problems synchronizein my software to the latest available version
im getting the error mesg
Code:
** Found 408 pre-existing rpmdb problem(s), 'yum check' output follows:
ImageMagick-c++-6.6.5.10-20.fc15.i686 has missing requires of ImageMagick = ('0', '6.6.5.10', '20.fc15')
OpenGTL-0.9.15.1-3.fc15.i686 has missing requires of libLLVM-2.8.so
OpenGTL-libs-0.9.15.1-3.fc15.i686 has missing requires of libLLVM-2.8.so
TeXmacs-1.0.7.9-2.fc15.i686 has missing requires of texmacs-fedora-fonts = ('0', '1.0.7.9', '2.fc15')
VirtualBox-3.2-3.2.10_66523_fedora13-1.i686 has missing requires of libpython2.6.so.1.0
VirtualBox-3.2-3.2.10_66523_fedora13-1.i686 has missing requires of python(abi) = ('0', '2.6', None)
almanah-0.8.0-1.fc15.i686 has missing requires of libcamel-1.2.so.23
almanah-0.8.0-1.fc15.i686 has missing requires of libcryptui.so.0
almanah-0.8.0-1.fc15.i686 has missing requires of libebook-1.2.so.10
almanah-0.8.0-1.fc15.i686 has missing requires of libecal-1.2.so.8
almanah-0.8.0-1.fc15.i686 has missing requires of libedataserver-1.2.so.14
almanah-0.8.0-1.fc15.i686 has missing requires of libedataserverui-3.0.so.0
amanda-server-3.2.3-2.fc15.i686 has missing requires of amanda = ('0', '3.2.3', '2.fc15')
amanda-server-3.2.3-2.fc15.i686 has missing requires of libamanda-3.2.3.so
amanda-server-3.2.3-2.fc15.i686 has missing requires of libamandad-3.2.3.so
amanda-server-3.2.3-2.fc15.i686 has missing requires of libamglue-3.2.3.so
amanda-server-3.2.3-2.fc15.i686 has missing requires of libamxfer-3.2.3.so
amanda-server-3.2.3-2.fc15.i686 has missing requires of libndmlib-3.2.3.so
aqsis-1.6.0-8.fc15.i686 has missing requires of libboost_filesystem-mt.so.1.46.0
aqsis-1.6.0-8.fc15.i686 has missing requires of libboost_regex-mt.so.1.46.0
aqsis-1.6.0-8.fc15.i686 has missing requires of libboost_system-mt.so.1.46.0
aqsis-1.6.0-8.fc15.i686 has missing requires of libboost_thread-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_filesystem-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_iostreams-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_regex-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_system-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_thread-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_wave-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_filesystem-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_iostreams-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_regex-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_system-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_thread-mt.so.1.46.0
audacious-plugins-2.5.4-2.fc15.i686 has missing requires of libmtp.so.8
avahi-compat-libdns_sd-0.6.30-3.fc15.i686 has missing requires of avahi = ('0', '0.6.30', '3.fc15')
avahi-compat-libdns_sd-0.6.30-3.fc15.i686 has missing requires of avahi-libs = ('0', '0.6.30', '3.fc15')
avahi-qt3-0.6.30-3.fc15.i686 has missing requires of avahi = ('0', '0.6.30', '3.fc15')
avahi-ui-0.6.30-3.fc15.i686 has missing requires of avahi = ('0', '0.6.30', '3.fc15')
1:blender-2.49b-17.fc15.i686 has missing requires of libGLEW.so.1.5
cegui-0.7.5-8.fc15.i686 has missing requires of libGLEW.so.1.5
cmake-gui-2.8.4-1.fc15.i686 has missing requires of cmake = ('0', '2.8.4', '1.fc15')
compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-fusion-extras-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-plugins-main-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
cpan-upload-2.2-8.fc15.noarch has missing requires of perl(:MODULE_COMPAT_5.12.3)
device-mapper-multipath-0.4.9-15.fc15.i686 has missing requires of kpartx = ('0', '0.4.9', '15.fc15')
drpython-3.11.1-1.fc13.noarch has missing requires of python(abi) = ('0', '2.6', None)
1:eclipse-cdt-sdk-7.0.2-3.fc15.i686 has missing requires of eclipse-cdt = ('1', '7.0.2', '3.fc15')
eclipse-mylyn-context-cdt-3.5.1-1.fc15.noarch has missing requires of eclipse-mylyn-context = ('0', '3.5.1', '1.fc15')
ffmpeg-libs-0.7.13-1.fc15.i686 has missing requires of libcelt0.so.1
file-devel-5.07-4.fc15.i686 has missing requires of file = ('0', '5.07', '4.fc15')
2:gimp-2.6.12-1.fc15.i686 has missing requires of libpoppler-glib.so.6
2:gimp-2.6.12-1.fc15.i686 has missing requires of libpoppler.so.13
git-email-1.7.6.5-1.fc15.noarch has missing requires of git = ('0', '1.7.6.5', '1.fc15')

do i need to fix mirror configuration?
__________________
http://geeks.pirillo.com/
Reply With Quote
  #2  
Old 9th July 2012, 12:41 PM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,078
linuxfirefox
Re: error missing requires of?

Looks like you still have a lot of Fedora 15 programs installed.
Reply With Quote
  #3  
Old 9th July 2012, 12:49 PM
Yellowman
Guest
 
Posts: n/a
linuxfirefox
Re: error missing requires of?

Run
Code:
su
yum distro-sync
Reply With Quote
  #4  
Old 9th July 2012, 03:48 PM
mschwendt Offline
Registered User
 
Join Date: Jun 2010
Posts: 312
linuxfirefox
Re: error missing requires of?

The DVD isn't big enough for all packages.

You should apply the missing updates from network repositories. Alternatively, you could have enabled the network repositories already when you did the upgrade via DVD.
Reply With Quote
  #5  
Old 12th July 2012, 11:56 PM
noobusinglinux Offline
Registered User
 
Join Date: Oct 2008
Location: canada alberta
Posts: 219
linuxunknown
Re: error missing requires of?

ok so i did
yum distro-sync same error so i did --skip-broken
Code:
Running Transaction Check
ERROR with transaction check vs depsolve:
python(abi) = 2.6 is needed by (installed) python-psyco-1.6-4.fc12.i686
python(abi) = 2.6 is needed by (installed) drpython-3.11.1-1.fc13.noarch
python(abi) = 2.6 is needed by (installed) VirtualBox-3.2-3.2.10_66523_fedora13-1.i686
libcryptui.so.0 is needed by almanah-0.8.0-1.fc16.i686
Please report this error in https://bugzilla.redhat.com/enter_bu...&component=yum
** Found 407 pre-existing rpmdb problem(s), 'yum check' output follows:
ImageMagick-c++-6.6.5.10-20.fc15.i686 has missing requires of ImageMagick = ('0', '6.6.5.10', '20.fc15')
OpenGTL-0.9.15.1-3.fc15.i686 has missing requires of libLLVM-2.8.so
OpenGTL-libs-0.9.15.1-3.fc15.i686 has missing requires of libLLVM-2.8.so
TeXmacs-1.0.7.9-2.fc15.i686 has missing requires of texmacs-fedora-fonts = ('0', '1.0.7.9', '2.fc15')
VirtualBox-3.2-3.2.10_66523_fedora13-1.i686 has missing requires of libpython2.6.so.1.0
VirtualBox-3.2-3.2.10_66523_fedora13-1.i686 has missing requires of python(abi) = ('0', '2.6', None)
almanah-0.8.0-1.fc15.i686 has missing requires of libcamel-1.2.so.23
almanah-0.8.0-1.fc15.i686 has missing requires of libcryptui.so.0
almanah-0.8.0-1.fc15.i686 has missing requires of libebook-1.2.so.10
almanah-0.8.0-1.fc15.i686 has missing requires of libecal-1.2.so.8
almanah-0.8.0-1.fc15.i686 has missing requires of libedataserver-1.2.so.14
almanah-0.8.0-1.fc15.i686 has missing requires of libedataserverui-3.0.so.0
amanda-server-3.2.3-2.fc15.i686 has missing requires of libamanda-3.2.3.so
amanda-server-3.2.3-2.fc15.i686 has missing requires of libamandad-3.2.3.so
amanda-server-3.2.3-2.fc15.i686 has missing requires of libamglue-3.2.3.so
amanda-server-3.2.3-2.fc15.i686 has missing requires of libamxfer-3.2.3.so
amanda-server-3.2.3-2.fc15.i686 has missing requires of libndmlib-3.2.3.so
aqsis-1.6.0-8.fc15.i686 has missing requires of libboost_filesystem-mt.so.1.46.0
aqsis-1.6.0-8.fc15.i686 has missing requires of libboost_regex-mt.so.1.46.0
aqsis-1.6.0-8.fc15.i686 has missing requires of libboost_system-mt.so.1.46.0
aqsis-1.6.0-8.fc15.i686 has missing requires of libboost_thread-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_filesystem-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_iostreams-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_regex-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_system-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_thread-mt.so.1.46.0
aqsis-core-1.6.0-8.fc15.i686 has missing requires of libboost_wave-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_filesystem-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_iostreams-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_regex-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_system-mt.so.1.46.0
aqsis-libs-1.6.0-8.fc15.i686 has missing requires of libboost_thread-mt.so.1.46.0
audacious-plugins-2.5.4-2.fc15.i686 has missing requires of libmtp.so.8
avahi-compat-libdns_sd-0.6.30-3.fc15.i686 has missing requires of avahi = ('0', '0.6.30', '3.fc15')
avahi-compat-libdns_sd-0.6.30-3.fc15.i686 has missing requires of avahi-libs = ('0', '0.6.30', '3.fc15')
avahi-qt3-0.6.30-3.fc15.i686 has missing requires of avahi = ('0', '0.6.30', '3.fc15')
avahi-ui-0.6.30-3.fc15.i686 has missing requires of avahi = ('0', '0.6.30', '3.fc15')
1:blender-2.49b-17.fc15.i686 has missing requires of libGLEW.so.1.5
cegui-0.7.5-8.fc15.i686 has missing requires of libGLEW.so.1.5
cmake-gui-2.8.4-1.fc15.i686 has missing requires of cmake = ('0', '2.8.4', '1.fc15')
compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-fusion-extras-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-plugins-main-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
cpan-upload-2.2-8.fc15.noarch has missing requires of perl(:MODULE_COMPAT_5.12.3)
device-mapper-multipath-0.4.9-15.fc15.i686 has missing requires of kpartx = ('0', '0.4.9', '15.fc15')
drpython-3.11.1-1.fc13.noarch has missing requires of python(abi) = ('0', '2.6', None)
1:eclipse-cdt-sdk-7.0.2-3.fc15.i686 has missing requires of eclipse-cdt = ('1', '7.0.2', '3.fc15')
eclipse-mylyn-context-cdt-3.5.1-1.fc15.noarch has missing requires of eclipse-mylyn-context = ('0', '3.5.1', '1.fc15')
ffmpeg-libs-0.7.13-1.fc15.i686 has missing requires of libcelt0.so.1
file-devel-5.07-4.fc15.i686 has missing requires of file = ('0', '5.07', '4.fc15')
2:gimp-2.6.12-1.fc15.i686 has missing requires of libpoppler-glib.so.6
2:gimp-2.6.12-1.fc15.i686 has missing requires of libpoppler.so.13
git-email-1.7.6.5-1.fc15.noarch has missing requires of git = ('0', '1.7.6.5', '1.fc15')
git-email-1.7.6.5-1.fc15.noarch has missing requires of perl-Git = ('0', '1.7.6.5', '1.fc15')
glew-1.5.8-4.fc15.i686 has missing requires of libGLEW.so.1.5
1:gnash-0.8.10-2.fc15.i686 has missing requires of libboost_date_time-mt.so.1.46.0
1:gnash-0.8.10-2.fc15.i686 has missing requires of libboost_iostreams-mt.so.1.46.0
1:gnash-0.8.10-2.fc15.i686 has missing requires of libboost_program_options-mt.so.1.46.0
1:gnash-0.8.10-2.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
1:gnash-0.8.10-2.fc15.i686 has missing requires of libboost_thread-mt.so.1.46.0
1:gnash-klash-0.8.10-2.fc15.i686 has missing requires of libboost_program_options-mt.so.1.46.0
gnomad2-2.9.6-1.fc15.i686 has missing requires of libmtp.so.8
gnome-media-apps-2.91.2-6.fc15.i686 has missing requires of gnome-media = ('0', '2.91.2', '6.fc15')
gnome-python2-bonobo-2.28.1-4.fc15.i686 has missing requires of gnome-python2 = ('0', '2.28.1', '4.fc15')
gnome-python2-evince-2.32.0-3.fc14.i686 has missing requires of gnome-python2-desktop = ('0', '2.32.0', '3.fc14')
gnome-python2-evince-2.32.0-3.fc14.i686 has missing requires of libevdocument.so.3
gnome-python2-evince-2.32.0-3.fc14.i686 has missing requires of libevview.so.3
gnome-python2-gnomeprint-2.32.0-4.fc15.i686 has missing requires of gnome-python2-desktop = ('0', '2.32.0', '4.fc15')
gstreamer-plugins-bad-free-0.10.22-2.fc16.1.i686 has missing requires of libvpx.so.0
gstreamer-plugins-bad-free-extras-0.10.22-1.fc15.1.i686 has missing requires of gstreamer-plugins-bad-free = ('0', '0.10.22', '1.fc15.1')
gstreamer-plugins-bad-free-extras-0.10.22-1.fc15.1.i686 has missing requires of libopencv_calib3d.so.2.2
gstreamer-plugins-bad-free-extras-0.10.22-1.fc15.1.i686 has missing requires of libopencv_contrib.so.2.2
gstreamer-plugins-bad-free-extras-0.10.22-1.fc15.1.i686 has missing requires of libopencv_core.so.2.2
__________________
http://geeks.pirillo.com/
Reply With Quote
  #6  
Old 13th July 2012, 12:06 AM
noobusinglinux Offline
Registered User
 
Join Date: Oct 2008
Location: canada alberta
Posts: 219
linuxunknown
Re: error missing requires of?

and heres an attachment of all my terminall activity
Attached Files
File Type: zip konsole yum distro-sync.txt.zip (185.9 KB, 62 views)
__________________
http://geeks.pirillo.com/
Reply With Quote
  #7  
Old 13th July 2012, 12:30 AM
noobusinglinux Offline
Registered User
 
Join Date: Oct 2008
Location: canada alberta
Posts: 219
linuxunknown
Question Re: error missing requires of?

i just realized theres that theres thingse here from fedora 12!

and my Android is haveing this problem where there are text msgs being rejected i cant get any data communication and and firefox and opera jjust vanished into thin air files and all as if they were never on my phone and the home screen keeps re arangeing on its own and the backround is blacking out, sony ericsson programs are crashing "fun and downloads"
my ISP went down yesterday after an electrical fire
not to mention im seing fedora 15 programs in fedora 16 mirrors
whats going on?
Attached Thumbnails
Click image for larger version

Name:	fc 15 packages in fc16 repos.png
Views:	94
Size:	162.9 KB
ID:	23411  
__________________
http://geeks.pirillo.com/
Reply With Quote
  #8  
Old 13th July 2012, 10:43 AM
mschwendt Offline
Registered User
 
Join Date: Jun 2010
Posts: 312
linuxfirefox
Re: error missing requires of?

Don't rush. It's rather obvious you've got some things to learn to handle such problems after a full distribution upgrade, especially if you didn't enable network updates when doing the upgrade.

Focus on the following problems first:
Quote:
python(abi) = 2.6 is needed by (installed) python-psyco-1.6-4.fc12.i686
python(abi) = 2.6 is needed by (installed) drpython-3.11.1-1.fc13.noarch
python(abi) = 2.6 is needed by (installed) VirtualBox-3.2-3.2.10_66523_fedora13-1.i686
These are rather old packages and/or are not provided by Fedora. Get familiar with Yum or repoquery to examine whether these packages (or updates for them) are still found in the repositories.
For example, run: yum list python-psyco drpython VirtualBox
What do you get? Are there updates for them or not? You may need to erase/remove these packages before you can continue. It can happen that some Fedora packages are not available anymore and that nothing deletes them automatically. You need to decide what to do with them.

There are tools to help you with several problems. For example, "yum check" can be run manually to examine the installation for problems. "yum list extras" finds packages not available in any repositories anymore. "package-cleanup --cleandupes" can remove duplicate packages automatically.

The ".fc15" (or older) marker in package names is no immediate reason to be concerned. Not all packages are rebuilt for each new distribution release. Especially not .noarch packages. Older builds may still work fine in a new distribution release.
Reply With Quote
Reply

Tags
error, missing, requires

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bugzilla requires (missing) "duphash" . Quicksort Using Fedora 5 16th September 2011 06:40 PM
[SOLVED] libpanelappletmm-2.26.0-2.fc12.i686 has missing requires of libpanel-applet-2.so.0 Ex_Soft Using Fedora 2 13th June 2011 07:03 PM
yum update (..missing requires of kernel.uname-r=..) HeyRicardo Using Fedora 8 24th April 2010 06:29 AM
Error: Missing Dependency metalman51 Using Fedora 3 11th January 2007 05:32 PM
yum error:Error: Missing Dependency: libpisock.so.9 is needed by package evolution shams Using Fedora 4 5th May 2006 01:42 AM


Current GMT-time: 11:13 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Bilsi Photos - Charkhari Instagram Photos - Tirthahalli Photos on Instagram