Fedora Linux Support Community & Resources Center
  #1  
Old 28th November 2010, 03:26 PM
AMAMH Offline
Registered User
 
Join Date: Sep 2009
Posts: 17
linuxchrome
Change default window manager to "compiz-manager" compiz wrapper

Hi,
I spent *#@$ hours trying to figure out how to change my default window manager to "compiz-manger".
I tried using gconf-editor and .gnomerc
Anybody has an idea how to do this?

btw, shouldn't this be easy? (FOR F**K SAKE!!)

Last edited by AMAMH; 28th November 2010 at 06:15 PM.
Reply With Quote
  #2  
Old 28th November 2010, 03:44 PM
cneil Offline
Registered User
 
Join Date: Oct 2010
Location: Cambridgeshire UK
Posts: 31
linuxfedorafirefox
Re: change default window manager

Assuming you have multiple managers installed when you have opened fedora if you look on the bottom bar on the screen you will see three places for drop down screens; one for language a second one for keyboard and a third for window manager, click on this one and choose which manager you want to use and then log in.


Neil
Reply With Quote
  #3  
Old 28th November 2010, 03:53 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 71
Posts: 23,058
linuxfedorafirefox
Re: change default window manager

Amamh, we have the obscenity filter there for a reason, however we'd appreciate it if you didn't put it to the test. This Forum is viewed by people of all ages and genders. Please keep that in mind in future posts.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #4  
Old 28th November 2010, 05:00 PM
EnglandA Offline
Registered User
 
Join Date: May 2005
Location: UK
Posts: 254
linuxfedorafirefox
Re: change default window manager

I thought this was enabled by going to desktop effects, under system, preferences.
__________________
Registered Linux User #221895
Reply With Quote
  #5  
Old 28th November 2010, 06:14 PM
AMAMH Offline
Registered User
 
Join Date: Sep 2009
Posts: 17
linuxfirefox
Re: change default window manager

Quote:
Originally Posted by cneil View Post
Assuming you have multiple managers installed when you have opened fedora if you look on the bottom bar on the screen you will see three places for drop down screens; one for language a second one for keyboard and a third for window manager, click on this one and choose which manager you want to use and then log in.


Neil
I don't mean choosing KDE/GNOME/XFCE
I'm talking about choosing a window manager e.g. metacity/compiz/compiz-manager

---------- Post added at 07:14 PM GMT ---------- Previous post was at 07:13 PM GMT ----------

Quote:
Originally Posted by EnglandA View Post
I thought this was enabled by going to desktop effects, under system, preferences.
That enables "compiz"
I want "compiz-manager" which is a wrapper script to start compiz with appropriate settings/plugins.

i.e. I want to change default manager to "compiz-manager"
Reply With Quote
  #6  
Old 7th December 2010, 05:17 AM
AMAMH Offline
Registered User
 
Join Date: Sep 2009
Posts: 17
linuxfirefox
Re: change default window manager

while installing Enlightenment desktop from svn (pain in the ass), I solved this problem.
The answer is to use gconf and change this value:
/desktop/gnome/session/required_components/windowmanager

..... thanks !?
Reply With Quote
  #7  
Old 11th December 2010, 03:50 PM
AMAMH Offline
Registered User
 
Join Date: Sep 2009
Posts: 17
linuxfirefox
Cool How to change default window manager to "compiz-manager" compiz wrapper

These are my notes from gnote, scroll down to see the final solution.

changed gconf key /desktop/gnome/session/required_components/windowmanager to "compiz-manager" works fine but windows have no decration !! (no close, minimize, etc)
work around: add "compiz-manager --replace" to autostart (awkward ****, now we r executing it again)

problem discovered:
compiz-manager gets executed but it does not start the "gtk-window-decorator" !!

add logging to "compiz-manager" script, result:
changing /desktop/gnome/session/required_components/windowmanager to "compiz-manager", doesn't actually execute "compiz-manager", but it does execute a compiz wm, don't know how.

/usr/bin/gnome-wm says:

# NOTE: DON'T USE THIS. Please have your window manager install
# a desktop file and change the gconf key
# /desktop/gnome/session/required_components/windowmanager

added desktop file, changed the key to "compiz-manager", now:
compiz gets executed 2 times, the second time is because of my changes, what about the first? it does not execute "compiz-manager" script in the first time, it executes compiz directly

I found a .session file in .gnome2, specifying the window manager as compiz-manager:
deleted.

deleted everything here:
/home/xv22/.config/gnome-session/saved-session


PROBLEM SOLVED !

Conclusion:
seems like compiz was being executed because of some stupid scripts in my home dir, that I have created to start it, and forgot to delete them
the correct way to execute it is to:
add a desktop file to /usr/share/applications (copy "metacity.desktop" and modify it)
change gconf key to "compiz-manager"


Now I have a question:
Ubuntu/Mint does all this automatically, why do I need to dig into gnome files to to do this in Fedora !!?? I still love fedora though....

Last edited by AMAMH; 11th December 2010 at 05:50 PM.
Reply With Quote
  #8  
Old 11th December 2010, 06:10 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 71
Posts: 23,058
linuxfedorafirefox
Re: change default window manager

Threads merged. You should only have one thread per topic. It's confusing to others looking for solutions.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #9  
Old 2nd January 2011, 09:17 AM
prkos Offline
Registered User
 
Join Date: May 2008
Location: Croatia
Posts: 36
linuxfedorafirefox
Re: Change default window manager to "compiz-manager" compiz wrapper

I got in trouble with gconftool-2 changing /desktop/gnome/session/required_components/windowmanager, I had to delete the file created by this through terminal, gui couldn't start without problems

In the end I started the fusion-icon through terminal, and in the output saw the command that is executed to start compiz. I copied the command into a new Startup applications entry and now things are working fine.

This is the command that works for me:
Code:
compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
make compiz-manager as default desktop manager msankhala Hardware & Laptops 4 25th January 2010 09:57 PM
getting a compiz error when running compiz-manager manuleka Installation, Upgrades and Live Media 0 28th February 2009 05:20 AM
XFCE Window Manager & Compiz savage Using Fedora 2 8th July 2008 08:15 AM
GL Desktop/Gnome Compiz Manager - Adding to Compiz Axklor Guides & Solutions (Not For Questions) 1 24th February 2007 11:07 AM
Change default window manager Hiltonizer Using Fedora 9 20th December 2004 11:34 PM


Current GMT-time: 18:28 (Monday, 27-03-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat