Fedora Linux Support Community & Resources Center
  #1  
Old 29th March 2012, 11:54 PM
dsmithhfx Offline
Registered User
 
Join Date: Apr 2008
Posts: 90
linuxfirefox
Network fails to load after kernel 3.3 upgrade

Hi,

My wired network has stopped loading after a recent upgrade to kernel kernel-3.3.0-4 (along with a few other automatic updates.

Going through Nework Manager settings appear to be ok. Not sure I'm looking for, but here's some stuff I pulled out of /var/log/yum.log and /var/log/messages. Note at the very bottom it seems to be saying it is getting all the relevant DHCP connection information, but the network doesn't come up (e.g. I can't even ping my router). The network works fine on same pc when I boot to FC15 and XP.

------------------Log stuff:

yum.log:
---
Mar 27 05:51:58 Updated: systemd-units-37-17.fc16.x86_64
Mar 27 05:52:00 Updated: systemd-37-17.fc16.x86_64
Mar 27 05:52:01 Updated: gnutls-2.12.14-2.fc16.x86_64
Mar 27 05:52:04 Updated: libpurple-2.10.2-1.fc16.x86_64
Mar 27 05:52:04 Updated: systemd-sysv-37-17.fc16.x86_64
Mar 27 05:52:04 Updated: 2:libpng-1.2.48-1.fc16.x86_64
Mar 27 05:52:05 Updated: iproute-2.6.39-5.fc16.x86_64
Mar 27 05:52:06 Updated: kernel-tools-3.3.0-4.fc16.x86_64
Mar 27 05:52:14 Installed: kernel-3.3.0-4.fc16.x86_64
---

messages
---

Mar 29 18:33:21 fc16 NetworkManager[916]: <info> (em1): DHCPv4 state changed expire -> preinit
Mar 29 18:33:21 fc16 avahi-daemon[921]: Registering new address record for fe80::219:dbff:fee7:a6ab on em1.*.
Mar 29 18:33:22 fc16 dhclient[1714]: DHCPREQUEST on em1 to 255.255.255.255 port 67
Mar 29 18:33:22 fc16 dhclient[1714]: DHCPOFFER from 192.168.1.1
Mar 29 18:33:22 fc16 NetworkManager[916]: DHCPREQUEST on em1 to 255.255.255.255 port 67
Mar 29 18:33:22 fc16 NetworkManager[916]: DHCPOFFER from 192.168.1.1
Mar 29 18:33:22 fc16 dhclient[1714]: DHCPACK from 192.168.1.1
Mar 29 18:33:22 fc16 NetworkManager[916]: DHCPACK from 192.168.1.1
Mar 29 18:33:22 fc16 dhclient[1714]: bound to 192.168.1.102 -- renewal in 42677 seconds.
Mar 29 18:33:22 fc16 NetworkManager[916]: bound to 192.168.1.102 -- renewal in 42677 seconds.
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> (em1): DHCPv4 state changed preinit -> bound
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> (em1): DHCPv4 state changed preinit -> bound
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> Activation (em1) Stage 4 of 5 (IP4 Configure Get) scheduled...
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> Activation (em1) Stage 4 of 5 (IP4 Configure Get) scheduled...
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> Activation (em1) Stage 4 of 5 (IP4 Configure Get) started...
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> Activation (em1) Stage 4 of 5 (IP4 Configure Get) started...
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> address 192.168.1.102
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> address 192.168.1.102
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> prefix 24 (255.255.255.0)
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> prefix 24 (255.255.255.0)
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> gateway 192.168.1.1
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> gateway 192.168.1.1
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> nameserver '64.71.255.198'
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> nameserver '64.71.255.198'
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> domain name '[***this is correct***]'
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> domain name '[***this is correct***]'
Mar 29 18:33:22 fc16 NetworkManager[916]: NetworkManager[916]: <info> Activation (em1) Stage 4 of 5 (IP4 Configure Get) complete.
Mar 29 18:33:22 fc16 NetworkManager[916]: <info> Activation (em1) Stage 4 of 5 (IP4 Configure Get) complete.
-------------------End log stuff

OK I had to delete a lot of stuff because it exceeded maximum post length. Sorry.

Last edited by dsmithhfx; 30th March 2012 at 11:11 AM. Reason: Sexier title
Reply With Quote
  #2  
Old 30th March 2012, 03:46 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 5,998
linuxfirefox
Re: Network fails to load on FC16 x86_64 after kernel upgrade

Are you sure the nameserver is right? Lots of 192.168.*.* networks DNS to the gateway (the gateway proxies dns from the ISP for efficiency/caching). Can you list out what's in:
Quote:
/etc/resolv.conf
and show the results of running:
Quote:
route -n
Reply With Quote
  #3  
Old 31st March 2012, 12:39 AM
dsmithhfx Offline
Registered User
 
Join Date: Apr 2008
Posts: 90
macosfirefox
Re: Network fails to load on FC16 x86_64 after kernel upgrade

Hi,

My router is running a dhcp server. I can confirm the ip for the machine and the gateway are both correct. However I'll have to wait until I get home to post the other info you requested.

For now, suffice to say I've had no network problems since installing FC16 up until the last yum update, and not changed any network settings from DHCP automatic, apart from a failed attempt at manual setting yesterday (settings copied from my working FC15 installation on the same pc). Network isn't working anymore on the two previous kernels either, since the last update, so I guess it may not be a kernel issue per se.

edit: the primary dns shown is my isp, so that's a correct ip too

---------- Post added at 07:39 PM ---------- Previous post was at 11:38 AM ----------

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface

[all blank]

resolve.conf:

# Generated by NetworkManager
domain phub.net.cable.rogers.com
search phub.net.cable.rogers.com
nameserver 64.71.255.198

Usual networking (as working in fc15, and previously in fc16):

Last edited by dsmithhfx; 30th March 2012 at 05:02 PM. Reason: checked dns
Reply With Quote
  #4  
Old 31st March 2012, 02:06 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 5,998
linuxfirefox
Re: Network fails to load on FC16 x86_64 after kernel upgrade

Quote:
Originally Posted by dsmithhfx View Post
Hi,
....
route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface

[all blank]


resolve.conf:

# Generated by NetworkManager
domain phub.net.cable.rogers.com
search phub.net.cable.rogers.com
nameserver 64.71.255.198

Usual networking (as working in fc15, and previously in fc16):
The problem is there's no route, (you showed it as blank and it shouldn't be) why I'm not sure I guess you've tried deleting the interfaces entry in NetworkManager and recreating it?

Last edited by marko; 31st March 2012 at 02:09 AM.
Reply With Quote
  #5  
Old 31st March 2012, 12:07 PM
dsmithhfx Offline
Registered User
 
Join Date: Apr 2008
Posts: 90
linuxfirefox
Re: Network fails to load on FC16 x86_64 after kernel upgrade

Yes I tried that. I'm wondering if iproute-2.6.39 (which came through with the new kernel) might be the culprit?

edit: do you think "yum downgrade iproute" would be a reasonable test of this theory? Or could it cause more problems (I never tried yum downgrade) ?

I see listings for an "iproute-3.3.0-1.fc18 RPM for x86_64". Might that better match the upgraded kernel?

Last edited by dsmithhfx; 31st March 2012 at 01:17 PM.
Reply With Quote
  #6  
Old 1st April 2012, 06:02 AM
FrankCrawford Offline
Registered User
 
Join Date: May 2006
Posts: 10
linuxfirefox
Re: Network fails to load on FC16 x86_64 after kernel upgrade

There are some issues with NetworkManager and the Linux 3.3 kernel. While your description doesn't quite match other issues I've seen, it may be related.

Have a look at the following Bugzilla entry https://bugzilla.redhat.com/show_bug.cgi?id=797524

Frank
Reply With Quote
  #7  
Old 1st April 2012, 12:53 PM
dsmithhfx Offline
Registered User
 
Join Date: Apr 2008
Posts: 90
linuxfirefox
Re: Network fails to load on FC16 x86_64 after kernel upgrade

Interesting. Since I don't use ipv6 for anything, I'm going to try to disable it and see if that helps: http://fedoraforum.org/forum/showthread.php?p=1561424.

However, as far as the bug being 3.3 kernel-specific, in my case it persists even when booting into earlier kernels.

---------- Post added at 07:53 AM ---------- Previous post was at 07:21 AM ----------

I got Fedora 16 back online. Disabling ipv6 didn't help (at least, not by itself). The culprit seems to be the last iproute update (2.6.39-5). I yum downgraded it to 2.6.39-3 (from the installation dvd, since obviously the network was unavailable, by following these instructions), and logged out-in. The network failed to come back up immediately, so I fiddled around in NetworkManager, where the only substantive change I made was to unclick "Require ipv6 addressing ...", then the network came right back up.

I guess this thread may be marked "solved", if only I knew how...
Reply With Quote
  #8  
Old 11th April 2012, 12:07 PM
kawaikx15 Offline
Registered User
 
Join Date: Apr 2012
Location: india
Posts: 37
windows_7ie
Re: Network fails to load on FC16 x86_64 after kernel upgrade

I have the similar problem.. i will try your solution
Reply With Quote
  #9  
Old 11th April 2012, 04:49 PM
dsmithhfx Offline
Registered User
 
Join Date: Apr 2008
Posts: 90
macosfirefox
Re: Network fails to load on FC16 x86_64 after kernel upgrade

Quote:
Originally Posted by kawaikx15 View Post
I have the similar problem.. i will try your solution
You might want to read this first.
Reply With Quote
Reply

Tags
fails, fc16, kernel, load, network, upgrade, x8664

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No touchpad after upgrade F16 to kernel-3.2.9-1.fc16.x86_64 Gescape Hardware & Laptops 5 13th March 2012 08:54 PM
[SOLVED] Missing kernel release for kmod-nvidia-3.2.6-3.fc16.x86_64-290.10-1.fc16.14.x86_64 d4v1dv00 Using Fedora 2 16th February 2012 01:12 AM
Network problems after upgrade to FC16 josefk Using Fedora 2 15th December 2011 02:28 PM
Problem wiyh last kernel 3.0.0-1.fc16.x86_64 chepioq F16 Development 3 2nd August 2011 09:15 PM
libgcjwebplugin.so fails to load on FC6-x86_64 clearer Using Fedora 2 26th October 2006 07:53 PM


Current GMT-time: 19:15 (Saturday, 26-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat