Fedora Linux Support Community & Resources Center
  #1  
Old 16th July 2017, 11:55 PM
ToddAndMargo Online
Registered User
 
Join Date: Feb 2010
Posts: 548
linuxfirefox
What is wrong with "notify-send"?

Hi All,

I just upgraded from fc25 to 26 on two machines. "notify-send" stopped working on both.

Examples to test:

notify-send Test "I'm a test."

notify-send -u normal -i /usr/share/icons/gnome/48x48/status/stock_dialog-warning.png summary "test text"

From /var/log/messages:

Jul 16 15:52:46 KVM-Fedora-x64 dbus-daemon[992]: [session uid=500 pid=992] Activating service name='org.freedesktop.Notifications' requested by ':1.54' (uid=500 pid=2038 comm="notify-send Test I'm a test. " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023")


This breaks a bunch of stuff.

-T

I just posted: https://bugzilla.redhat.com/show_bug.cgi?id=1471560

Last edited by ToddAndMargo; 17th July 2017 at 01:58 AM.
Reply With Quote
  #2  
Old 17th July 2017, 11:48 AM
dswaner Offline
Registered User
 
Join Date: Nov 2008
Posts: 222
linuxfedorafirefox
Re: What is wrong with "notify-send"?

notify-send is working on my updated-daily F26 machine. Same release (libnotify-0.7.7-2.fc26.x86_64). I did a fresh install of F26, not an upgrade. I'm running Workstation, Wayland.
Reply With Quote
  #3  
Old 17th July 2017, 05:14 PM
ToddAndMargo Online
Registered User
 
Join Date: Feb 2010
Posts: 548
linuxfirefox
Re: What is wrong with "notify-send"?

Both of mine were upgrades from 25
Reply With Quote
  #4  
Old 17th July 2017, 06:55 PM
satanselbow Offline
Registered User
 
Join Date: Apr 2011
Location: Rainham, Essex, UK
Posts: 278
linuxchrome
Re: What is wrong with "notify-send"?

Working on an upgraded F25 -> F26 here ... have you tried a re-install of notify-send sorry my err libnotify?
Reply With Quote
  #5  
Old 17th July 2017, 08:10 PM
dswaner Offline
Registered User
 
Join Date: Nov 2008
Posts: 222
linuxfedorafirefox
Re: What is wrong with "notify-send"?

Does
Code:
# rpm --verify --all
show any clues?
Reply With Quote
  #6  
Old 17th July 2017, 08:55 PM
ToddAndMargo Online
Registered User
 
Join Date: Feb 2010
Posts: 548
linuxfirefox
Re: What is wrong with "notify-send"?

Quote:
Originally Posted by satanselbow View Post
Working on an upgraded F25 -> F26 here ... have you tried a re-install of notify-send sorry my err libnotify?
Yes, no joy.

---------- Post added at 12:55 PM ---------- Previous post was at 12:52 PM ----------

Quote:
Originally Posted by dswaner View Post
Does
Code:
# rpm --verify --all
show any clues?
running it right now. It is really slow. How long should it take?

So far, I have

# rpm --verify --all
.M....... /var/run/pluto
.M....... /var/cache/man
S.5....T. c /etc/plymouth/plymouthd.conf
.M....... /var/lib/nfs/rpc_pipefs
missing /var/run/pulse


Edit: here is the whole thing:

# rpm --verify --all
.M....... /var/run/pluto
.M....... /var/cache/man
S.5....T. c /etc/plymouth/plymouthd.conf
.M....... /var/lib/nfs/rpc_pipefs
missing /var/run/pulse
S.5....T. c /etc/cups/cups-browsed.conf
S.5....T. /usr/share/icons/Crux/icon-theme.cache
S.5....T. /usr/share/icons/Mist/icon-theme.cache
.......T. c /etc/hba.conf
....L.... c /etc/pam.d/fingerprint-auth
....L.... c /etc/pam.d/password-auth
....L.... c /etc/pam.d/postlogin
....L.... c /etc/pam.d/smartcard-auth
....L.... c /etc/pam.d/system-auth
.......T. c /etc/kdump.conf
..5....T. /var/lib/selinux/targeted/active/commit_num
.......T. /var/lib/selinux/targeted/active/file_contexts
.......T. /var/lib/selinux/targeted/active/homedir_template
S.5....T. /var/lib/selinux/targeted/active/policy.kern
.......T. /var/lib/selinux/targeted/active/seusers
.......T. /var/lib/selinux/targeted/active/users_extra
S.5....T. c /etc/ssh/sshd_config
.M....... /var/log/audit
missing /usr/lib/systemd/system-preset/85-display-manager.preset

Last edited by ToddAndMargo; 17th July 2017 at 09:27 PM.
Reply With Quote
  #7  
Old 17th July 2017, 10:14 PM
dswaner Offline
Registered User
 
Join Date: Nov 2008
Posts: 222
linuxfedorafirefox
Re: What is wrong with "notify-send"?

Here's the rpm output from my F26 (sorry about the different sort order). I don't see any significant differences between yours and mine, except that in mine I've got:
Quote:
missing c /etc/systemd/system/dbus-org.freedesktop.resolve1.service
I don't know what that implies, or if it matters..

Quote:
.M.....T. /boot/efi/EFI/BOOT/BOOTX64.EFI
.M.....T. /boot/efi/EFI/BOOT/fallback.efi
.M....... /boot/efi/EFI/fedora
.M....... /boot/efi/EFI/fedora
.M.....T. /boot/efi/EFI/fedora/BOOT.CSV
.M....... /boot/efi/EFI/fedora/fonts
.M.....T. /boot/efi/EFI/fedora/fonts/unicode.pf2
.M....... /boot/efi/EFI/fedora/fw
.M.....T. /boot/efi/EFI/fedora/fwupx64.efi
.M.....T. /boot/efi/EFI/fedora/gcdx64.efi
.M.....T. /boot/efi/EFI/fedora/grubx64.efi
.M.....T. /boot/efi/EFI/fedora/MokManager.efi
.M.....T. /boot/efi/EFI/fedora/shim.efi
.M.....T. /boot/efi/EFI/fedora/shim-fedora.efi
.M.....T. /boot/efi/mach_kernel
.M.....T. /boot/efi/System/Library/CoreServices/SystemVersion.plist
S.5....T. c /etc/aliases
S.5....T. c /etc/cron.deny
S.5....T. c /etc/cups/cups-browsed.conf
S.5....T. c /etc/dnf/dnf.conf
S.5....T. c /etc/grub.d/40_custom
.......T. c /etc/kdump.conf
....L.... c /etc/pam.d/fingerprint-auth
....L.... c /etc/pam.d/password-auth
....L.... c /etc/pam.d/postlogin
....L.... c /etc/pam.d/smartcard-auth
....L.... c /etc/pam.d/system-auth
S.5....T. c /etc/plymouth/plymouthd.conf
S.5....T. c /etc/printcap
.......T. c /etc/sysconfig/system-config-users
S.5....T. c /etc/systemd/journald.conf
missing c /etc/systemd/system/dbus-org.freedesktop.resolve1.service
S.5....T. c /etc/wpa_supplicant/wpa_supplicant.conf
.......T. c /root/.bash_profile
.......T. c /root/.bashrc
.M....... /run/libgpod
missing /usr/lib/systemd/system-preset/85-display-manager.preset
.M....... /var/cache/man
.M....... /var/lib/nfs/rpc_pipefs
..5....T. /var/lib/selinux/targeted/active/commit_num
.......T. /var/lib/selinux/targeted/active/file_contexts
.......T. /var/lib/selinux/targeted/active/homedir_template
S.5....T. /var/lib/selinux/targeted/active/policy.kern
.......T. /var/lib/selinux/targeted/active/seusers
.......T. /var/lib/selinux/targeted/active/users_extra
.M....... /var/log/audit
.M....G.. /var/log/gdm
missing /var/run/pulse
Reply With Quote
  #8  
Old 18th July 2017, 08:28 AM
ToddAndMargo Online
Registered User
 
Join Date: Feb 2010
Posts: 548
linuxfirefox
Re: What is wrong with "notify-send"?

New info:

I qemu-kbm booted Fedora-Xfce-Live-x86_64-26-1.5.iso. Send-notify worked perfectly. This must have something to do with the fc25 to fc26 upgrade
Reply With Quote
  #9  
Old 18th July 2017, 09:11 AM
srakitnican Offline
Registered User
 
Join Date: Oct 2011
Posts: 1,399
linuxchrome
Re: What is wrong with "notify-send"?

Quote:
Jul 16 15:52:46 KVM-Fedora-x64 dbus-daemon[992]: [session uid=500 pid=992] Activating service name='org.freedesktop.Notifications' requested by ':1.54' (uid=500 pid=2038 comm="notify-send Test I'm a test. " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023")
I can't tell much from this message. It just says "I am doing stuff". Also /var/log/messages is a weird place to look for one, Fedora doesn't use it for years. Custom configuration I suppose. Try to look into some other places if you can, like journalctl.

notify-send sends messages to D-Bus which then DE uses to display the message. I guess you should investigate if this works properly.

Also, maybe as a shoot in the dark, try to make /.autorelabel and then reboot. This should fix any SELinux labeling issues if there are any.
Reply With Quote
Reply

Tags
notifysend, wrong

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Using Firefox 3.6 "Send Link..." with Thunderbird 8 - F15 PolywogSys Guides & Solutions (Not For Questions) 0 25th January 2012 04:27 PM
unpredictable "delete" "move to trash" or "cut" file menu option dorianrenato Using Fedora 1 21st November 2011 03:09 AM
Problem mounting a samba share "CIFS VFS: Send error in SETFSUnixInfo = -5" Roderick Servers & Networking 3 9th November 2006 07:16 AM
"Video bus notify" messages (Ati Radeon 9200) hyde Hardware & Laptops 0 26th October 2006 09:36 PM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM


Current GMT-time: 06:43 (Tuesday, 25-07-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat