Fedora Linux Support Community & Resources Center
  #1  
Old 24th October 2011, 03:28 AM
ampdbi Offline
Registered User
 
Join Date: Oct 2011
Posts: 3
linuxfirefox
Eagle Install Problem

Hi,

I'm trying to install eagle (http://www.cadsoftusa.com/) on a F15 x64 machine. When I tried to run the install I got the error "/tmp/eagle-setup.14566/eagle-5.11.0/bin/eagle: error while loading shared libraries: libXrender.so.1: cannot open shared object file: No such file or directory"

First I tried making a link to /usr/lib from /usr/lib64 and that didn't work, so I installed the libXrender.i686 from yum.

Then it asked for libXrandr, so I installed libXrandr.i686, then libXcursor.so.1, so I installed libXcursor.i686.

Now it's asking me for libfreetype.so.6. There's no 1686 package I can find. Am I doing something horribly wrong? Do I need to install all these 32 bit libs? Is there a way to install them all at once?
Reply With Quote
  #2  
Old 24th October 2011, 04:56 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,928
linuxfirefox
Re: Eagle Install Problem

Yup, you got to install everything it complains about. You can use ldd to get the whole list then do it all in one go with yum.
Reply With Quote
  #3  
Old 24th October 2011, 05:05 AM
ampdbi Offline
Registered User
 
Join Date: Oct 2011
Posts: 3
linuxfirefox
Re: Eagle Install Problem

I thought so. Is there a way to install libfreetype through yum? I couldn't find it.
Reply With Quote
  #4  
Old 24th October 2011, 06:42 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,928
linuxfirefox
Re: Eagle Install Problem

Try something like 'yum provides libfreetype' to find out what package it is in.
Reply With Quote
  #5  
Old 24th October 2011, 05:31 PM
ampdbi Offline
Registered User
 
Join Date: Oct 2011
Posts: 3
linuxfirefox
Re: Eagle Install Problem

Thanks, found the package! But it still won't install. I don' t think it likes having both versions. Any ideas?

Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package freetype.i686 0:2.4.4-4.fc15 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: freetype-2.4.4-4.fc15.i686 != freetype-2.4.4-5.fc15.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Reply With Quote
Reply

Tags
eagle, install, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cadsoft eagle g8jvm Using Fedora 4 7th October 2010 10:11 AM
Aztech DSL 208U and Eagle USB 2.0.0 driver on Fedora 7 hsaleem1 Using Fedora 0 15th September 2007 09:20 AM
try to install eagle usb driver leaves me with error: kernel-sources cannot be found! rapaneli Using Fedora 1 6th July 2007 11:38 AM
eagle usb Forum hussram Using Fedora 2 9th January 2006 06:17 PM
fc2 eagle-usb divali Using Fedora 1 15th November 2005 12:40 PM


Current GMT-time: 02:47 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Baratie - Mandala Beach Mojacar!! Photos on Instagram - Santana De Parnaiba Photos