Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #76  
Old 29th May 2014, 12:34 AM
debo2011 Offline
Registered User
 
Join Date: Jan 2012
Location: all world
Posts: 114
linuxfirefox
Re: PostInstallerF

This is the Future of PostInstallerF, I am rewriting and redesigning PostInstallerF. Coming Soon



More Info here
Reply With Quote
  #77  
Old 4th September 2014, 05:44 PM
debo2011 Offline
Registered User
 
Join Date: Jan 2012
Location: all world
Posts: 114
linuxfirefox
Re: PostInstallerF

and finally PostInstallerF 1.5. Enjoy!
Reply With Quote
  #78  
Old 4th September 2014, 07:37 PM
tdell Online
Registered User
 
Join Date: Feb 2009
Posts: 65
linuxchrome
Re: PostInstallerF

Downloaded but will not install due to unresolved dependencies
__________________
Wrath of the Manrat
https://www.createspace.com/4674043
Reply With Quote
  #79  
Old 4th September 2014, 09:32 PM
broadstairs Online
Registered User
 
Join Date: Nov 2011
Location: UK
Posts: 345
linuxfirefox
Re: PostInstallerF

I just installed this but was horrified when APPER said it had just installed a whole bunch of stuff not directly related to PostintallerF. Only thing which showed initially was a new version of PostInstallerF. So where did all this other stuff come from? I dont asppreciate it installed loads of other stuff .... All that was installed in pricipal was PostInstallerF and App-install-data-postinstallerf but Apper showed me a whole list of new apps installed WHY?

Stuart
Reply With Quote
  #80  
Old 5th September 2014, 12:17 AM
debo2011 Offline
Registered User
 
Join Date: Jan 2012
Location: all world
Posts: 114
linuxfirefox
Re: PostInstallerF

Quote:
Originally Posted by tdell View Post
Downloaded but will not install due to unresolved dependencies
@tdell unresolved dependencies? sorry but you need update...o upgrade, It only work for f20 -f22

How to update?

Code:
su
yum clean metadata
yum -y update

Quote:
Originally Posted by broadstairs View Post
I just installed this but was horrified when APPER said it had just installed a whole bunch of stuff not directly related to PostintallerF. Only thing which showed initially was a new version of PostInstallerF. So where did all this other stuff come from? I dont asppreciate it installed loads of other stuff .... All that was installed in pricipal was PostInstallerF and App-install-data-postinstallerf but Apper showed me a whole list of new apps installed WHY?

Stuart
I have no control over sub dependencies.

Dependencies

My current system...

Code:
[makerpm@localhost ~]$ uname -a
Linux localhost.localdomain 3.15.10-200.fc20.x86_64 #1 SMP Thu Aug 14 15:39:24 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
[makerpm@localhost ~]$
checking dependencies

Quote:
[makerpm@localhost ~]$ rpm -q --requires postinstallerf
/bin/bash
/bin/sh
/bin/sh
ImageMagick
PackageKit
SDL_mixer
app-install-data-postinstallerf
binutils
curl
dnf
pulseaudio-utils
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
wget
xterm
yad
zenity
rpmlib(PayloadIsXz) <= 5.2-1

Code:
[makerpm@localhost ~]$ rpm -q --requires app-install-data-postinstallerf
/bin/sh
ImageMagick
binutils
libpng
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

Last edited by debo2011; 5th September 2014 at 12:33 AM.
Reply With Quote
  #81  
Old 5th September 2014, 03:01 AM
tdell Online
Registered User
 
Join Date: Feb 2009
Posts: 65
linuxchrome
Re: PostInstallerF

OK got it installed, the only problem I see is it does not update the lastest version of Frostwire.
__________________
Wrath of the Manrat
https://www.createspace.com/4674043
Reply With Quote
  #82  
Old 5th September 2014, 07:36 AM
debo2011 Offline
Registered User
 
Join Date: Jan 2012
Location: all world
Posts: 114
linuxfirefox
Re: PostInstallerF

Quote:
Originally Posted by tdell View Post
OK got it installed, the only problem I see is it does not update the lastest version of Frostwire.
Coming soon
Reply With Quote
  #83  
Old 5th September 2014, 09:15 AM
broadstairs Online
Registered User
 
Join Date: Nov 2011
Location: UK
Posts: 345
linuxfirefox
Re: PostInstallerF

Quote:
I have no control over sub dependencies.
These were not sub-dependencies. I only saw two things installed postinstallerf and app-install-data-postinstallerf which were selected by Apper, however once installed the window opened in Apper giving me the option to run a whole bunch of installed programs some of which were games. This is what I dont understand - why did apper tell me that this whole bunch of stuff was available to run. Prior to running this update the system was fully updated and had been re-booted so there was nothing left for apper to complete etc.

One further observation, now you have to select a program before you can see the install status, it would be much improved in my view if the install status could be shown on the menu screen without having to select the item first.

Stuart
Reply With Quote
  #84  
Old 5th September 2014, 09:35 AM
broadstairs Online
Registered User
 
Join Date: Nov 2011
Location: UK
Posts: 345
linuxfirefox
Re: PostInstallerF

Just installed this new version on my laptop and got the same message, see attached image. Can you explain why this is happening? Once again this was the only thing installed as on my previous PC.

Stuart

PS> It would appear that none of these are actually installed according to APPER now, however this message is VERY misleading and something should be done about it.
Attached Thumbnails
Click image for larger version

Name:	snapshot1.png
Views:	59
Size:	110.4 KB
ID:	26235  

Last edited by broadstairs; 5th September 2014 at 10:36 AM.
Reply With Quote
  #85  
Old 5th September 2014, 09:56 PM
debo2011 Offline
Registered User
 
Join Date: Jan 2012
Location: all world
Posts: 114
linuxubuntufirefox
Re: PostInstallerF

Quote:
Originally Posted by broadstairs View Post
These were not sub-dependencies. I only saw two things installed postinstallerf and app-install-data-postinstallerf which were selected by Apper, however once installed the window opened in Apper giving me the option to run a whole bunch of installed programs some of which were games. This is what I dont understand - why did apper tell me that this whole bunch of stuff was available to run. Prior to running this update the system was fully updated and had been re-booted so there was nothing left for apper to complete etc.

One further observation, now you have to select a program before you can see the install status, it would be much improved in my view if the install status could be shown on the menu screen without having to select the item first.

Stuart
But you can use the checklist mode menu.


Quote:
Originally Posted by broadstairs View Post
Just installed this new version on my laptop and got the same message, see attached image. Can you explain why this is happening? Once again this was the only thing installed as on my previous PC.

Stuart

PS> It would appear that none of these are actually installed according to APPER now, however this message is VERY misleading and something should be done about it.
Is a joke? The message said there are pending updates .. an now change to you have new programs... remember "You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that." This error is not related to PostInstallerF; and usually happens because you do not have a culture of update. I recommend you, clean the cache packagekit.

From a terminal ...

Code:
su
pkcon refresh
pkcon update
dnf -y update
Please report this isue with apper, could be a bug.

Last edited by debo2011; 5th September 2014 at 10:23 PM.
Reply With Quote
  #86  
Old 5th September 2014, 10:03 PM
broadstairs Online
Registered User
 
Join Date: Nov 2011
Location: UK
Posts: 345
linuxfirefox
Re: PostInstallerF

Sorry, there is no way I have ever tried to install these programs, there was nothing outstanding on my system and it had been FULLY updated prior to installing postinstallerf. I cannot see anywhere it says that there are pending updates in that screen shot. This happened on two different PCs both of which had ALL outstanding updates installed. Other programs have installed before this with no such messages. The ONLY thing I installed was postinstallerf.
Reply With Quote
  #87  
Old 5th September 2014, 11:46 PM
broadstairs Online
Registered User
 
Join Date: Nov 2011
Location: UK
Posts: 345
linuxfirefox
Re: PostInstallerF

With regard to the Checklist Mode Menu does this only show if the program wsa actually installed with postinstallerf? I tried running it and at least two programs show up as Not Installed but in fact were already installed by me outside of postinstallerf.
Reply With Quote
  #88  
Old 6th September 2014, 05:17 AM
debo2011 Offline
Registered User
 
Join Date: Jan 2012
Location: all world
Posts: 114
linuxfirefox
Re: PostInstallerF

Quote:
Originally Posted by broadstairs View Post
Sorry, there is no way I have ever tried to install these programs, there was nothing outstanding on my system and it had been FULLY updated prior to installing postinstallerf. I cannot see anywhere it says that there are pending updates in that screen shot. This happened on two different PCs both of which had ALL outstanding updates installed. Other programs have installed before this with no such messages. The ONLY thing I installed was postinstallerf.
checking requires....

Code:
[makerpm@localhost ~]$ rpm -q --requires postinstallerf
wget
binutils
yad
zenity
curl
SDL_mixer
xterm
pulseaudio-utils
ImageMagick
app-install-data-postinstallerf
PackageKit
rpm-build
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
[makerpm@localhost ~]$

Code:
[makerpm@localhost ~]$ rpm -q --requires app-install-data-postinstallerf
/bin/sh
ImageMagick
binutils
libpng
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
[makerpm@localhost ~]$

Now checking if provides some packages...

Code:
[makerpm@localhost ~]$ rpm -q --provides postinstallerf
postinstallerf = 1.5-13.fc20
[makerpm@localhost ~]$
Code:
[makerpm@localhost ~]$ rpm -q --provides app-install-data-postinstallerf
app-install-data-postinstallerf = 1.0-9.fc20
NONE only the package
sorry, this problem isn't related to PostInstallerF; if you want to review the source code is at your disposal, also if you want check if PostInstallerF run occult.

Code:
ps -A | grep postinstaller
pstree
If you believe the PostInstallerf is responsible, please remove PostInstallerF

I just installed a new spin with KDE today, and not ask me programs I saw in your screenshot...

Last edited by debo2011; 6th September 2014 at 05:33 AM.
Reply With Quote
Reply

Tags
postinstallation fedora, postinstallerf, repositories, scripts, sudeenly

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Current GMT-time: 14:27 (Thursday, 18-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Cala Llenguadets Photos on Instagram - Killing Fields, Siem Reap Travel Photos - Novotel Hotel Kolkata Instagram Photos - American Embassy Estates,Cantoments Travel Photos - Calle De Los Suspiros, Colonia Del Sacramento Uruguay