Fedora Linux Support Community & Resources Center
  #1  
Old 13th April 2004, 11:17 PM
Finalzone Online
Community Manager
 
Join Date: Mar 2004
Location: Vancouver, Canada
Posts: 2,493
Enable alsa soundcard always on

Each time I reboot, the sound is always muted. Unfortunately, FC2 mute the sound configuration each time I shut down the computer. How can I leave the alsa soundcard unmuted?
  #2  
Old 14th April 2004, 03:33 AM
mars_hall Offline
Registered User
 
Join Date: Feb 2004
Location: S.E. USA
Age: 52
Posts: 135
are you using core 2 test 1? or core 2 test 2?
  #3  
Old 14th April 2004, 08:39 AM
Finalzone Online
Community Manager
 
Join Date: Mar 2004
Location: Vancouver, Canada
Posts: 2,493
FC2 Test 2. It also happened with Test 1. It could be a minor issue.
__________________
Desktop CPU: AMD Phenom II(tm) X4 Processor 940 AM2+ - Memory: 8GB DDR2-RAM - GPU: Nvidia Geforce GTX 460 v2 - OS: Fedora 21 Workstation Alpha x86-64 and Windows 7 Ultimate SP1 64-bit
Laptop Sony VAIO N250E - OS: Fedora 21 Alpha Design Suite i386.
  #4  
Old 14th April 2004, 03:39 PM
foolish Offline
Retired Community Manager
 
Join Date: Feb 2004
Location: Aalesund, Norway
Age: 28
Posts: 1,888
You have to set the volumes once, then as root do :
Code:
alsactl store
You have to run alsactl restore sometime during boot, one way is to have it run as soon as you load the modules. You can also tell alsactl to store the volumes when the modules are unloaded, so that the volume will always be like they were the last time you shut down your computer.

My example uses the snd-emu10k1 module, as I have a sblive card. Replace this with the name of your module. Which you can find in your /etc/modprobe.conf. But I'm sure you know this, you are using a test release after all.

Add this to /etc/modprobe.conf

Code:
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-emu10k1

This should be in there already, I don't know why it isn't, as a tester it is your responsiblity to investigate and report issues like this.
__________________
Sindre Pedersen Bjørdal || http://www.fedorasolved.org || Hardware Profile
- Please adhere to the FedoraForum Guidelines.

Last edited by foolish; 14th April 2004 at 03:46 PM.
  #5  
Old 14th April 2004, 05:23 PM
Ug Offline
Retired Community Manager
 
Join Date: Feb 2004
Posts: 2,999
Moved.
__________________
gareth@fedoraforum.org
Registered Linux User # 301555
garethrussell.net


Please adhere to the FedoraForum Guidelines.
  #6  
Old 14th April 2004, 07:45 PM
Finalzone Online
Community Manager
 
Join Date: Mar 2004
Location: Vancouver, Canada
Posts: 2,493
Here is the source code from /etc/modprobe.conf
Quote:
nstall sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
Using aumix command, I found out the volume was minimal and muted. I set it to max and save it. Since then, the issue is solved. Thanks for the tip about /etc/modprobe.conf.
__________________
Desktop CPU: AMD Phenom II(tm) X4 Processor 940 AM2+ - Memory: 8GB DDR2-RAM - GPU: Nvidia Geforce GTX 460 v2 - OS: Fedora 21 Workstation Alpha x86-64 and Windows 7 Ultimate SP1 64-bit
Laptop Sony VAIO N250E - OS: Fedora 21 Alpha Design Suite i386.
 

Tags
alsa, enable, soundcard

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Alsa sound problems on 64 bit caused by multiple alsa pulse audio plugins jinliew Hardware & Laptops 3 23rd June 2009 09:42 AM
Installation of soundcard which is not in Core 6 ALSA but is available at AlsaProject spintonik Hardware & Laptops 5 12th February 2007 06:40 AM
How to enable alsa-oss mebrelith Using Fedora 0 9th November 2005 07:00 PM
alsa mixer and soundcard Robgould Using Fedora 1 27th April 2005 04:18 AM


Current GMT-time: 01:34 (Friday, 19-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram