Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Security and Privacy
FedoraForum Search

Forgot Password? Join Us!

Security and Privacy Sadly, malware, spyware, hackers and privacy threats abound in today's world. Let's be paranoid and secure our penguins, and slam the doors on privacy exploits.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 30th January 2007, 03:48 PM
alpha645 Offline
Registered User
 
Join Date: Jul 2006
Posts: 740
Selinux is not listening >.<

Recently I had to edit Selinux to let it work with samba. However, I accidentaly checked under admin: 'Do not allow any process to change the Selinux policy'. So, I cannot edit the selinux policy anymore. This seems like an beginners error, but I can't find a work-around for it
Reply With Quote
  #2  
Old 2nd February 2007, 04:07 AM
Jman Offline
Registered User
 
Join Date: Mar 2004
Location: Minnesota, USA
Age: 28
Posts: 7,909
I would think you can just uncheck that in system-config-securitylevel. Or maybe you can reboot with it disabled. The FAQ may help: http://fedora.redhat.com/docs/selinux-faq/
Reply With Quote
  #3  
Old 2nd February 2007, 05:48 AM
alpha645 Offline
Registered User
 
Join Date: Jul 2006
Posts: 740
Quote:
Originally Posted by Jman
I would think you can just uncheck that in system-config-securitylevel. Or maybe you can reboot with it disabled. The FAQ may help: http://fedora.redhat.com/docs/selinux-faq/
That is just the weird part, I can not edit the policy. It's useless, saving en then reopening it shows that it is still checked. I do get AVC errors, but I can't edit the policy. For now, I completely disabled it.
Reply With Quote
  #4  
Old 6th February 2007, 04:53 PM
rhatdan Offline
Registered User
 
Join Date: Feb 2007
Posts: 29
Setting this boolean, basically removes any capability of modifying selinux policy in enforcing mode. So if you want to modify the policy, you need to boot in permissive mode, or single user mode.

enforcing=0 on the boot line will boot in permissive mode.
Reply With Quote
  #5  
Old 6th February 2007, 05:54 PM
alpha645 Offline
Registered User
 
Join Date: Jul 2006
Posts: 740
Quote:
Originally Posted by rhatdan
Setting this boolean, basically removes any capability of modifying selinux policy in enforcing mode. So if you want to modify the policy, you need to boot in permissive mode, or single user mode.

enforcing=0 on the boot line will boot in permissive mode.
I already solved that, but thanks . In fact, I think I'm going to write a good howto for Selinux. Because it's actually really easy to use.
Reply With Quote
Reply

Tags
><, listening, selinux

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
listening in... Wiles Security and Privacy 3 16th July 2007 12:06 AM
XDMCP is not listening on FC5 kurifu EOL (End Of Life) Versions 6 13th June 2006 06:07 PM
Listening on Ports? teknowiztx Servers & Networking 8 7th July 2005 09:36 PM
GUI problems with VNC Listening Arseman03 Using Fedora 1 18th January 2005 01:33 AM


Current GMT-time: 07:49 (Wednesday, 23-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat