Fedora Linux Support Community & Resources Center
Prev Previous Post   Next Post Next
  #1  
Old 29th March 2006, 08:25 PM
jsweatte Offline
Registered User
 
Join Date: Apr 2005
Posts: 2
eth0 is active but no internet connection. New FC5 install

I've just installed FC5 from cdrom isos onto a Dell D810. I have looked through quite a few threads but nothing I've seen...and tried, has resolved the issue. Essentially eth0, a BCM5751 using the TG3 driver, goes active but it appears DHCP or DNS, or both?, isn't working. I've checked network manager, as seen on several threads, and it looks to be active.

/etc/sysconfig/network-scripts/ifcfg-eth0 reads as follows;
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=xxxxx
ONBOOT=yes
DHCP_HOSTNAME=whatever
USERCTL=no
IPV6INIT=no
PEERDNS=yes
TYPE=Ethernet

/etc/modprobe.conf reads as follows;
alias eth0 tg3
alias scsi_hostadapter ata_piix
alias eth1 ipw2200
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0....
options tg3

dmesg has some interesting text relevant to eth0 it reads;
eth0: Tigon3 (partno(BCM95751) rev 4001 PHY(5750) (PCI Express) 10/100/1000BaseT Ethernet...
...
tg3: eth0: link is up at 10 mbps, half duplex
tg3: eth0: Flow control is off for TX and off for RX
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
eth0: no IPv6 routers present
...
the previous series of messages starting at tg3 repeats.

I looked at /etc/resolv.conf but the only thing in it is a comment that reads as follows;
# generated by NetworkManager, do not edit!

I have not tried static addressing which I would prefer to avoid if possible.

lspci shows;
Ethernet controller: Broadcom Corpporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)

I also have a Intel PRO/Wireless card at eth1 but I haven't tried to do anything with that. It does not go active at boot.

I'll be glad to provide further info as needed and I appreciate any help provided.
Thanks
Jsweatte
Reply With Quote
 

Tags
active, connection, eth0, fc5, install, internet

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I Install VLC Without Internet Connection? abrock Using Fedora 2 5th January 2008 10:25 PM
Internet Connection Sharing, Desktop (F7,eth0) to Laptop (WinXP, Wireless)? Llanowyn Servers & Networking 1 7th June 2007 07:23 PM
Yum without an active internet connection kombucha Using Fedora 1 2nd July 2006 03:03 AM
laptop DV1000 - cannot active eth0 trung_bmt Servers & Networking 2 20th December 2005 10:46 AM


Current GMT-time: 15:31 (Thursday, 31-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat