Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Security and Privacy
FedoraForum Search

Forgot Password? Join Us!

Security and Privacy Sadly, malware, spyware, hackers and privacy threats abound in today's world. Let's be paranoid and secure our penguins, and slam the doors on privacy exploits.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 16th March 2005, 01:04 PM
jort Offline
Registered User
 
Join Date: Feb 2005
Location: Utrecht, The Netherlands
Posts: 35
Disable direct root login

Hello,

I'm trying to disable direct root login via SSH. There are lots of tutorials available via Google how to disable direct root login.

The tutorial:
Quote:
1. SSH into your server as 'admin' and gain root access by su

2. Copy and paste this line to edit the file for SSH logins
pico -w /etc/ssh/sshd_config

3. Find the line
Protocol 2, 1

4. Uncomment it and change it to look like
Protocol 2

5. Next, find the line
PermitRootLogin yes

6. Uncomment it and make it look like PermitRootLogin no

7. Save the file Ctrl+X then Y then enter

8. Now you can restart SSH
/etc/rc.d/init.d/sshd restart
But when I open a shell (terminal) and type
Code:
ssh -l jort MY-IP-ADDRESS
, I get no response. What do I have to do?
Reply With Quote
  #2  
Old 16th March 2005, 03:18 PM
awdac Offline
Registered User
 
Join Date: Feb 2005
Location: Athens, GA
Posts: 352
Are you saying that you can't log in via ssh at all anymore, or just as jort? Are you sure the firewall is not blocking connections to port 22? If you are getting no response, it sounds like it's getting blocked, rather than sshd denying you.
__________________
Registered Linux User #240607
2001-11-02 03:17:23
Reply With Quote
  #3  
Old 16th March 2005, 04:21 PM
jort Offline
Registered User
 
Join Date: Feb 2005
Location: Utrecht, The Netherlands
Posts: 35
Quote:
Originally Posted by awdac
Are you saying that you can't log in via ssh at all anymore, or just as jort? Are you sure the firewall is not blocking connections to port 22? If you are getting no response, it sounds like it's getting blocked, rather than sshd denying you.
Could it have something to do with the fact that I'm trying to connect from and to the same computer? Port 22 is open to everybody according to Firestarter.
Reply With Quote
  #4  
Old 31st March 2005, 10:30 PM
bcruze Offline
Registered User
 
Join Date: Mar 2005
Age: 33
Posts: 13
http://www.webhostgear.com/24.html

works for me
Reply With Quote
  #5  
Old 1st April 2005, 02:58 PM
jort Offline
Registered User
 
Join Date: Feb 2005
Location: Utrecht, The Netherlands
Posts: 35
I'm sure that's a good article, but I even cannot log on via SSH on my computer.

I open a terminal and type SSH [hostname] and just get no response.

What to do?
Reply With Quote
  #6  
Old 1st April 2005, 03:39 PM
w5set Offline
Registered User
 
Join Date: Feb 2005
Location: ark n saw out in the sticks
Posts: 2,316
You are trying to logon the same computer that you are using the keyboard on--using SSH?
Reply With Quote
  #7  
Old 1st April 2005, 04:39 PM
jort Offline
Registered User
 
Join Date: Feb 2005
Location: Utrecht, The Netherlands
Posts: 35
Quote:
Originally Posted by w5set
You are trying to logon the same computer that you are using the keyboard on--using SSH?
Yes, I am.
Reply With Quote
Reply

Tags
direct, disable, login, root

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No root login allowed at login screen - Fedora 10 mitchellray Using Fedora 2 2nd April 2009 02:13 AM
f10 can't login root at login screen - su works fine bobatlcpmbdx Using Fedora 2 1st January 2009 04:36 PM
fedora 10 auto login and root login issue pcandpc Using Fedora 0 22nd December 2008 04:44 PM
strange direct rendering problem (root has DRI, other users don't) sweetrain Using Fedora 1 6th September 2007 08:02 PM
disable root X login axelseap Security and Privacy 6 24th February 2006 03:43 AM


Current GMT-time: 17:52 (Friday, 19-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat