Fedora Linux Support Community & Resources Center
  #1  
Old 2nd June 2013, 05:12 PM
flashl Offline
Registered User
 
Join Date: May 2008
Posts: 20
windows_7ie
Yum fc18 to fc19 upgrade error

I'm stuck between fc18 and fc19, meaning kernel is fc18 and fedora-release is fc19. I used fedora-update to upgrade, the system froze during yum update. Efforts to recover includes: yum-complete-transaction, rpm rebuilddb, yum clean all, etc. Presently using yum releasever=19 distro-sync. Yum terminates with traceback.
PHP Code:
---> Package systemd.x86_64 0:201-2.fc18.7 will be updated
--> Processing Dependencysystemd 201-2.fc18.7 for packagesystemd-python-201-2.fc18.7.x86_64
--> Processing Dependencysystemd 201-2.fc18.7 for packagelibgudev1-201-2.fc18.7.x86_64
--> Processing Dependencysystemd 201-2.fc18.7 for packagesystemd-sysv-201-2.fc18.7.x86_64
Traceback 
(most recent call last):
  
File "/bin/yum"line 29in <module>
    
yummain.user_main(sys.argv[1:], exit_code=True)
  
File "/usr/share/yum-cli/yummain.py"line 319in user_main
    errcode 
main(args)
  
File "/usr/share/yum-cli/yummain.py"line 185in main
    
(resultresultmsgs) = base.buildTransaction() 
  
File "/usr/lib/python2.7/site-packages/yum/__init__.py"line 1146in buildTransaction
    
(rescoderestring) = self.resolveDeps()
  
File "/usr/lib/python2.7/site-packages/yum/depsolve.py"line 908in resolveDeps
    
if self._checkObsoletes():
  
File "/usr/lib/python2.7/site-packages/yum/depsolve.py"line 1329in _checkObsoletes
    
for po in self.rpmdb.returnObsoletePackages():
AttributeError'RPMDBPackageSack' object has no attribute 'returnObsoletePackages' 
The problem appears to be "systemd". My observation when using yum -d 9 is, yum attempts to obsolete fc19 systemd and update/upgrade with fc18 systemd.

Is there a yum setting to change the systemd conflict behavior?

Thanks in advance
Reply With Quote
Reply

Tags
error, fc18, fc19, upgrade, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[FC18/KDE] RPMDB was altered outside of yum. majestyx Using Fedora 4 28th February 2013 09:16 AM
Yum upgrade from fc8 to fc9. Yum error. Tobbz Installation, Upgrades and Live Media 1 22nd September 2008 09:02 PM
64 bit Fedora 8 does NOT upgrade (yum upgrade error) ichudov Using Fedora 1 13th November 2007 06:20 AM
Yum upgrade error :( Error: MD5 Signature leoleMCH Using Fedora 4 28th June 2005 10:46 PM


Current GMT-time: 12:28 (Thursday, 02-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat