Fedora Linux Support Community & Resources Center
  #1  
Old 10th April 2013, 02:26 PM
mpajoh Offline
Registered User
 
Join Date: May 2006
Location: Oklahoma
Posts: 334
windows_xp_2003firefox
Multilib version problems found

Last night I tried:
Code:
sudo yum update
and after many lines of "software being updated", I got the following:
Code:
 Dependency Resolution Errors:

 Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

  1. You have an upgrade for audit-libs which is missing some
     dependency that another package requires. Yum is trying to
     solve this by installing an older version of audit-libs of the
     different architecture. If you exclude the bad architecture
     yum will tell you what the root cause is (which package
     requires what). You can try redoing the upgrade with
     --exclude audit-libs.otherarch ... this should give you an error
     message showing the root cause of the problem.

  2. You have multiple architectures of audit-libs installed, but
     yum can only see an upgrade for one of those arcitectures.
     If you don't want/need both architectures anymore then you
     can remove the one with the missing update and everything
     will work.

  3. You have duplicate versions of audit-libs installed already.
     You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: audit-libs-2.2.3-2.fc18.i686 != audit-libs-2.2.2-3.fc18.x86_64
I did:
Code:
yum check
the result was more or less the as when I tried:
Code:
package-cleanup --orphans
the result of which is attached.

This is a long list of problems. I have corrected similar things in the past by brute force and many hours of work.

Now, since this is F18, I am hoping someone will have better, i.e. less cumbersome, suggestion or tool, other than a clean reinstall.

This a system that I have had for a long time to learn Linux on.
It has been through several "preupgrades" and at last a "fedup" and now is running F18 fairly well.


I thank everyone for any pointers ahead of time.

Masoud
Attached Files
File Type: log orphans.log (24.6 KB, 224 views)
__________________
I use F20 and Gnome, with all updates applied, on a X86_64 kernel with 4gb of DRAM and Evga Geforce 7600 GS PCI-E 256mb DDR2 video card.
Reply With Quote
  #2  
Old 10th April 2013, 03:24 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 5,854
linuxfirefox
Re: Multilib version problems found

What happens when you do:
Code:
yum update audit-libs.i686 audit-libs.x86_64
I just checked and matching version-release packages are in the updates repo (at least in the ones I'm checking).
Code:
[paul@ScorpioBlue ~]$ sudo yum list audit-libs
Loaded plugins: langpacks, presto
Installed Packages
audit-libs.x86_64                                              2.2.3-2.fc18                                               @updates
Available Packages
audit-libs.i686                                                2.2.3-2.fc18                                               updates
Reply With Quote
  #3  
Old 10th April 2013, 03:51 PM
mpajoh Offline
Registered User
 
Join Date: May 2006
Location: Oklahoma
Posts: 334
windows_xp_2003firefox
Re: Multilib version problems found

PabloTwo;
Thank you so much for your time.
I will try that when I get home.

Thanks again.

Masoud
__________________
I use F20 and Gnome, with all updates applied, on a X86_64 kernel with 4gb of DRAM and Evga Geforce 7600 GS PCI-E 256mb DDR2 video card.
Reply With Quote
  #4  
Old 11th April 2013, 05:42 PM
mpajoh Offline
Registered User
 
Join Date: May 2006
Location: Oklahoma
Posts: 334
windows_xp_2003firefox
Re: Multilib version problems found

Quote:
Originally Posted by PabloTwo View Post
What happens when you do:
Code:
yum update audit-libs.i686 audit-libs.x86_64
I tried that but still the same message came up!
Then I did
Code:
yum erase audit-libs-2.2.2-3.fc18.i686 audit-libs-2.2.2-3.fc18.x86_64
It also erased audit-devel for dependency.
Then I did:
Code:
yum install audit-libs.i686 audit-libs.x86_64
and it installed:
Code:
audit-libs-2.2.3-2.fc18.i686
audit-libs-2.2.3-2.fc18.x86_64
and all dependencies needed
after this the rest updates went fine.

Thanks for the help.

Masoud
__________________
I use F20 and Gnome, with all updates applied, on a X86_64 kernel with 4gb of DRAM and Evga Geforce 7600 GS PCI-E 256mb DDR2 video card.

Last edited by mpajoh; 25th April 2013 at 02:28 AM. Reason: for accuracy
Reply With Quote
  #5  
Old 24th April 2013, 03:55 PM
LeFou Offline
Registered User
 
Join Date: May 2006
Posts: 67
linuxfirefox
Re: Multilib version problems found

I just tried this and

yum erase audit-libs.i686 audit-libs.x86_64

resulted in F18 trying to remove what looked like everything on the system and then saying

Quote:
Error: Trying to remove "systemd", which is protected
Error: Trying to remove "yum", which is protected
Reply With Quote
  #6  
Old 25th April 2013, 02:32 AM
mpajoh Offline
Registered User
 
Join Date: May 2006
Location: Oklahoma
Posts: 334
linuxfirefox
Re: Multilib version problems found

LeFou:
Please check my previous post again.
I edited it in an attempt to clarify what I did.
I mind you, this is somewhat from my memory, but it should be mostly correct.
But before letting the system delete important stuff make sure, as it seems that you are doing, you are doing the right thing.

Good luck.

Masoud
__________________
I use F20 and Gnome, with all updates applied, on a X86_64 kernel with 4gb of DRAM and Evga Geforce 7600 GS PCI-E 256mb DDR2 video card.
Reply With Quote
  #7  
Old 26th April 2013, 08:50 PM
LeFou Offline
Registered User
 
Join Date: May 2006
Posts: 67
linuxfirefox
Re: Multilib version problems found

I have not let the system delete anything. I did the yum erase of adit-livs (i686 and _64 both)
reinstalled, etc. I now have

Code:
yum list audit-libs
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
audit-libs.i686                      2.2.3-2.fc18                    @updates
audit-libs.x86_64                    2.2.3-2.fc18                    @updates
But yum update still fails with :

Error: Multilib version problems found. This often means that the root ...

---------- Post added at 11:50 AM ---------- Previous post was at 11:49 AM ----------

Immediately before the "Multilib version" error was this output :

Code:
--> Running transaction check
---> Package kernel.x86_64 0:3.6.10-4.fc18 will be erased
---> Package kernel-modules-extra.x86_64 0:3.6.10-4.fc18 will be erased
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
Reply With Quote
  #8  
Old 27th April 2013, 03:51 PM
mpajoh Offline
Registered User
 
Join Date: May 2006
Location: Oklahoma
Posts: 334
linuxfirefox
Re: Multilib version problems found

[QUOTE=LeFou;1648997]
Quote:
...

Error: Multilib version problems found. This often means that the root ...

....]
Is this complaining about audit-libs?

If you post more of the error maybe someone could help.

Masoud
__________________
I use F20 and Gnome, with all updates applied, on a X86_64 kernel with 4gb of DRAM and Evga Geforce 7600 GS PCI-E 256mb DDR2 video card.
Reply With Quote
  #9  
Old 29th April 2013, 02:52 PM
LeFou Offline
Registered User
 
Join Date: May 2006
Posts: 67
linuxfirefox
Re: Multilib version problems found

I thought the original complaint was about audit-libs and that's how I found this thread. But currently the message is:

Code:
       Protected multilib versions: 1:v8-3.14.5.8-1.fc18.i686 != 1:v8-3.15.11.17-1.fc18.x86_64


---------- Post added at 05:52 AM ---------- Previous post was at 05:49 AM ----------

yum list v8

led me to the problem (fedora-chromium repo) so I disabled that and the update appears to be working now
Reply With Quote
  #10  
Old 29th April 2013, 04:18 PM
mpajoh Offline
Registered User
 
Join Date: May 2006
Location: Oklahoma
Posts: 334
windows_xp_2003firefox
Re: Multilib version problems found

Good deal.

Masoud
__________________
I use F20 and Gnome, with all updates applied, on a X86_64 kernel with 4gb of DRAM and Evga Geforce 7600 GS PCI-E 256mb DDR2 video card.
Reply With Quote
Reply

Tags
cleanup, multilib, orphans, problems, version

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error, version `GLIBC_2.3.3' not found andersgd Using Fedora 1 31st July 2005 10:25 PM


Current GMT-time: 23:30 (Sunday, 20-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat