Fedora Linux Support Community & Resources Center
  #1  
Old 22nd March 2013, 12:38 AM
leonardevens Offline
Registered User
 
Join Date: Dec 2006
Age: 81
Posts: 491
linuxfirefox
Grub2 problem: Can't display this Video Mode

This is a new attempt to get help on this matter. The previous thread is very long and contains irrelevant material, so, once I thought I discovered the problem, I thought I would start a new thread,

I installed Fedora 17 on a computer which had Windows 7 and Fedora 15 on it by doing fresh install. It just goes into Linux without giving me the option to choose what I want to boot. I've examined the /boot/grub2/grub.cfg file and there is an entry for booting windows 7 there, but I can't choose it.

When I boot I get a message on the screen saying
Can't Display This Video Mode.
I think the problem is that grub 2 is trying to put the monitor in a mode it doesn't recognize. So the grub2 boot choice screen is not displayed and after the timeout, it boots Linux.

My /etc/default/grub file says

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Fedora"
GRUB_DEFAULT=saved
GRUB_CMDLINE_LINUX="rd.lvm.lv=vg_dodgson/lv_root rd.md=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rd.lvm.lv=vg_dodgson/lv_swap rhgb quiet"
#GRUB_THEME="/boot/grub2/themes/system/theme.txt"

Some googling suggests the problem is the string 'rhgb', which appears in all the menuentry commands in
/boot/grub2/grub.cfg.

I haven't figure out what to change in /etc/default/grub to fix the problem,

Can anyone help me?

If I haven't diagnosed the problem correctly, please tell me where I've gone wrong. If I have come close to a correct diagnosis, please tell me what to do to fix it.

Finally, is there any chance that the problem arises from the monitor, which is a basic Dell monitor. Should I try another Acer monitor that I have?
Reply With Quote
  #2  
Old 22nd March 2013, 12:48 AM
solo2101 Offline
Registered User
 
Join Date: Jan 2010
Location: behind that screen...
Posts: 790
linuxchrome
Re: Grub2 problem: Can't display this Video Mode

I believe you can edit the command before booting the kernel... "e" is the key (i think)
remove the rhgb option that will help you troubleshoot the problem...
Reply With Quote
  #3  
Old 22nd March 2013, 12:51 AM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,365
linuxfirefox
Re: Grub2 problem: Can't display this Video Mode

Sounds like grub might be trying to use a video mode that your monitor doesn't support.

First thing I would try is pressing the 'c' key repeatedly after grub has started but before it
boots into Fedora. If you get a grub console onscreen with the 'grub>' prompt, enter 'vbeinfo'
(without the quotes) and see what grub thinks about available video modes, which one it is trying
to use, and whether it is correctly reading your monitor's edid block.

Whether you get the grub console or not, I think you might have to tell grub what video mode to
use. Do that by opening the /etc/default/grub file and adding, or editing the value GRUB_GFXMODE.

It should be something like GRUB_GFXMODE=1024x768

If the vbeinfo command works it should give you a list of possible modes, although since grub isn't
working right that list may be all wrong.

Your monitor's documentation might tell you which vesa bios extension (vbe) modes it supports, or
you can look for modes to try in your Xorg log file. The wikipedia page lists the standard modes:
http://en.wikipedia.org/wiki/VESA_BIOS_Extensions
Reply With Quote
  #4  
Old 22nd March 2013, 01:07 AM
solo2101 Offline
Registered User
 
Join Date: Jan 2010
Location: behind that screen...
Posts: 790
linuxchrome
Re: Grub2 problem: Can't display this Video Mode

My bad... I finally understand your problem... sorry

---------- Post added at 05:07 PM ---------- Previous post was at 04:55 PM ----------

Is it something similar to this?

http://karol.miaskiewicz.com/?p=532
Reply With Quote
  #5  
Old 22nd March 2013, 03:28 AM
triumphisme Offline
Registered User
 
Join Date: Mar 2013
Location: Vietnam
Posts: 1
windows_7chrome
Wink Re: Grub2 problem: Can't display this Video Mode

Quote:
Originally Posted by sonoran View Post
Sounds like grub might be trying to use a video mode that your monitor doesn't support.

First thing I would try is pressing the 'c' key repeatedly after grub has started but before it
boots into Fedora. If you get a grub console onscreen with the 'grub>' prompt, enter 'vbeinfo'
(without the quotes) and see what grub thinks about available video modes, which one it is trying
to use, and whether it is correctly reading your monitor's edid block.

Whether you get the grub console or not, I think you might have to tell grub what video mode to
use. Do that by opening the /etc/default/grub file and adding, or editing the value GRUB_GFXMODE.

It should be something like GRUB_GFXMODE=1024x768

If the vbeinfo command works it should give you a list of possible modes, although since grub isn't
working right that list may be all wrong.

Your monitor's documentation might tell you which vesa bios extension (vbe) modes it supports, or
you can look for modes to try in your Xorg log file. The wikipedia page lists the standard modes:
http://en.wikipedia.org/wiki/VESA_BIOS_Extensions
Hello, new member,
It's helpful, thanx
Reply With Quote
  #6  
Old 22nd March 2013, 04:37 AM
leonardevens Offline
Registered User
 
Join Date: Dec 2006
Age: 81
Posts: 491
linuxfirefox
Re: Grub2 problem: Can't display this Video Mode

Quote:
Originally Posted by sonoran View Post
Sounds like grub might be trying to use a video mode that your monitor doesn't support.

First thing I would try is pressing the 'c' key repeatedly after grub has started but before it
boots into Fedora. If you get a grub console onscreen with the 'grub>' prompt, enter 'vbeinfo'
(without the quotes) and see what grub thinks about available video modes, which one it is trying
to use, and whether it is correctly reading your monitor's edid block.

Whether you get the grub console or not, I think you might have to tell grub what video mode to
use. Do that by opening the /etc/default/grub file and adding, or editing the value GRUB_GFXMODE.

It should be something like GRUB_GFXMODE=1024x768

If the vbeinfo command works it should give you a list of possible modes, although since grub isn't
working right that list may be all wrong.

Your monitor's documentation might tell you which vesa bios extension (vbe) modes it supports, or
you can look for modes to try in your Xorg log file. The wikipedia page lists the standard modes:
http://en.wikipedia.org/wiki/VESA_BIOS_Extensions
When I press 'c' rpeatedly, I still get the
Cannot Display Video Mode
messsage, but then it hangs and fails to boot. I think c actually brings up the console, but I can't see it.

So I will next try GRUB_GX_MODE=....

I'm still a bit nervous about what to do next, so let me ask some questions.

After adding that line to /etc/default/grub, I assume i just run
/usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg.

But if that doesn't work, am I likely to lose the ability to boot Linux altogether? Will my supergrub2 CD still work? Or will I be able to use the Fedora 17 DVD to boot linux? (If worse comes to worse, I can reinstall Fedora 17 from the DVD, but I would rather not have to do that.)
Reply With Quote
  #7  
Old 22nd March 2013, 06:10 AM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,365
linuxfirefox
Re: Grub2 problem: Can't display this Video Mode

A possible workaround: open your /etc/default/grub file and add the entry
Code:
GRUB_TERMINAL=console
Then run grub2-mkconfig -o /boot/grub2/grub.cfg

That may at least make grub visible, so you can boot Windows and explore the grub configuration from the grub console.
Reply With Quote
  #8  
Old 22nd March 2013, 09:25 PM
leonardevens Offline
Registered User
 
Join Date: Dec 2006
Age: 81
Posts: 491
linuxfirefox
Re: Grub2 problem: Can't display this Video Mode

Quote:
Originally Posted by sonoran View Post
A possible workaround: open your /etc/default/grub file and add the entry
Code:
GRUB_TERMINAL=console
Then run grub2-mkconfig -o /boot/grub2/grub.cfg

That may at least make grub visible, so you can boot Windows and explore the grub configuration from the grub console.
That seems to have fixed it. At least I get a grub list of boot options, and I can boot either Fedora or Windows 7.

There may be other problems due to the convoluted history of this computer. I've been told, for example, in another thread, that I have a legacy grub MBR. But I always started with Windows on my disk and installed Fedora afterwards. I thought in such circumstances that all any version of grub would do was to modify the partition table and to insert an instruction in the MBR to go to a grub section in the Linux installtion to continue booting. Certainly, the last thing I did was to install Fedora 17 in space outside a Windows 7 partition, and that inolved only grub2.

I am entirely mystefied by the idea that legacy grub could have created the MBR.

---------- Post added at 12:25 PM ---------- Previous post was at 11:12 AM ----------

I am really puzzled now. Either
GRUB_TERMINAL=console
or
GRUB_GFXMODE=1024x768
works so I can see the grub menu of choices and boot

In particular I can boot Linux or Windows 7. But when I boot Linux and login to my account and then logout, X seems to hang and I get a blank screen. I can't login again or reboot. Ctrl-Alt-Bksp to restart X doesn't work. Also, when I am logged in, if I try to use system settings, the screen freezes when I click on some options. In either case, I have to turn the machine off and turn it on again.

It also seems that I lose the video when the screen saver comes on.

But, if I use the super grub2 CD, and ask it to boot Linux, it also goes into that grub menu and lets me boot , but then I don't have any problem logging out and getting the right login screen.

So it appears that something is still wrong with my grub.cfg file which seems to affect X.
Any other suggestions of what to try. Since I can get the grub menu, I can presumably try troubleshooting from there by trying various things, if I knew what to try.

Last edited by leonardevens; 22nd March 2013 at 11:44 PM.
Reply With Quote
  #9  
Old 23rd March 2013, 03:52 AM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,365
linuxfirefox
Re: Grub2 problem: Can't display this Video Mode

Quote:
Originally Posted by leonardevens View Post
I am really puzzled now. Either
GRUB_TERMINAL=console
or
GRUB_GFXMODE=1024x768
works so I can see the grub menu of choices and boot
When you are at the grub menu, try hitting the 'c' key, and then at the grub> prompt run the vbeinfo
command. If you are using a digital monitor, do you know what its native resolution is? That
1024x768 is just a standard mode, there might be something better to try.

Have you tried only using the GRUB_GFXMODE=1024x768 setting, without the GRUB_TERMINAL=console? I think
the latter is more drastic, and if the former gets you a grub2 menu it would be preferable, and maybe
better-looking.

---------- Post added at 03:52 AM ---------- Previous post was at 03:40 AM ----------

Quote:
Originally Posted by leonardevens View Post
That seems to have fixed it.
Not really, it's just bypassing the mis-installation or mis-configuration. Even if it isn't
related to the logout/reboot issue, you never know when the underlying problem is going to bite
you again, maybe somewhere else.

I think I would re-install grub2 in the supported manner - to the MBR, not trying to force it onto
a partition, because there are too many ways that can go wrong, both during and after installation.

From a root terminal,
Code:
grub2-install /dev/sda
I don't know if that will overwrite your /etc/default/grub file and the changes you made. If it
doesn't you might revert the changes to see if a new grub2 will work normally. If you don't get
the grub menu you can always edit the file again.

Before rebooting you have to run 'grub2-mkconfig -o /boot/grub2/grub.cfg'.

Quote:
I am entirely mystefied by the idea that legacy grub could have created the MBR.
If you were trying to install F17's grub2 to a partition, it could happen.

Quote:
But when I boot Linux and login to my account and then logout, X seems to hang and I get a blank screen.
One hurdle at a time. Once you get grub2 working right the problem might go away. If not you should
probably open a new thread for that.
Reply With Quote
  #10  
Old 23rd March 2013, 04:26 AM
leonardevens Offline
Registered User
 
Join Date: Dec 2006
Age: 81
Posts: 491
linuxfirefox
Re: Grub2 problem: Can't display this Video Mode

I am really puzzled now. Either
GRUB_TERMINAL=console
or
GRUB_GFXMODE=1024x768
works so I can see the grub menu of choices and boot

In particular I can boot Linux or Windows 7. But when I boot Linux and login to my account and then logout, X seems to hang and I get a blank screen. I can't login again or reboot. Ctrl-Alt-Bksp to restart X doesn't work. Also, when I am logged in, if I try to use system settings, the screen freezes when I click on some options. In either case, I have to turn the machine off and turn it on again.

I thought it worked if I booted using a supergrub2 CD, but now I can't get that to work either.

So it appears that something is still wrong with my grub.cfg file which seems to affect X.
Any other suggestions of what to try. Since I can get the grub menu, I can presumably try troubleshooting from there by trying various things, if I knew what to try.

I did try pressing c in the grub interface and then entered help. I tried the vbetest and vbeinfo, and some patterns came up on the screen, but then it froze and I couldn't get out.
Reply With Quote
  #11  
Old 23rd March 2013, 04:56 AM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,365
linuxfirefox
Re: Grub2 problem: Can't display this Video Mode

I would boot Fedora and reinstall grub2 to /dev/sda.

If problems persist, back up your personal data and reinstall F17 from scratch.

There's a cost/benefit, diminishing return angle here, particularly on a system with a history of
problems. At some point you turn Mother's picture to the wall and just start over.
Reply With Quote
Reply

Tags
display, grub2, mode, problem, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot Display This Video Mode da420 Using Fedora 4 18th March 2014 08:17 PM
Forcing grub2 to display in console text mode wangmaster Using Fedora 2 4th June 2012 05:52 PM
"Cannot Display This Video Mode" awalling Hardware & Laptops 1 11th December 2008 10:11 PM
"Can not display this video mode" phutinet Hardware & Laptops 6 21st July 2006 12:49 AM
Digital Input: Cannot display This Video Mode kill Installation, Upgrades and Live Media 1 10th February 2006 05:41 AM


Current GMT-time: 13:31 (Wednesday, 17-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat