Fedora Linux Support Community & Resources Center
  #1  
Old 19th January 2013, 07:25 PM
ravenfrost Offline
Registered User
 
Join Date: Jan 2013
Location: Sweden
Posts: 17
linuxfirefox
AMD Testing use only watermark in Fedora 18

Just did an upgrade from Fedora 17 to Fedora 18 and now on the desktop i have a watermark that says:

"AMD testing use only"

What is this? How do i remove it?

---------- Post added at 08:25 PM ---------- Previous post was at 04:12 PM ----------

I saw on AMDs page that they had released a new version of their driver so i downloaded it and was trying to install it, but it said that fglrx drivers was still found on the system?

But the thing is, i had removed them before running AMDs installer but still the installer said the drivers was found on the system?

So how do i install AMDs driver installation from AMDs page?

I have a AMD Radeon HD 6800 Series card.
Reply With Quote
  #2  
Old 19th January 2013, 11:47 PM
Fenrin Online
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 892
linuxepiphany
Re: AMD Testing use only watermark in Fedora 18

which driver did you install the one from the support.amd.com site or are you using the rpmfusion driver?

in the rpmfusion repo there is only the beta driver available currently. Then a way to solve the watermark issue would be:
Code:
su -c 'yum remove *catalyst*'
this just uninstalls the beta driver. But there is also another way to remove the watermark:
http://wiki.cchtml.com/index.php/Amd_watermark
http://wiki.cchtml.com/index.php/Ubu...ware_Watermark
Reply With Quote
  #3  
Old 20th January 2013, 09:27 AM
ravenfrost Offline
Registered User
 
Join Date: Jan 2013
Location: Sweden
Posts: 17
linuxfirefox
Re: AMD Testing use only watermark in Fedora 18

Quote:
Originally Posted by Fenrin View Post
which driver did you install the one from the support.amd.com site or are you using the rpmfusion driver?

in the rpmfusion repo there is only the beta driver available currently. Then a way to solve the watermark issue would be:
Code:
su -c 'yum remove *catalyst*'
this just uninstalls the beta driver. But there is also another way to remove the watermark:
http://wiki.cchtml.com/index.php/Amd_watermark
http://wiki.cchtml.com/index.php/Ubu...ware_Watermark
I downloaded the 13.1 proprietary driver from AMDs page.
Now im using the rpmfusion driver again because i had problems installing the driver from AMDs page.
Reply With Quote
  #4  
Old 20th January 2013, 09:59 AM
Gregovsky Offline
Registered User
 
Join Date: Jan 2013
Location: Czech
Posts: 5
linuxchrome
Re: AMD Testing use only watermark in Fedora 18

Hello ravenfrost, I got same watermark logo and this from askubuntu.com help me remove it:

Put this in a text file and save it (call it fixwatermark.sh):

Code:
#!/bin/sh
DRIVER=/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
done
With terminal go to the location where you saved it and do a

Code:
chmod +x fixwatermark.sh
to make it executable and a

Code:
sudo ./fixwatermark.sh
and reboot

PS. make sure that path for DRIVER is correct for fglrx_drv.so (I must change it little bit)
Reply With Quote
  #5  
Old 4th July 2013, 04:32 AM
Nsession Offline
Registered User
 
Join Date: Jul 2013
Location: Miami, Fl
Posts: 1
linuxfirefox
Re: AMD Testing use only watermark in Fedora 18

Hey guys hope this helps someone as it helped me. I had to mod the code a little due to having Fedora 19 (New Release) installed. The fglrx_drv.so file is located in a nice little place called modules/drivers. So here is the code: #!/bin/sh
DRIVER=`find /usr/lib64/xorg/modules/drivers/ -name fglrx_drv.so`

echo “Come on AMD!”

for token in $DRIVER;do
echo “Removing AMD logo from “$token

for x in $(objdump -d $DRIVER|awk ‘/call/&&/EnableLogo/{print “\\x”$2″\\x”$3″\\x”$4″\\x”$5″\\x”$6}’Smilie: ; do
sed -i “s/$x/\x90\x90\x90\x90\x90/g” $DRIVER
done
done

echo “Reboot computer to finish”
Reply With Quote
Reply

Tags
amd, fedora, testing, watermark

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Watermark on Images netsuvi Using Fedora 6 30th August 2010 08:56 AM
AMD Watermark "Unsupported hardware" osikes Hardware & Laptops 3 12th February 2009 02:13 AM
Grace: xmgrace not working after update to KDE4.2 using updtaes-testing/testing repos cunio Using Fedora 0 9th February 2009 08:17 PM
OpenOffice Watermark tranquilpenguin Using Fedora 3 26th August 2008 07:27 PM
Where's Fedora Testing? eelgueta Using Fedora 2 8th August 2005 11:07 PM


Current GMT-time: 08:34 (Saturday, 02-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat