Fedora Linux Support Community & Resources Center
  #1  
Old 13th September 2012, 10:55 PM
nitrolinux Offline
Registered User
 
Join Date: Nov 2004
Posts: 8
linuxchrome
FC17, mounting Samba Home Directories wiredness

Hello,

When I try to mount a home directory from a Samba File server (FC15), I keep getting a message from Nautilus (on my FC17 machine):

"Unable to mount location: Failed to mount Windows Share"

I can mount other Samba shares with no problems. I do have SELinux disabled. My firewall is allowing Port 139. Also, I can actually use smbclient to browse the home directory on my FC15 Samba file sharing server.

HTML Code:
smbclient //192.168.1.4/homes
Enter woode's password:
Domain=[NITRONET] OS=[Unix] Server=[Samba 3.5.15-74.fc15]
smb: \> 
What am I missing? Any help would be appreciated.
Reply With Quote
  #2  
Old 13th September 2012, 11:13 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,898
linuxfirefox
Re: FC17, mounting Samba Home Directories wiredness

Why in the world would you use samba for that...

Use NFS. At least the filesystems would be compatable (and run faster too).
Reply With Quote
  #3  
Old 22nd September 2012, 01:44 AM
nitrolinux Offline
Registered User
 
Join Date: Nov 2004
Posts: 8
unknownsafari
Re: FC17, mounting Samba Home Directories wiredness

Little late reply but... I appreciate you suggesting using NFS, and I did, but the same problems exist with that too. Once I mount the share home directory on a Fedora Core 15 server, to a Fedora Core 17 client, the permissons are (rwx------) 0700. With a UID of 500 and a GID of 500. All that is correct, but only root can access that folder on the client. I am passing the right username and password. On a windows client, I can access the shares with no special configuration. I can't remember this being a problem before. My smb.conf file on the FC15 server is basic like this:

HTML Code:
[homes]
valid users = %S
writable = yes
browsable = no

Nothing has changed there recently and it has been working. SELinux disabled on both machines.

My fstab file on the client:
HTML Code:
/192.168.1.4/homes /media/woode cifs username=XXXX,password=XXXX,gid=500,uid=500,dir_mode=0700,file_mode=0700
BTW, I have tried differnt parameters in the fstab mount line. Some include changing the dir_mode to 0777 and the file_mode the same. To no avail. It actually mounts on the client but root is the only account that has access to it. The other samba shares mount perfectly. As expected. If anyone has some suggestions, I would be thankful.

-nitrolinux
Reply With Quote
  #4  
Old 22nd September 2012, 02:15 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: FC17, mounting Samba Home Directories wiredness

For one..

You are mounting it into /media which is tmpfs on F17. With it being tmpfs, you can't properly set the permissions and SELinux context on the mount point.

Try moving it to use /mnt instead of /media.

Then make sure you have the permissions set correctly on your mount point directory. If your mount point restricts permissions, then there is no way you will get more permissions from a directory under it.

If you wish for everyone to be able to have read/write/execute permissions:

mkdir -p -m 0777 /mnt/woode

Then mount your cifs or nfs share to that mount point.

But to explain why your options don't seem to be having any effect.

uid= and gid= will only set the uid/gid if the server doesn't provide ownership information unless the forceuid and forcegid options are also specified.

dir_mode/file_mode will only override the default dir_mode/file_mode if the server does not support the CIFS Unix extensions.

Since your server is linux, it supports these things, so the options don't have any effect.
Reply With Quote
  #5  
Old 22nd September 2012, 02:53 PM
nitrolinux Offline
Registered User
 
Join Date: Nov 2004
Posts: 8
unknownsafari
Re: FC17, mounting Samba Home Directories wiredness

Thank you, I will change it and report back.

---------- Post added 22nd September 2012 at 08:53 AM ---------- Previous post was 21st September 2012 at 10:08 PM ----------

Hello DBelton,

I tried your suggestion, but the same effect. When I switch mount points to the /mnt directory and mount, I still only have root privileges on the home folder on my FC15 server. When I run "ls -l":

HTML Code:
 drwxrwxr-x 11 500 staff 0 Aug 28 09:59 family
drwxrwxr-x 17 500 staff 0 Sep 19 01:26 mp3
drwx------ 51 root  root 0 Sep  6 23:42 woode
My fstab:

HTML Code:
#
# /etc/fstab
# Created by anaconda on Thu Aug 30 15:05:19 2012
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/vg_p3antec2-lv_root /                                 ext4    defaults        1 1
UUID=2eebd891-23e8-496e-b740-a8613cc69a31 /boo  ext4    defaults        1 2
/dev/mapper/vg_p3antec2-lv_home /home                      ext4    defaults        1 2
/dev/mapper/vg_p3antec2-lv_swap swap                    swap    defaults        0 0
//192.168.1.4/music	  /mnt/mp3       cifs   username=woode,password=XXXXXX  0 0
//192.168.1.4/homes /mnt/woode   cifs   username=woode,password=XXXXXX  0 0
//192.168.1.4/family	  /mnt/family     cifs   username=woode,password=XXXXXX  0 0
My smb.conf on the FC15 server:

HTML Code:
# Self-rolled 5-11-2011

[global]
  workgroup = nitronet
  netbios name = nitroserver
# interfaces =
  security = user
  printing = bsd
  printcap name = /dev/null
  show add printer wizard = no
  disable spoolss = yes

[homes]
  comment = Home Directories
  valid users = %S
  read only = no
  create mask = 0700
  directory mask = 0700
  browsable = yes
  writable = yes

[music]
  comment = MP3 Share
  path =  comment = MP3 Share
  path = /usr/local/share/music
  force group = staff
  valid users = @staff
  read only = no
  public = yes
  guest ok = yes
  writable = yes
  create mask = 0775
  force create mode = 0775
  directory mask = 0775
  force directory mode = 0775

[family]
  comment = Family Share
  path = /usr/local/share/family
  valid users = @staff
  force group = staff
  read only = no
  public = yes
  guest ok = yes
  writable = yes
  create mask = 0775
  force create mode = 0775
  directory mask = 0775
  force directory mode = 0775
SELInux disabled on both machines. Firewall open for port 139. It works from Windows clients, but not this FC17 machine. Any help would be appreciated.

-nitrolinux
Reply With Quote
  #6  
Old 26th September 2012, 03:34 AM
nitrolinux Offline
Registered User
 
Join Date: Nov 2004
Posts: 8
unknownsafari
Re: FC17, mounting Samba Home Directories wiredness

Well....

Here's an update.

I have confirmed some things. Number one, it is NOT the version of Samba I'm running. I took it upon mysef to rpm -e my current Samba installation, which was like 3.5. I downloaded the most current stable version of Samba (3.8?) And compiled it from source. A LOT of work, and it prove to be all in vain. Same issue as before. Only root can access my home directory on my FC15 server. Again, what's weird is that the correct UID and GID gets assigned to the mounted share, the UID and GID that belongs to my account on the Samba file server, but again, only root can access it. Number two, I have a Ubuntu machine also, and I have discovered that I can mount my home directory and access it without root privleges. The UID and the GID assigned to the share is my local username on that Ububtu machine. The Ubuntu machine is the most current version (12.10). Go figure.

-nitrolinux
Reply With Quote
  #7  
Old 28th September 2012, 06:07 AM
nitrolinux Offline
Registered User
 
Join Date: Nov 2004
Posts: 8
linuxchrome
Re: FC17, mounting Samba Home Directories wiredness

[SOLVED]

I specified my local UID and GID on the remote share and I have read and write permissions on the Home Directory share.

In my fstab:

HTML Code:
//192.168.1.4/homes  //media/woode   cifs  credentials=/home/jason/.keep,uid=1000,gid=1000   0 0 
Thank you!

-nitrolinux
Reply With Quote
Reply

Tags
directories, fc17, home, mounting, samba, wiredness

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Home Directories cottsay Using Fedora 0 13th May 2007 01:44 AM


Current GMT-time: 20:53 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Chalchuapa City Travel Photos - Victoria Harbour, Hong Kong Travel Photos - Coffee View ,mae Kajan Travel Photos on Instagram