Fedora Linux Support Community & Resources Center
  #1  
Old 17th August 2012, 02:35 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,795
linuxfirefox
Spin down disks - no longer working

One of the nice features of recent Fedoras is that the power managers allows you to spin-down disks when unused. This has been a real power/heat/noise savings.

However sometime in the past few weeks this feature has ceased to work as expected. I have a backup drive (/dev/sdc) this is only used for one period at night, and the normally when I do an "ls -l /backup' (the mountpoint) in the day the drive has to spinup for 3-5 seconds before I get a result. No longer the case - it's always spinning.

In XFCE power manager, under the "On AC" tab, I have the "Spin down hard disks" checked.
In the past that was all it took.

Sadly as with the corresponding Gnome power manager there is no way to debug or monitor this that I am aware of.

Anyone else seeing this ?
Time for bugzilla ?
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #2  
Old 17th August 2012, 06:33 PM
szilagyic Offline
Registered User
 
Join Date: Aug 2008
Posts: 194
linuxfirefox
Re: Spin down disks - no longer working

I've also noticed this behavior, in Gnome 3 on Fedora 17. I've set the Power Options to spin down the disks, however it doesn't seem to actually spin them down. I've also tried to see how power management is handled and have not had any luck yet either getting it to actually work. This used to work fine in Gnome 2.x on Fedora 14. If you figure this out I think it will benefit others with the same issue.
Reply With Quote
  #3  
Old 17th August 2012, 07:15 PM
Dan Offline
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 23,250
linuxfirefox
Re: Spin down disks - no longer working

Ayup. Bugzilla time.
Reply With Quote
  #4  
Old 19th August 2012, 02:13 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,795
linuxfirefox
Re: Spin down disks - no longer working

It's been reported.

FWIW szilagyic, this feature did work in early F17 packages.

Note that a drive that is mounted as root will likely never spin down since there is regular log activity (to /var/log for example).
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #5  
Old 20th August 2012, 08:50 PM
droidhacker Offline
Registered User
 
Join Date: Oct 2009
Posts: 827
linuxfirefox
Re: Spin down disks - no longer working

You can use 'hdparm -S60 /dev/sdBLAH'. I.e., throw a list of this command into your /etc/rc.d/rc.local script to enable it on boot.

Funny thing that I noticed, is that setting the spin down time too high and the damned thing wouldn't spin down any more!!!!

-S60 is 5 minutes. When I had it set to -S180, it wouldn't spin down ever.


Edit: Note that some laptop disks are weird with the spindown thing. They may not support "-S". The western digital laptop disk I recently retired in favor of an SSD used a combination of "-B" (value of 1-127 inclusive allows spin down), and "-J" (western digital "green" idle3 timeout, in seconds -- stupid thing defaulted to 8 seconds, which is absurdly low, permitted values 8-12 seconds or 30-300 seconds in 30-second increments)

Last edited by droidhacker; 20th August 2012 at 08:56 PM.
Reply With Quote
  #6  
Old 21st August 2012, 02:21 AM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,089
linuxfirefox
Re: Spin down disks - no longer working

Using the hdparm command in the rc.local file is what I've been doing on my desktop pc with F16 for quite some time.
Code:
BASH:~/-> cat /etc/rc.d/rc.local 
#!/bin/bash
# Add commands to run at system startup

/sbin/hdparm -S 120 /dev/sdb /dev/sdc
This works 100% of the time on sdb and ~95% of the time for sdc (1TB storage only drive).
Code:
BASH:~/-> sensorstats
Core 0:    +35.0C
Core 1:    +32.0C
Core 2:    +29.0C
Core 3:    +32.0C
CPUFAN2:    0 RPM
CPUFAN1:    1590 RPM
CHAFAN1:    728 RPM
CHAFAN2:    661 RPM
CHAFAN3:    675 RPM
SYSTEM:    +33.0C 
CPUTEM:    +31.5C 
GPUTEM:    +31.0C
GPUFAN:    40%
/dev/sdb:  sleeping
/dev/sdc:  sleeping
/dev/sda:  +35.0C
Reply With Quote
  #7  
Old 12th July 2014, 12:38 AM
sigg3net Offline
Registered User
 
Join Date: Jul 2014
Location: Oslo
Posts: 1
linuxfirefox
Re: Spin down disks - no longer working

I found this thread while trying to work out what values to use (and which to avoid). Apparently, and contrary to popular belief in some forums, the timeouts are not chronological. From man hdparm:

Quote:
The encoding of the timeout value is somewhat peculiar. A value of zero means "timeouts are disabled": the device will not automatically enter standby mode. Values from 1 to 240 specify multiples of 5 seconds, yielding timeouts from 5 seconds to 20 minutes. Values from 241 to 251 specify from 1 to 11 units of 30 minutes, yielding timeouts from 30 minutes to 5.5 hours. A value of 252 signifies a timeout of 21 minutes. A value of 253 sets a vendor-defined timeout period between 8 and 12 hours, and the value 254 is reserved. 255 is interpreted as 21 minutes plus 15 seconds. Note that some older drives may have very different interpretations of these values.
In order to verify it, I created a script. It simply checks the hdparm -C status of the disk(s) specified at regular, changeable intervals (default 15 seconds) and adjusts for the uptime before the script was run. It is therefore not a management tool, but more like a measurement. Its approximation depends on the interval size (15 seconds or less is pretty accurate).

You can find it here: https://gitorious.org/check-disk-spindown/sh

Sample output for my 4 disk RAID:
Code:
/dev/sdb estimated spindown time: 0 hours, 29 minutes and 46 seconds.
/dev/sdc estimated spindown time: 0 hours, 29 minutes and 46 seconds.
/dev/sdd estimated spindown time: 0 hours, 29 minutes and 46 seconds.
/dev/sde estimated spindown time: 0 hours, 29 minutes and 46 seconds.
Reply With Quote
Reply

Tags
disks, longer, spin, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash Plugin Working... Selectively. Megavideo Among Others No Longer Working thunderwinde Using Fedora 0 24th December 2011 06:33 AM
Hard disks only spin down for a few seconds Sockmonster Hardware & Laptops 5 21st May 2011 07:40 PM
mobile broadband not working on fedora kde spin 13 Vic2004 Servers & Networking 0 13th July 2010 05:58 PM
Working Connection No Longer working....ASW-108 New factor? stepher Servers & Networking 0 15th September 2008 04:10 AM
Spin down disks in software raid array and otherwise? shadowwyvern Hardware & Laptops 1 21st September 2006 03:30 PM


Current GMT-time: 10:53 (Wednesday, 27-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin Copyright 2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat