Fedora Linux Support Community & Resources Center
  #16  
Old 19th August 2012, 11:38 AM
Yellowman
Guest
 
Posts: n/a
linuxfirefox
Re: bohdi AutoQA: depcheck test FAILED

Quote:
Originally Posted by TheBigRed View Post
@Yellowman

speed-dreams is now available on the fedora updates-testing repo, but couldn't install
due a problem with opengl-games-utils.
opengl-games-utils is only available as platform independet version (noarch).


Code:
yum install --enablerepo=updates-testing speed-dreams-2.1.0-9.trunk_r4810.fc17
Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, presto, refresh-packagekit, tidy-cache
Loading mirror speeds from cached hostfile
 * fedora: mirror.switch.ch
 * rpmfusion-free: mirror.switch.ch
 * rpmfusion-free-updates: mirror.switch.ch
 * rpmfusion-nonfree: mirror.switch.ch
 * rpmfusion-nonfree-updates: mirror.switch.ch
 * updates: mirror.switch.ch
 * updates-testing: mirror.switch.ch
Resolving Dependencies
--> Running transaction check
---> Package speed-dreams.x86_64 0:2.1.0-9.trunk_r4810.fc17 will be installed
--> Processing Dependency: opengl-games-utils(x86-64) for package: speed-dreams-2.1.0-9.trunk_r4810.fc17.x86_64
--> Processing Dependency: libFreeSOLID.so.0()(64bit) for package: speed-dreams-2.1.0-9.trunk_r4810.fc17.x86_64
--> Running transaction check
---> Package FreeSOLID.x86_64 0:2.1.1-12.fc17 will be installed
---> Package speed-dreams.x86_64 0:2.1.0-9.trunk_r4810.fc17 will be installed
--> Processing Dependency: opengl-games-utils(x86-64) for package: speed-dreams-2.1.0-9.trunk_r4810.fc17.x86_64
--> Finished Dependency Resolution
Error: Package: speed-dreams-2.1.0-9.trunk_r4810.fc17.x86_64 (updates-testing)
           Requires: opengl-games-utils(x86-64)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Code:
rpm -qa |grep opengl-games
opengl-games-utils-0.2-2.fc17.noarch
does this mean, the spec file must be patched again. ?

Code:
diff -Naur speed-dreams-old.spec speed-dreams.spec 
--- speed-dreams-old.spec	2012-08-19 11:05:06.169292389 +0200
+++ speed-dreams.spec	2012-08-19 11:05:59.778297047 +0200
@@ -36,7 +36,7 @@
 Source5: %{name}.desktop
 
 Provides:      %{name} = %{version}-%{release}
-Requires:      opengl-games-utils%{?_isa}
+Requires:      opengl-games-utils
 BuildRequires: cmake
 BuildRequires: chrpath
 BuildRequires: desktop-file-utils
Sorry, my mistake.

Yes your patch is needed.

---------- Post added at 11:38 AM ---------- Previous post was at 10:17 AM ----------

Quote:
Originally Posted by Yellowman View Post
Sorry, my mistake.

Yes your patch is needed.
At least my provides idea for the main package seems to work.
Reply With Quote
  #17  
Old 20th August 2012, 03:15 PM
TheBigRed Offline
Registered User
 
Join Date: Mar 2008
Location: Germany
Posts: 291
windows_xp_2003firefox
Re: bohdi AutoQA: depcheck test FAILED

AutoQA DepCheck fails again, but the package is pushed anyway, is this ok or must be investigated.
Reply With Quote
  #18  
Old 20th August 2012, 05:03 PM
Yellowman
Guest
 
Posts: n/a
linuxfirefox
Re: bohdi AutoQA: depcheck test FAILED

Quote:
Originally Posted by TheBigRed View Post
AutoQA DepCheck fails again, but the package is pushed anyway, is this ok or must be investigated.
You could try splitting the libs into a sub-package to see if that helps.
Reply With Quote
  #19  
Old 21st August 2012, 06:01 PM
TheBigRed Offline
Registered User
 
Join Date: Mar 2008
Location: Germany
Posts: 291
linuxfirefox
Re: bohdi AutoQA: depcheck test FAILED

issue discussed on fedora devel list, because i do not quite understand the it.
http://lists.fedoraproject.org/piper...st/170976.html
Reply With Quote
  #20  
Old 22nd August 2012, 07:43 PM
TheBigRed Offline
Registered User
 
Join Date: Mar 2008
Location: Germany
Posts: 291
linuxfirefox
Re: bohdi AutoQA: depcheck test FAILED

> It really seems to be depcheck bug, because I was able to install speed-dreams from f17 x86_64 updates-testing just fine.
a bug against AutoQA was filled:
https://fedorahosted.org/fedora-infr...re/ticket/3445
Reply With Quote
Reply

Tags
autoqa, bohdi, depcheck, failed, test

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Command to List BuildRequires (like Debian's dpkg-depcheck) Jeff91 Programming & Packaging 0 21st December 2010 06:26 AM
CD Test failed Spikey123 Using Fedora 1 10th December 2007 12:09 AM
Fedora 7 Test Failed Peter_APIIT Installation, Upgrades and Live Media 9 22nd June 2007 11:05 AM
FC7 test 2 failed? bigmacbb63 Installation, Upgrades and Live Media 4 23rd May 2007 03:55 AM
another failed media test thegoomba Installation, Upgrades and Live Media 6 7th February 2005 02:45 AM


Current GMT-time: 18:23 (Tuesday, 21-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Firminy Photos - Perovo Instagram Photos - Eckernforde Photos on Instagram