Fedora Linux Support Community & Resources Center
  #1  
Old 15th August 2012, 06:17 PM
neocortex Offline
Registered User
 
Join Date: Sep 2011
Posts: 30
linuxfirefox
Need GNU Octave 3.2

Hello ALL,
Please, can anyone tell me how to install Octave 3.2 which I need for my work? I am using version 3.4.3, but I need that older, which supports addons for my work.

(I am using Fedora 16 64-bit)

Thank you! Best,
PM
Reply With Quote
  #2  
Old 15th August 2012, 06:41 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,771
linuxfedorafirefox
Re: Need GNU Octave 3.2

See the koji page - http://koji.fedoraproject.org/koji/p...packageID=2672

I don't know if these would work - might have different dependencies and hence might not work.

Alternatively, you can build from source. Here is the link to the source - ftp://ftp.gnu.org/gnu/octave/

---------- Post added at 12:41 PM ---------- Previous post was at 12:40 PM ----------

More specifically, Octave 3.2.4 built for F14 - http://koji.fedoraproject.org/koji/b...buildID=159160
Reply With Quote
  #3  
Old 15th August 2012, 09:06 PM
neocortex Offline
Registered User
 
Join Date: Sep 2011
Posts: 30
linuxfirefox
Re: Need GNU Octave 3.2

Quote:
Originally Posted by nonamedotc View Post
More specifically, Octave 3.2.4 built for F14 - http://koji.fedoraproject.org/koji/b...buildID=159160
Thanks for the prompt reply!

So, then, I should download x86_64 build from the above page and install. Is there a way to point rpm/yum to that page, and tell it not to use the latest but this one? (I know how to do this on Debian based distros, on which I have much more experience. But for RH base distros I am sort of newbie.)

Best,
PM
Reply With Quote
  #4  
Old 15th August 2012, 09:18 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,771
linuxfedorafirefox
Re: Need GNU Octave 3.2

Unfortunately, I do not how to do that. I can suggest a workaround though.

Download the rpm from the website and install it (hopefully it will work - not sure). Just edit /etc/yum.conf file to exclude octave from the updates. Add the line below to /etc/yum.conf file

Code:
exclude=octave*
Reply With Quote
  #5  
Old 15th August 2012, 10:23 PM
neocortex Offline
Registered User
 
Join Date: Sep 2011
Posts: 30
linuxfirefox
Re: Need GNU Octave 3.2

I tried both with rpm-files and from the source. They both failed with many errors. rpm asks for some 'libfltk' files, and they do not exists. Source also barks all the time.

Octave 3.2.X is the one that is needed for PsychtoolBox.

Please, any other ideas?

Best,
PM
Reply With Quote
  #6  
Old 15th August 2012, 11:43 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,771
linuxfedorafirefox
Re: Need GNU Octave 3.2

As I mentioned earlier, octave 3.2 rpm was for F14 - pretty old! So, it not working is not very surprising.

What errors are you getting when you compile the source? I can try to compile when I get back home and post what I get ...
Reply With Quote
  #7  
Old 17th August 2012, 06:54 PM
neocortex Offline
Registered User
 
Join Date: Sep 2011
Posts: 30
linuxfirefox
Re: Need GNU Octave 3.2

Quote:
Originally Posted by nonamedotc View Post
As I mentioned earlier, octave 3.2 rpm was for F14 - pretty old! So, it not working is not very surprising.

What errors are you getting when you compile the source? I can try to compile when I get back home and post what I get ...
Have you tried?
Reply With Quote
  #8  
Old 17th August 2012, 07:35 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,771
linuxfedorafirefox
Re: Need GNU Octave 3.2

Sorry - Did not have time last couple of days. I will try it tonight or tomorrow morning and post what I get ....
Reply With Quote
Reply

Tags
gnu, octave

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GNU Octave for Fedora 17 RhnBlack Using Fedora 6 20th July 2012 06:06 PM
Octave is looking for epstool... hence, so am I flash3780 Using Fedora 9 28th July 2011 05:08 PM
GNU Octave bee Using Fedora 15 26th September 2008 03:51 PM
Octave has IDE? legendbb Using Fedora 4 30th March 2007 09:38 PM
Octave On FC4 mathpeak Using Fedora 4 29th March 2006 07:07 AM


Current GMT-time: 00:54 (Tuesday, 16-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat