Fedora Linux Support Community & Resources Center
  #1  
Old 10th August 2011, 07:02 PM
speedhunt3r Offline
Registered User
 
Join Date: Mar 2009
Posts: 18
linuxfirefox
Exclamation Fedora 15 Wifi "firmware missing" HP mini 210-1000

Hi,

I just installed Fedora 15 on my HP mini 210-1000, everything is working fine except my wifi is not up. It says firmware missing. How do i fix this problem?

Previously I used to have Ubuntu 11.04 on it and wifi worked fine, but I need Fedora as i am using .rpm based applications. So please assist me in getting my Wifi up!

lscpi gives this:

Code:
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
*edit* sorry, found a solution in another post on the forum : http://forums.fedoraforum.org/showthread.php?t=249364

Last edited by speedhunt3r; 10th August 2011 at 07:06 PM. Reason: found solution
Reply With Quote
  #2  
Old 10th August 2011, 07:12 PM
Sagitter Offline
Registered User
 
Join Date: Sep 2009
Location: Salento - Italy
Age: 33
Posts: 520
linuxfirefox
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

Configure RPMFusion:

Code:
rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm 
rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
Then:

Code:
yum update
yum install broadcom-wl akmod-wl b43-openfwwf
reboot
Fedora will be rebooted.
__________________
Homepage: http://www.fedoraos.wordpress.com
Wiki page: https://fedoraproject.org/wiki/User:Sagitter
Reply With Quote
  #3  
Old 10th August 2011, 07:33 PM
speedhunt3r Offline
Registered User
 
Join Date: Mar 2009
Posts: 18
linuxfirefox
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

Sorry! But that post didn't really fix the problem! After installing

Code:
sudo yum install akmod-wl broadcom-wl b43-openfwwf
and a reboot, my wifi is not even showing up in the network manager.

dmesg is:
http://pastebin.com/WqcXT7yA
Reply With Quote
  #4  
Old 10th August 2011, 07:36 PM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
linuxfirefox
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

Quote:
Originally Posted by Sagitter
Code:
yum update
yum install broadcom-wl akmod-wl b43-openfwwf
reboot
Hello Sagitter,

Just so you will know (and for the record), b43-openfwwf is firmware used by the b43 driver module to support a few Broadcom chipsets of which BCM4312 is not one. To use the b43 driver with BCM4312, firmware has to be extracted from a proprietary driver source object file.

The Broadcom 802.11 STA Linux driver also supports the BCM4312. To install the akmod version of it, merely installing akmod-wl will install everything needed including broadcom-wl. To install the kmod version of it, I still recommend specifying in the yum command either kmod-wl or kmod-wl-PAE depending on the running kernel. Specifying broadcom-wl with yum also installs the kmod version and nowadays probably will install the right version for the running kernel. But at one time it did not, that's why I started recommending kmod-wl or kmod-wl-PAE instead of broadcom-wl for the yum command when the kmod version is desired.
Reply With Quote
  #5  
Old 10th August 2011, 07:57 PM
speedhunt3r Offline
Registered User
 
Join Date: Mar 2009
Posts: 18
linuxfirefox
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

Quote:
Originally Posted by stoat View Post
Hello Sagitter,

Just so you will know (and for the record), b43-openfwwf is firmware used by the b43 driver module to support a few Broadcom chipsets of which BCM4312 is not one. To use the b43 driver with BCM4312, firmware has to be extracted from a proprietary driver source object file.

The Broadcom 802.11 STA Linux driver does support the BCM4312. To install the akmod version of it, merely installing akmod-wl will install everything needed including broadcom-wl. To install the kmod version of it, I still recommend installing either kmod-wl or kmod-wl-PAE depending on the running kernel. Specifying broadcom-wl with yum installs the kmod version and nowadays probably will install the right version for the running kernel. But at one time it did not, that's why I started recommending kmod-wl or kmod-wl-PAE instead of broadcom-wl for the yum command.
Hey... can you explain that in simpler terms? If after installing those drivers my wifi isn't working, i should try kmod-wl or kmod-wl-PAE? won't the multiple drivers conflict if i do that?

---------- Post added at 09:57 AM ---------- Previous post was at 09:40 AM ----------

Ooh....it worked thanks stoat
Reply With Quote
  #6  
Old 11th August 2011, 12:57 PM
Sagitter Offline
Registered User
 
Join Date: Sep 2009
Location: Salento - Italy
Age: 33
Posts: 520
linuxfirefox
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

Quote:
Originally Posted by stoat View Post
Hello Sagitter,

Just so you will know (and for the record), b43-openfwwf is firmware used by the b43 driver module to support a few Broadcom chipsets of which BCM4312 is not one. To use the b43 driver with BCM4312, firmware has to be extracted from a proprietary driver source object file.

The Broadcom 802.11 STA Linux driver also supports the BCM4312. To install the akmod version of it, merely installing akmod-wl will install everything needed including broadcom-wl. To install the kmod version of it, I still recommend specifying in the yum command either kmod-wl or kmod-wl-PAE depending on the running kernel. Specifying broadcom-wl with yum also installs the kmod version and nowadays probably will install the right version for the running kernel. But at one time it did not, that's why I started recommending kmod-wl or kmod-wl-PAE instead of broadcom-wl for the yum command when the kmod version is desired.

You are right. Maybe I've being not much clear.

Kernel-PAE for a netbook ?
kmod-wl modules for lastest kernel 2.6.40 could not be available (i've checked now, it is in repository).

I'm sorry for my superficiality.


@speedhunt3r

If you use a kernel PAE ($uname -r), must install a kmod-PAE.
__________________
Homepage: http://www.fedoraos.wordpress.com
Wiki page: https://fedoraproject.org/wiki/User:Sagitter
Reply With Quote
  #7  
Old 12th August 2011, 02:06 PM
speedhunt3r Offline
Registered User
 
Join Date: Mar 2009
Posts: 18
linuxchrome
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

is there a netbook edition for fedora? I just downloaded the normal desktop iso it came with that kernel.
Reply With Quote
  #8  
Old 13th August 2011, 11:57 PM
jimpm Offline
Registered User
 
Join Date: Jan 2008
Location: Venice, FL
Posts: 30
linuxfedorafirefox
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

Have you recently updated software. The update to kernel 2.6.40 broke broadcom wifi on my HP laptop. Even manually loading the wl mod won't bring up wifi. Rolling back to 2.6.38 fixes everything. Anybody else notice this? And if you did any fixes? Thanks.
Jim
PS Yum says akmod-wl is latest version and lsmod shows wl loaded still no wifi.

addendum: Found in another post modprobe -r bcma then echo "blacklist bcma" >> /etc/modprobe.d/Broadcom-wl-blacklist.conf
This worked well for me.

Last edited by jimpm; 14th August 2011 at 12:43 AM.
Reply With Quote
  #9  
Old 14th August 2011, 12:11 AM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,377
linuxopera
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

Hello jimpm

Post #10 in this thread usually fixes it:

http://forums.fedoraforum.org/showthread.php?t=267852
Reply With Quote
  #10  
Old 9th August 2012, 10:05 AM
JollyTb Offline
Registered User
 
Join Date: Aug 2012
Location: California
Posts: 2
linuxfirefox
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

Quote:
Originally Posted by jimpm View Post
Have you recently updated software. The update to kernel 2.6.40 broke broadcom wifi on my HP laptop. Even manually loading the wl mod won't bring up wifi. Rolling back to 2.6.38 fixes everything. Anybody else notice this? And if you did any fixes? Thanks.
Jim
PS Yum says akmod-wl is latest version and lsmod shows wl loaded still no wifi.

addendum: Found in another post modprobe -r bcma then echo "blacklist bcma" >> /etc/modprobe.d/Broadcom-wl-blacklist.conf
This worked well for me.
I attempted the addendum. When I run the code: modprobe -r bcma I'm getting the a message that says the BCMA module is in use.

When I attempt to run the second code beginning at echo, I get an error saying no such command exists.


Also, I was unable to install the drivers using the Yum code, and am not sure what I am doing wrong. I'm new to Fedora and trying to figure this all out. Please let me know, in as much detail as possible, the steps to fix this.
Reply With Quote
  #11  
Old 9th August 2012, 03:36 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,994
linuxfirefox
Re: Fedora 15 Wifi "firmware missing" HP mini 210-1000

You need to be root to execute those commands, and o need to uncheck the "enable wireless" on NetworkManager (right click the icon & select) before you unload the driver.


(disable NM wireless then ....)
su -
<rootpasswd>
modprobe -r bcma
exit


and

su -
<rootpasswd>
echo "blacklist bcma" >> /etc/modprobe.d/Broadcom-wl-blacklist.conf
exit
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update errors: "missing attribute" and "Error in PREIN scriptlet" nimnull22 Fedora 13 Development Branch 3 28th April 2010 08:02 AM
Metacity and "Xlib: extension "SHAPE" missing on display ":0.0". debu_sagii Using Fedora 0 29th August 2007 06:53 PM
xlib:extension "xfree86-misc" missing on display ":0:0" Sicily1918 Using Fedora 4 3rd January 2007 09:30 PM
Fglrx driver install - "direct rendering: No", Xlib: extension "XFree86-DRI" missing Squeaks Hardware & Laptops 9 21st October 2006 01:10 PM
error message say; Xlib: extension "XFree86-DRI" missing on display ":0.0". sturmkim Using Fedora 3 1st October 2006 05:40 AM


Current GMT-time: 01:37 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Rostokino - Betul - Wolfenbuettel Instagram Photos