Fedora Linux Support Community & Resources Center
  #1  
Old 19th July 2012, 10:43 PM
AllanPen Offline
Registered User
 
Join Date: Mar 2007
Location: Nanoose Bay, B.C. Canada
Age: 74
Posts: 229
linuxchrome
chown command

I realize this should be simple; haven't been LInuxing for a while. I can't get access to a mounted vfat partition. I give the command sudo chown -R allan /media/vfat
and get back this:

[allan@MyFedora ~]$ sudo chown -R allan /media/vfat
chown: changing ownership of `/media/vfat/$RECYCLE.BIN/desktop.ini': Operation not permitted
chown: changing ownership of `/media/vfat/$RECYCLE.BIN': Operation not permitted
chown: changing ownership of `/media/vfat/ATIH2012_5545_en-US.exe': Operation not permitted
chown: changing ownership of `/media/vfat/mbam-consumer.exe': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/PC/PC_MBR/Mint.mbw': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/PC/PC_MBR/FedoraMBR.mbw': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/PC/PC_MBR': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/PC/PC_BIOS/OC_BIOS': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/PC/PC_BIOS': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/PC': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/LP.html': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/MyDexpot.dxp': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/PW.txt': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/Laptop/Lap_Win7.mbw': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/Laptop/Lap_Mint.mbw': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg/Laptop': Operation not permitted
chown: changing ownership of `/media/vfat/Backup/USB_Emerg': Operation not permitted
chown: changing ownership of `/media/vfat/Backup': Operation not permitted
chown: changing ownership of `/media/vfat': Operation not permitted
__________________
MB: Gigabyte P55A-UD4P ATX LGA1156
CPU: Intel Core i5 750 Quad Core Processor
Mem: 8GB G.SKILL Ripjaws PC3-12800
Windows 7, Ubuntu Fedora, Suse
Reply With Quote
  #2  
Old 19th July 2012, 11:01 PM
sidebrnz Offline
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 65
Posts: 2,615
linuxfirefox
Re: chown command

You can't chown files on a vfat partition even as root because vfat doesn't have any way to record the ownership.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
Reply With Quote
  #3  
Old 20th July 2012, 02:20 AM
AllanPen Offline
Registered User
 
Join Date: Mar 2007
Location: Nanoose Bay, B.C. Canada
Age: 74
Posts: 229
windows_7chrome
Re: chown command

Quote:
Originally Posted by sidebrnz View Post
You can't chown files on a vfat partition even as root because vfat doesn't have any way to record the ownership.
Ahhh I see; thanks.
__________________
MB: Gigabyte P55A-UD4P ATX LGA1156
CPU: Intel Core i5 750 Quad Core Processor
Mem: 8GB G.SKILL Ripjaws PC3-12800
Windows 7, Ubuntu Fedora, Suse
Reply With Quote
  #4  
Old 20th July 2012, 01:18 PM
Gareth Jones Offline
Official Gnome 3 Sales Rep. (and Adminstrator)
 
Join Date: Jul 2011
Location: Birmingham, UK
Age: 31
Posts: 2,771
linuxfirefox
Re: chown command

You can fake the ownership and permissions of (all) files a vFAT (or other non-Unix) file-system with mount options, but if the device was auto-mounted in GNOME or KDE then that should have been done automatically.

If it's a manual mount, or in /etc/fstab, check the section "Mount options for fat" in "man mount", specifically uid, gid, umask, dmask and fmask. You probably want something like "uid=1000,gid=1000".
Reply With Quote
  #5  
Old 20th July 2012, 02:04 PM
AllanPen Offline
Registered User
 
Join Date: Mar 2007
Location: Nanoose Bay, B.C. Canada
Age: 74
Posts: 229
windows_7chrome
Re: chown command

Quote:
Originally Posted by Gareth Jones View Post
You can fake the ownership and permissions of (all) files a vFAT (or other non-Unix) file-system with mount options, but if the device was auto-mounted in GNOME or KDE then that should have been done automatically.

If it's a manual mount, or in /etc/fstab, check the section "Mount options for fat" in "man mount", specifically uid, gid, umask, dmask and fmask. You probably want something like "uid=1000,gid=1000".
I mounted it during installation and partition selection.
__________________
MB: Gigabyte P55A-UD4P ATX LGA1156
CPU: Intel Core i5 750 Quad Core Processor
Mem: 8GB G.SKILL Ripjaws PC3-12800
Windows 7, Ubuntu Fedora, Suse
Reply With Quote
Reply

Tags
chown, command

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I did chown mso:mso /*/* martin.sourada Fedora Focus 5 24th June 2007 03:16 PM
Chown MarkTheDaemon Using Fedora 2 15th December 2005 04:19 AM
Chown permanently on /dev/... in FC4 Zipster Using Fedora 1 15th September 2005 03:02 PM
#*! chown ./ -R HELP bluejuice Using Fedora 3 23rd August 2005 12:01 PM


Current GMT-time: 03:32 (Wednesday, 17-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat