Fedora Linux Support Community & Resources Center
  #1  
Old 4th June 2012, 07:34 PM
daytooner Offline
Registered User
 
Join Date: Apr 2009
Posts: 216
linuxfedorafirefox
Yumex and XFCE

Okay, I am switching to XFCE, since my boxes are older and can't handle Gnome anymore (thanks alot guys :-( ).

Everythings seemed to be going okay, but then I tried to run yumex: it started, and said "authenticating as root", but didn't pop up a dialog box to enter the root password.

What did I miss?

TIA

ken
Reply With Quote
  #2  
Old 4th June 2012, 07:46 PM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,423
linuxfirefox
Re: Yumex and XFCE

Quote:
Originally Posted by daytooner View Post
Okay, I am switching to XFCE, since my boxes are older and can't handle Gnome anymore (thanks alot guys :-( ).

Everythings seemed to be going okay, but then I tried to run yumex: it started, and said "authenticating as root", but didn't pop up a dialog box to enter the root password.

What did I miss?

TIA

ken
Yumex is broken in openbox as well - same symptom.
Reply With Quote
  #3  
Old 4th June 2012, 07:51 PM
Cuvou Offline
Registered User
 
Join Date: Sep 2007
Location: Los Angeles, CA
Posts: 123
linuxfirefox
Re: Yumex and XFCE

What version of Fedora? It works for me on Fedora 17 XFCE 4.8, starting yumex from CLI or from the Apps->System menu.
__________________
~ Kirsle
Reply With Quote
  #4  
Old 4th June 2012, 10:36 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: Yumex and XFCE

It works fine here on F17.
I noticed that before it used the usermode-gtk password prompt but now it's using the policykit one.
Reply With Quote
  #5  
Old 4th June 2012, 11:30 PM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,423
linuxfirefox
Re: Yumex and XFCE

After updating, yumex 3.0.5 is still broken in openbox in F17. Launching it from a terminal gives:
Code:
** (process:2978): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:2978): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:2978): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
/usr/lib/python2.7/site-packages/guihelpers/__init__.py:256: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
  self.add_from_file(filename)
15:17:59 : DEBUG - network interface eth0 (r8169) is connected
15:17:59 : INFO - Connected to an network
15:17:59 : DEBUG - network interface eth0 (r8169) is connected
15:17:59 : INFO - Starting yum child process
15:17:59 : INFO - YUM: ==== AUTHENTICATING FOR org.yum-extender.backend.pkexec.run ===
15:17:59 : INFO - YUM: Authentication is required for Yum Extender to handle packages on the system
15:17:59 : INFO - YUM: Authenticating as: <myusername>
...and there it sits. No authorization box appears. It can be closed normally, at least.
Reply With Quote
  #6  
Old 5th June 2012, 12:07 AM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: Yumex and XFCE

Do you have polkit and polkit-gnome installed?
Also you need to start the authentication agent at login. Add
Code:
/usr/libexec/polkit-gnome-authentication-agent-1 &
to you autostart file.
Reply With Quote
  #7  
Old 5th June 2012, 01:22 AM
daytooner Offline
Registered User
 
Join Date: Apr 2009
Posts: 216
linuxfedorafirefox
Re: Yumex and XFCE

Quote:
Originally Posted by secipolla View Post
Do you have polkit and polkit-gnome installed?
Also you need to start the authentication agent at login. Add
Code:
/usr/libexec/polkit-gnome-authentication-agent-1 &
to you autostart file.
Okay, that was it. Manually ran that command, then yumex pops up the authentication box :-).

In the session settings for startup apps, there is a checkbox the polkit authentication, which wasn't checked, so now it is and runs on login.

Thanks!

ken
Reply With Quote
  #8  
Old 5th June 2012, 06:34 PM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,423
linuxfedorafirefox
Re: Yumex and XFCE

Quote:
Originally Posted by secipolla View Post
Do you have polkit and polkit-gnome installed?
Also you need to start the authentication agent at login. Add
Code:
/usr/libexec/polkit-gnome-authentication-agent-1 &
to you autostart file.
They were installed but I needed to start polkit-gnome-authentication-agent. Thanks secipolla.

Another yumex change is that the authentication-agent wants me to enter my password, not root's, even when I install new packages. Have to wonder who it thinks logged in as me with my password in the first place. It is in effect asking "Is that still you? Do you still know your own password?" What is the point of this entire baroque exercise, I wonder.

Yum on the command line is looking more reasonable. I don't mind a little bloat (4.4 MiB, while all of openbox is using 5.1), but senseless bloat?
Reply With Quote
  #9  
Old 5th June 2012, 07:28 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: Yumex and XFCE

For me it asks for the root password.
I don't have sudo configured, maybe that's the reason it asks the user password for you?
Reply With Quote
  #10  
Old 16th June 2012, 12:54 AM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: Yumex and XFCE

Here are some tips for people that want to run it without a password:
http://yum-extender.blogspot.com/201...-password.html
Reply With Quote
  #11  
Old 4th July 2012, 12:10 AM
arifur Offline
Registered User
 
Join Date: Jun 2012
Location: Bangladesh
Posts: 15
linuxfirefox
Re: Yumex and XFCE

Try uninstalling yumex,
update yum and then reinstall yumex


May be this article will help
http://www.abouthack.com/articles/li...fedora-17.html
Reply With Quote
  #12  
Old 1st February 2013, 11:41 PM
MALsPa Offline
Registered User
 
Join Date: Apr 2008
Location: albuquerque
Posts: 120
linuxchrome
Re: Yumex and XFCE

Quote:
Originally Posted by secipolla View Post
Do you have polkit and polkit-gnome installed?
Also you need to start the authentication agent at login. Add
Code:
/usr/libexec/polkit-gnome-authentication-agent-1 &
to you autostart file.
Thanks for the tip. Similar solution for Openbox in the F17 KDE spin:

Code:
/usr/libexec/kde4/polkit-kde-authentication-agent-1
Reply With Quote
Reply

Tags
authenticate as root, xfce, yumex

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 10 xfce xfce menu not working well xroox Hardware & Laptops 1 1st June 2009 06:47 AM
Test Day tomorrow - Xfce! Come along, Xfce fans. AdamW News 1 19th March 2009 04:08 AM
Yumex juanpedro Using Fedora 3 30th May 2007 10:56 PM
yumex error - missing dependency python abi 2.4 needed by yumex mikewainwright Installation, Upgrades and Live Media 0 3rd January 2007 03:00 PM
yumex xstation Installation, Upgrades and Live Media 8 21st December 2005 07:15 PM


Current GMT-time: 14:56 (Monday, 22-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Cheltenham City Center Travel Photos on Instagram - GH Universal Hotel Instagram Photos - McCreary's ThePub - Haw Par Villa Photos on Instagram - HOTEL EUROPA Travel Photos on Instagram