Fedora Linux Support Community & Resources Center
  #1  
Old 4th June 2012, 09:32 AM
Timmy111 Offline
Registered User
 
Join Date: Jun 2012
Location: germany
Posts: 19
linuxfedorafirefox
Cannot install vlc with Fedora 14

Hello everyone,

I have issues inastalling vlc on F14. Iḿ new to linux, so I googled my problem, found some posts related but couldnt get my problem solved..
Problem is : I want to install vlc on fedora 14 using yum, but it seems that it cannot find the right library or something.

when I type . yum install vlc, i get the following errors.

Error: Package: vlc-core-1.1.12-1.fc14.i686 (rpmfusion-free-updates)
Requires: libva-x11-0.31.1.1.so.1
Available: libva-freeworld-0.31.1-1.sds4.fc14.i686 (rpmfusion-free)
libva-x11-0.31.1.1.so.1
Error: Package: vlc-core-1.1.12-1.fc14.i686 (rpmfusion-free-updates)
Requires: libva-0.31.1.1.so.1
Available: libva-freeworld-0.31.1-1.sds4.fc14.i686 (rpmfusion-free)
libva-0.31.1.1.so.1
Error: Package: ffmpeg-libs-0.6.3-1.fc14.i686 (rpmfusion-free-updates)
Requires: libva-0.31.1.1.so.1
Available: libva-freeworld-0.31.1-1.sds4.fc14.i686 (rpmfusion-free)
libva-0.31.1.1.so.1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


Can someone tell me what the problem is and how I can solve it please?

Best Regards
Timmy
Reply With Quote
  #2  
Old 4th June 2012, 11:24 AM
SteveGYBE Offline
Registered User
 
Join Date: Jun 2007
Location: Lytham St Annes, Lancashire, UK
Posts: 338
linuxfirefox
Re: Cannot install vlc with Fedora 14

Strange - the 'libvs-freeworld' package is still available in the "rpmfusion-fee" repository for Fedora 14, so I'm not sure why Yum won't add it to the dependency list and install automatically. You could try installing it manually
Code:
yum install libva-freeworld-0.31.1-1.sds4.fc14.i686
If that doesn't work, download the RPM manually then install the downloaded RPM file
Code:
wget http://download1.rpmfusion.org/free/fedora/releases/14/Everything/i386/os/libva-freeworld-0.31.1-1.sds4.fc14.i686.rpm
yum install libva-freeworld-0.31.1-1.sds4.fc14.i686.rpm
Reply With Quote
  #3  
Old 4th June 2012, 12:34 PM
Timmy111 Offline
Registered User
 
Join Date: Jun 2012
Location: germany
Posts: 19
linuxfedorafirefox
Re: Cannot install vlc with Fedora 14

Hi,
Thank you for your quick answer,
It seems the package you told me to install is already here. When I use the command lines you gave me,
# yum install libva-freeworld-0.31.1-1.sds4.fc14.i686 is giving me this output : Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Nothing to do


# wget http://download1.rpmfusion.org/free/....fc14.i686.rpm is giving me :

Resolving download1.rpmfusion.org... 193.28.235.60
Connecting to download1.rpmfusion.org|193.28.235.60|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 104844 (102K) [application/x-rpm]
Saving to: “libva-freeworld-0.31.1-1.sds4.fc14.i686.rpm.1”

100%[=========================================>] 104,844 110K/s in 0.9s

2012-06-04 13:17:22 (110 KB/s) - “libva-freeworld-0.31.1-1.sds4.fc14.i686.rpm.1” saved [104844/104844]


and #yum install libva-freeworld-0.31.1-1.sds4.fc14.i686.rpm : Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Examining libva-freeworld-0.31.1-1.sds4.fc14.i686.rpm: libva-freeworld-0.31.1-1.sds4.fc14.i686
Cannot install package libva-freeworld-0.31.1-1.sds4.fc14.i686. It is obsoleted by installed package libva-1.0.12-1.i686
Error: Nothing to do

Installing vlc gives me the same erros as before. My understanding is that the lib files needed for the installation of vlc are (maybe) outdated. Am I wrong?

Thank you for your time
Timmy
Reply With Quote
  #4  
Old 4th June 2012, 12:47 PM
SteveGYBE Offline
Registered User
 
Join Date: Jun 2007
Location: Lytham St Annes, Lancashire, UK
Posts: 338
linuxfirefox
Re: Cannot install vlc with Fedora 14

Have you got another third-party repo enabled apart from RPMFusion? It looks like you've got a version of 'libva' from somewhere else which conflicts with the requirements of packages from RPMFusion. Post the output from
Code:
rpm -qi libva
and also
Code:
yum repolist
Reply With Quote
  #5  
Old 4th June 2012, 01:33 PM
bonedome Offline
Registered User
 
Join Date: Apr 2010
Location: uk
Posts: 727
linuxfirefox
Re: Cannot install vlc with Fedora 14

Hello
where did you get that libva you have ?
the version available from rpmfusion that I have is 0.31.1
I suspect vlc 1.1.12 will only work with the older version.
I'd remove the libva you have with either yum remove or rpm -e --nodeps, you may even be able to use yum downgrade libva* and try installing vlc again
__________________
fedora 14 fluxbox and gnome2 hp compaq nx9030 laptop 2Gb ram, helicopter landing pad, jacuzzi, mini fridge, gateway to alternative dimension
Reply With Quote
  #6  
Old 4th June 2012, 02:21 PM
Timmy111 Offline
Registered User
 
Join Date: Jun 2012
Location: germany
Posts: 19
linuxfedorafirefox
Re: Cannot install vlc with Fedora 14

hi,
Here are the outputs :

# rpm -qi libva
Name : libva Relocations: (not relocatable)
Version : 1.0.12 Vendor: (none)
Release : 1 Build Date: Tue 31 May 2011 06:39:50 PM CEST
Install Date: Thu 01 Jan 2009 07:38:17 AM CET Build Host: drone13
Group : System Environment/Libraries Source RPM: libva-1.0.12-1.src.rpm
Size : 842910 License: MIT
Signature : (none)
URL : http://freedesktop.org/wiki/Software/vaapi
Summary : Video Acceleration (VA) API for Linux
Description :
Libva is a library providing the VA API video acceleration API.

yum repolist
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
repo id repo name status
fedora Fedora 14 - i386 17,883
rpmfusion-free RPM Fusion for Fedora 14 - Free 364
rpmfusion-free-updates RPM Fusion for Fedora 14 - Free - Updates 1,050
timesys Timesys 128
updates Fedora 14 - i386 - Updates 7,988
repolist: 27,413
Reply With Quote
  #7  
Old 4th June 2012, 03:26 PM
SteveGYBE Offline
Registered User
 
Join Date: Jun 2007
Location: Lytham St Annes, Lancashire, UK
Posts: 338
linuxfirefox
Re: Cannot install vlc with Fedora 14

Aha - the problem is that you have installed packages two third-party repositories - RPMFusion and Timesys. Although both supply packages for Fedora 14, the individual packages may be at different versions between the repositories, causing incompatibilities like you are seeing.

The simplest way to get VLC installed from RPMFusion is to erase the 'libva' package from Timesys (plus any other packages which depend on that 'libva' package) before trying to install VLC again.
Reply With Quote
  #8  
Old 5th June 2012, 09:00 AM
Timmy111 Offline
Registered User
 
Join Date: Jun 2012
Location: germany
Posts: 19
linuxfedorafirefox
Re: Cannot install vlc with Fedora 14

Ok I understand that, I tried to remove it using the add remove software, but it wasnt there, how do I remove it using command lines? I guess I have to find the packages first using find, grep?

Regards
Timmy
Reply With Quote
  #9  
Old 5th June 2012, 09:07 AM
SteveGYBE Offline
Registered User
 
Join Date: Jun 2007
Location: Lytham St Annes, Lancashire, UK
Posts: 338
linuxfirefox
Re: Cannot install vlc with Fedora 14

As root, run
Code:
yum erase libva
The default Yum configuration will pause after producing a list of any dependencies that need removing as well for you to confirm the action.
Reply With Quote
  #10  
Old 5th June 2012, 09:44 AM
bonedome Offline
Registered User
 
Join Date: Apr 2010
Location: uk
Posts: 727
linuxfirefox
Re: Cannot install vlc with Fedora 14

You're probably going to have to disable that timesys repo aswell, to permanently disable
Code:
su -
root password
gedit /etc/yum.repos.d/timesys.repo
and change line
Code:
enabled=1
to
Code:
enabled=0
to use it one time only
Code:
yum --enablerepo=timesys
__________________
fedora 14 fluxbox and gnome2 hp compaq nx9030 laptop 2Gb ram, helicopter landing pad, jacuzzi, mini fridge, gateway to alternative dimension
Reply With Quote
  #11  
Old 5th June 2012, 10:03 AM
Timmy111 Offline
Registered User
 
Join Date: Jun 2012
Location: germany
Posts: 19
linuxfedorafirefox
Re: Cannot install vlc with Fedora 14

Hi,

When I use yum erase libva, it does give me a list of dependencies, im afraid the libva is used by the display driver emgd as you can see in output below, will this cause problem if I remove it?

Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package libva.i686 0:1.0.12-1 set to be erased
--> Processing Dependency: libva.so.1 for package: intel-emgd-driver-extras-2032-1.8.fc14.i686
--> Running transaction check
---> Package intel-emgd-driver-extras.i686 0:2032-1.8.fc14 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Removing:
libva i686 1.0.12-1 @anaconda-InstallationRepo-201107211556.i386 823 k
Removing for dependencies:
intel-emgd-driver-extras
i686 2032-1.8.fc14 @anaconda-InstallationRepo-201107211556.i386 2.2 M

Transaction Summary


regards
tim
Reply With Quote
  #12  
Old 5th June 2012, 04:25 PM
bonedome Offline
Registered User
 
Join Date: Apr 2010
Location: uk
Posts: 727
linuxfirefox
Re: Cannot install vlc with Fedora 14

Maybe not worth the risk, It might cause a load of grief, you could try
Code:
rpm -e --nodeps libva
It'll say something about database altered outside of yum, just ignore that and then try yum install vlc again
__________________
fedora 14 fluxbox and gnome2 hp compaq nx9030 laptop 2Gb ram, helicopter landing pad, jacuzzi, mini fridge, gateway to alternative dimension
Reply With Quote
  #13  
Old 11th June 2012, 04:09 PM
Timmy111 Offline
Registered User
 
Join Date: Jun 2012
Location: germany
Posts: 19
linuxfedorafirefox
Re: Cannot install vlc with Fedora 14

Hi,
I tried to remove the libva using : rpm -e --nodeps libva, but still couldnt install vlc afterwords ... Is there another way to have the vlc installed ?

Regards
Tim
Reply With Quote
  #14  
Old 13th June 2012, 01:40 PM
jonathonp Offline
Registered User
 
Join Date: Oct 2006
Location: Melbourne
Age: 43
Posts: 532
linuxfirefox
Re: Cannot install vlc with Fedora 14

This is the last version I was able to compile. You can download here:

http://poppleit.com/wp-content/uploa...c14.x86_64.zip

The other alternative is posted here http://poppleit.com/how-to-fedora-14...12-10-06-2012/
__________________
http://poppleit.com/

Fedora 17 XFCE x64, Xubuntu 12.04 LTS x64, Windows 7 64bit
HP-ProBook 5830 i3 - PC AMD Core 4
MacBookPro v10.7.4 - 2.8GHz i7 4GB RAM
Reply With Quote
  #15  
Old 14th June 2012, 09:37 AM
Timmy111 Offline
Registered User
 
Join Date: Jun 2012
Location: germany
Posts: 19
linuxfedorafirefox
Re: Cannot install vlc with Fedora 14

Hi,

Thank you for the file, I tried to install it using rpm -i vlc-2.0.0-1.fc14.x86_64.rpm but many lneeded libs are missing.
Output :
error: Failed dependencies:
kde-filesystem is needed by vlc-2.0.0-1.fc14.x86_64
libGL.so.1()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libICE.so.6()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libQtCore.so.4()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libQtGui.so.4()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libSM.so.6()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libX11-xcb.so.1()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libX11.so.6()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libaa.so.1()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libc.so.6()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libc.so.6(GLIBC_2.3)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libc.so.6(GLIBC_2.3.4)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libc.so.6(GLIBC_2.4)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libc.so.6(GLIBC_2.8)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libcaca.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libdbus-1.so.3()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libdl.so.2()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libgcc_s.so.1()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libgcc_s.so.1(GCC_3.3.1)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libgcc_s.so.1(GCC_3.4)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libm.so.6()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libm.so.6(GLIBC_2.2.5)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libprojectM.so.2.0.1()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libpthread.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libpulse.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libpulse.so.0(PULSE_0)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
librt.so.1()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libstdc++.so.6()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libvlccore.so.5()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb-composite.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb-keysyms.so.1()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb-randr.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb-render.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb-shape.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb-shm.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb-xfixes.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb-xv.so.0()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
libxcb.so.1()(64bit) is needed by vlc-2.0.0-1.fc14.x86_64
qt4(x86-64) >= 4.7.4 is needed by vlc-2.0.0-1.fc14.x86_64
vlc-core(x86-64) = 2.0.0-1.fc14 is needed by vlc-2.0.0-1.fc14.x86_64

I would have to questions :
1/ Why would it be possible to install the version you gave me and not the actual one (considering my lbva problem)
2/ I guess i have to get the missing libs to install your version, how can i find (and install) all of those?

Regards
Timmy
Reply With Quote
Reply

Tags
fedora, install, vlc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I used the i386 install DVD. Fedora wants me to install i686 updates. blackplague1347 Using Fedora 5 11th November 2010 10:58 PM
Install Experience needed to install Fedora 7 on HP tx1000 series laptop jiabo Hardware & Laptops 33 6th May 2010 12:23 PM
Can't boot Fedora 10 live cd or install Fedora 10 with install DVD dth4h Hardware & Laptops 7 28th May 2009 07:20 AM
Fedora 10 default install fails with ATI 4850 graphics card (but text install works) Jeff72 Installation, Upgrades and Live Media 1 20th January 2009 05:27 PM
Fedora 9 hands during install in Transfer Install Image ciper Installation, Upgrades and Live Media 1 16th May 2008 12:05 AM


Current GMT-time: 04:40 (Wednesday, 03-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat