Fedora Linux Support Community & Resources Center
  #1  
Old 6th June 2012, 09:45 PM
beason4251 Offline
Registered User
 
Join Date: Jun 2012
Location: San Antonio, TX
Posts: 10
linuxopera
While Formatting SD Card, error "Device partition expected ..."

I'm trying to format an SD card to use with an Arduino Ethernet. I've been trying to follow the instructions on the site: http://arduino.cc/en/Reference/SDCardNotes, but have run into a problem.

When I enter df, the SD card does not show up. However, if I enter cat /proc/scsi/scsi, I can clearly see the SD card listed. If I enter sudo /sbin/fdisk -l, I can see the SD card in /dev/sdb, so I know where it is.

However, when I try to enter sudo mkdosfs -F 16 /dev/sdb, I get the following error:

mkdosfs 3.0.12 (29 Oct 2011)
mkdosfs: Device partition expected, not making filesystem on entire device '/dev/sdb' (use -I to override)


I'm pretty new to Fedora, so I'm not sure what mkdosfs is trying to tell me. Is it okay for me to override, or will that not do what I want it to?

Thanks!
Reply With Quote
  #2  
Old 6th June 2012, 10:55 PM
tomkoskz Offline
Registered User
 
Join Date: Jun 2012
Location: NC
Posts: 14
linuxchrome
Re: While Formatting SD Card, error "Device partition expected ..."

Are you using a graphical installation of fedora? if you are try using the disk utility tool instead to format the card.
Reply With Quote
  #3  
Old 7th June 2012, 02:15 AM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxchrome
Re: While Formatting SD Card, error "Device partition expected ..."

It's trying to tell you that you didn't specify which partition on /dev/sdb to format to vfat16. If there is only one non-hidden partition on /dev/sdb, they you would specify /dev/sdb1.
Reply With Quote
  #4  
Old 7th June 2012, 11:20 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,078
linuxfirefox
Re: While Formatting SD Card, error "Device partition expected ..."

You don't usually have to format memory cards, because they are already formatted ;-)

Please read the instructions carefully, because you forgot the "1" like Pablo suggested. Check

Code:
fdisk -l /dev/sdb
to see if there really is a /dev/sdb1 partition. Some weird devices only have /dev/sdf4 instead.

If you use sdb instead of sdb1 you would format the card as superfloppy and thereby deleting the partition table. This is rather uncommon, but some MP3 players use this format. Hence the warning.
Reply With Quote
  #5  
Old 7th June 2012, 03:02 PM
beason4251 Offline
Registered User
 
Join Date: Jun 2012
Location: San Antonio, TX
Posts: 10
linuxopera
Re: While Formatting SD Card, error "Device partition expected ..."

Huh, when I input

Code:
sudo /sbin/fdisk -l
The lines that show the SD card are:

Code:
Disk /dev/sdb: 3965 MB, 3965190144 bytes
49 heads, 48 sectors/track, 3292 cylinders, total 7744512 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000
However, I went ahead and added the 1 and it formatted correctly.

Thanks!
Reply With Quote
Reply

Tags
card, device partition expected, error, formatting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer error msg:"Error Opening/Initializing The Selected Video Out (-vo) Device" alfoxyz Using Fedora 3 30th November 2009 01:37 AM
Sound works, still returns error "alsa-util.c: Error opening PCM device" saeedora Using Fedora 0 5th May 2009 01:06 PM
Sound works, still returns error "alsa-util.c: Error opening PCM device" saeedora Hardware & Laptops 0 30th April 2009 03:10 PM
"expected specifier-qualifier-list" ERROR while adding a new system call ahm_irf Programming & Packaging 0 30th April 2007 04:49 AM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM


Current GMT-time: 23:07 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Ilinden - Lorica Instagram Photos - Komotini