Fedora Linux Support Community & Resources Center
  #1  
Old 12th May 2012, 03:15 AM
gjwalsh Offline
Registered User
 
Join Date: Feb 2011
Posts: 43
linuxfirefox
sound problems with F17, while F16 was fine

The server in both cases is the same hardware configuration. It employs:
Processor: AMD Athlon 64x1 Dual Processor 4200+ x 2
Graphics: GeForce 440/PC1e/SSE2
Bus ID PCI:4:0:0
PCI Device ID 0x0de0
PCI Vendor ID 0x10de
lspci -v correctly identifies the nvidia kernel driver, and the audio device as the nVidia GF108 High Def Audio Controller.

Working through ala-info.txt, the reports for each system are identical up to the HDA-Intel Codec Information header except for the kernel version, of course, and the following:

f16 shows a sound related modprobe: snd-hda-intel: enable_msi=0 probe_mask=0x108. Under the following 'Loaded sound module options' header, enable_msi : 0 is within the listing fo rmodule snd-hda-intel.

f17 does not show the modprobe of snd-hda-intel at all, although the module is shown under loaded. However, enable_msi is set to -1. Further, there is no sound.config file found anywhere in this system.

Under the 'HDA-Intel Codec information' header, f16 identifies the codec: Nvidia GPU 14 HDMI/DP at address 3 and the alsa device nodes have been set up for address 3. That has always worked, and is the sole sound card in the server.

But f17 does not see the world in this way at all. It sets up the configuration for addresses 0, 1 and 2 as well as 3. The codec detail for address3 is identical to that of f16

Reviewing the ALSA/HDA dmesg file:
In f16 we find: microcode: AMD CPU family 0xf not supported; hda_intel: codec_mask forced to 0x8. That makes sense, because those settings were establised by modprobe earlier.
For f17: we read (Note that use of the override may cause unknown side effects.); hda_intel: Disabling MSI

So, msi comes back to bite me again.

Since the hardware is unchanged, I have to assume the kernel upgrade affects this or there is a change in the level of hardware support between the 2 configurations.

At this stage in the cycle, I don't hold out any hope that f17 final will be of any help but I'm hoping somebody out there might have a path to a solution for us here.

GJW
Reply With Quote
  #2  
Old 12th May 2012, 11:54 PM
gjwalsh Offline
Registered User
 
Join Date: Feb 2011
Posts: 43
linuxfirefox
Re: sound problems with F17, while F16 was fine

To correct this:
Insert the following line into /etc/modprobe.d/dist-alsa.conf:
options snd_hda_intel enable_msi=0 probe_mask=0x108
Reboot the system and you will now have a successful sound test .....

As it happens, this is the same fix I had to use previously to get f16 running.
Reply With Quote
Reply

Tags
f16, f17, fine, problems, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F12 sound distorted, was fine in F11 richardpu Using Fedora 9 6th January 2010 08:20 PM
Sound works fine, but not on Youtube videos Magickman Using Fedora 4 27th March 2009 06:34 PM
Usuing f4 now- its fine but NO SOUND----f5 still blacking out- opaline Installation, Upgrades and Live Media 0 1st June 2006 08:02 AM
My sound works fine in some programs, not in others... AlexMax Hardware & Laptops 3 9th July 2004 03:36 AM


Current GMT-time: 19:03 (Friday, 21-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Madinat `Isa Travel Photos - Smithfield - Menzelinsk Travel Photos on Instagram