Fedora Linux Support Community & Resources Center
  #1  
Old 11th May 2012, 12:09 AM
chandank Offline
Registered User
 
Join Date: May 2012
Location: Kelowna
Posts: 2
linuxfirefox
Issue while restoring the grub in MBR

I have setup dual boot in my laptop windows and F16. Mistakenly I uninstalled grub2 rpm from my f16 machine. And when I restarted the machine I could only see the grub prompt.

I tried installaing grub using one Centos 6 live CD but nothing seems to work. I googled a lot but I think something is missing and messing up that I am able to fix my system.

When I tried to install Centos by chosing the option of replacing existing linux, it failed to install and generated a dump log.

Please find below my system layout/information


Code:
[root@livecd ~]# lvdisplay 
  --- Logical volume ---
  LV Name                /dev/vg_chandanklt/lv_swap
  VG Name                vg_chandanklt
  LV UUID                kJF1aO-9PLg-3ntu-qgRb-jMda-vHWk-6iVpnV
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                9.69 GiB
  Current LE             310
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:2
   
  --- Logical volume ---
  LV Name                /dev/vg_chandanklt/lv_home
  VG Name                vg_chandanklt
  LV UUID                y0p80v-Xdfi-jKDe-Fm5Y-ARf0-IhAA-T7Xt53
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                151.09 GiB
  Current LE             4835
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:3
   
  --- Logical volume ---
  LV Name                /dev/vg_chandanklt/lv_root
  VG Name                vg_chandanklt
  LV UUID                NexdHD-uPRC-hk8B-TY4v-GpkP-zSuv-c0R8yi
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                50.00 GiB
  Current LE             1600
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:4
   
[root@livecd ~]# 

   
[root@livecd ~]# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xaefad785

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         192     1536000    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2             192       31181   248924160    7  HPFS/NTFS
/dev/sda3           58762       60802    16384000    7  HPFS/NTFS
/dev/sda4           31181       58762   221540352    5  Extended
/dev/sda5           31182       31245      512000   83  Linux
/dev/sda6           31245       58762   221026304   8e  Linux LVM

Partition table entries are not in disk order

Disk /dev/mapper/live-rw: 4294 MB, 4294967296 bytes
so far I have tried mounting my root file system sda6(LVM) and doing to /mnt/root

grub-install --root-directory=/mnt/root /dev/sda
Reply With Quote
  #2  
Old 11th May 2012, 12:44 PM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,077
linuxfirefox
Re: Issue while restoring the grub in MBR

If you use the windows boot manager you usually install grub in the linux root directory (or maybe boot of you have a separate partion) and not the MBR.
Reply With Quote
Reply

Tags
grub, mbr, restoring

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub restoring Help! sam88 Using Fedora 4 7th December 2011 12:54 PM
Grub error after restoring with fsarchiver jonathonp Using Fedora 4 30th January 2010 04:12 PM
Restoring GRUB gaaurav_singh Installation, Upgrades and Live Media 3 7th July 2008 12:39 PM
restoring GRUB vazel Installation, Upgrades and Live Media 7 27th January 2006 09:56 PM
Restoring GRUB ucetin Using Fedora 5 6th August 2005 06:36 AM


Current GMT-time: 22:11 (Wednesday, 23-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat