Fedora Linux Support Community & Resources Center
  #1  
Old 11th May 2012, 12:05 AM
woodpecker Offline
Registered User
 
Join Date: May 2012
Location: Milpitas, CA
Posts: 2
linuxchrome
disable tap-to-click and evdev driver

I have installed Fedora 14 on a Gateway LT4004u netbook and am trying to disable tapping on the touchpad.

Any help would be appreciated.

Here is what I've tried so far:

GUI:

System|Preferences|Mouse and System|Preferences|Pointing Devices and "click on Name in upper right|System Preferences|Mouse"

These do not have anything about "TouchPad", but I was able to disable some mouse gestures (scrolling), but not tap-to-click

Shell:

lshal indicates it is using the "evdev" for input.x11_driver. Most of the instructions on the Internet are for the synaptics driver. How can I get it to use the synaptics driver?

Also, lshal | grep -i 'touchpad'

doesn't show anything. It looks like the whole assembly is treated as a "PS/2 style mouse" from the lshal output.

I tried the following, but it didn't stick after reboot:

hal-set-property --udi /org/freedesktop/Hal/devices/platform_i8042_i8042_AUX1_port_logicaldev_input --key input.x11_driver --string synaptics

xorg.conf:

First of all, there is some discrepancy on the Internet about where this file should go, for this purpose:

Is it /etc/X11/xorg.conf, /usr/share/X11/xorg.conf, or /etc/xorg.conf?

I tried all of the MaxTapTime, TapButton1, etc. settings in xorg.conf, but that is for the synaptics driver, not evdev. It appeared there wasn't a setting to disable tap-to-click in evdev set up.

I tried a "catchall" for "evdev" input devices with a driver clause specifying synaptics in an effort to make it switch to the synaptics driver, but that didn't work.

I did a "yum install" to verify that I had the synaptics driver software loaded.
And, I did a "depmod -a" which made the driver appear to show up in the /lib/modules/2.6.35.6-45.fc14.x86_64/modules.dep - where it wasn't before.

Hardware:

I tried the BIOS setup but there was no place to configure the touchpad.

Finally, I found the F6 button which toggles on/off the touchpad, completely.
This serves as a workaround which makes the system useable, but it is still less productive to hit "F6" every time I switch between the mouse and typing.

Thanks in advance for your help.

Last edited by woodpecker; 2nd June 2012 at 11:05 PM. Reason: better subject title
Reply With Quote
  #2  
Old 8th October 2012, 04:05 PM
woodpecker Offline
Registered User
 
Join Date: May 2012
Location: Milpitas, CA
Posts: 2
linuxchrome
Re: disable tap-to-click and synaptics driver

Why has no one even responded "gee that was a tough one"? I am about to become a deadly casulty of the American Feminist movement if I have to learn to type with my palms raised!!!!!!!!!!
Reply With Quote
  #3  
Old 8th October 2012, 04:33 PM
smr54 Online
Registered User
 
Join Date: Jan 2010
Posts: 5,503
linuxchrome
Re: disable tap-to-click and synaptics driver

It probably got overlooked. Though there are rules against bumping, the delay is only 24 hours. (Although those that just type bump tend to get criticized.) As is mentioned in the posting guidelines, always good to post, and, I tried this and that.
Or it might have been that at the time, anyone who saw it didn't have a good answer. Surprised this got overlooked though, I would think that there might have been some solutions.

Sometimes, folks are just busy, see one, and while, on a slow Sunday, they might type, Gee, that's a tough one, on a busy workday they might not. May 10th was a Thursday.

Anyway, there are a few possibilities--I got most of mine from the Arch wiki https://wiki.archlinux.org/index.php/Touchpad_Synaptics

A thread I started on the UX31A mentions a couple that I found useful.

http://forums.fedoraforum.org/showthread.php?t=274988 in post 6.

Should have added, try synclient -l to see if it's recognized by a synaptic driver. If not, then all I can think of is the GUI things that you've mentioned that you tried.
Reply With Quote
Reply

Tags
disable, driver, synaptics, taptoclick

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptics Pad Click problem FC15 Druid Guides & Solutions (No Questions) 1 24th October 2011 09:38 PM
right click on Synaptics touch pad not working algarues Hardware & Laptops 3 14th July 2011 09:45 PM
How to disable 'touch-to-click' for Synaptics TouchPad leonard Hardware & Laptops 3 27th February 2006 04:53 PM
Disabling tap click on Synaptics touch pad hakonrk Hardware & Laptops 1 18th June 2005 02:27 PM
synaptics tap-to-click in 2.6 coldforge Using Fedora 1 7th January 2004 05:05 PM


Current GMT-time: 23:38 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat