Fedora Linux Support Community & Resources Center
  #1  
Old 8th March 2011, 05:34 AM
PercentSevenC Offline
Registered User
 
Join Date: Mar 2011
Posts: 4
linuxfedorafirefox
Muting the speakers when headphones are plugged in (Intel HDA)

So, I've been having problems trying to get my external speakers to mute when I plug in my headphones. Right now, sound plays through both the headphones and the speakers at the same time.

I've tried several other Linux distros on this box, and all have the same issue. Works fine in Windows. None of the settings in either the Gnome sound preferences or alsamixer seem to help. Muting any of the channels mutes both the headphones and the speakers. I've tried setting the model manually in /etc/modprobe.d/sound.conf, but honestly I have no idea what I should set it to other than 6stack-dig. The chipset is a Realtek ALC888; output from alsa-info is attached.

Any help?
Attached Files
File Type: txt alsa-info.txt (40.5 KB, 202 views)
Reply With Quote
  #2  
Old 8th May 2012, 04:14 PM
Sibivel Offline
Registered User
 
Join Date: May 2012
Location: Erode
Posts: 1
linuxubuntufirefox
Re: Muting the speakers when headphones are plugged in (Intel HDA)

I too have the same and exact problem. I am just a beginner in ubuntu. Pls help me if your problem gets solved.
Reply With Quote
  #3  
Old 8th May 2012, 06:29 PM
PercentSevenC Offline
Registered User
 
Join Date: Mar 2011
Posts: 4
windows_7firefox
Re: Muting the speakers when headphones are plugged in (Intel HDA)

Afraid to say I've never gotten it working. I posted my issue in probably half a dozen Linux forums and never got any advice. I've just given up and run Windows, since living in a dorm makes this issue a deal-breaker, and I was tired of messing around with it anyway.

If it helps, I found that setting the model in sound.conf did nothing for me. I went through the entire list, rebooting every time, and there was no change no matter what I set it to.
Reply With Quote
  #4  
Old 9th May 2012, 04:26 PM
gagou7 Offline
Registered User
 
Join Date: May 2012
Location: Switzerland
Posts: 1
linuxiceweasel
Re: Muting the speakers when headphones are plugged in (Intel HDA)

I don't know how to mute automatically speaker when headphones are plugged. But you can do it manually. I'm on Debian and I just have to go to "Sound parameters" and in the tab "Output" I can choose "Analog Speaker" or "Headphones". Juste select "Analog Speaker" and check the mute case, then select "Headphones" and adjust the sound level as you want.
Reply With Quote
  #5  
Old 9th May 2012, 06:04 PM
Cygn Offline
Registered User
 
Join Date: Dec 2008
Location: Paris, FR
Posts: 154
linuxfirefox
Re: Muting the speakers when headphones are plugged in (Intel HDA)

try one of these instead of 6stack-dig:

Code:
ALC882/883/885/888/889
======================
  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  arima		Arima W820Di1
  targa		Targa T8, MSI-1049 T8
  asus-a7j	ASUS A7J
  asus-a7m	ASUS A7M
  macpro	MacPro support
  mb5		Macbook 5,1
  macmini3	Macmini 3,1
  mba21		Macbook Air 2,1
  mbp3		Macbook Pro rev3
  imac24	iMac 24'' with jack detection
  imac91	iMac 9,1
  w2jc		ASUS W2JC
  3stack-2ch-dig	3-jack with SPDIF I/O (ALC883)
  alc883-6stack-dig	6-jack digital with SPDIF I/O (ALC883)
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  acer-aspire-6530g Acer Aspire 6530G
  acer-aspire-7730g Acer Aspire 7730G
  acer-aspire-8930g Acer Aspire 8930G
  medion	Medion Laptops
  targa-dig	Targa/MSI
  targa-2ch-dig	Targa/MSI with 2-channel
  targa-8ch-dig Targa/MSI with 8-channel (MSI GX620)
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m540r	Clevo M540R (6ch + digital)
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  intel-alc889a	Intel IbexPeak with ALC889A
  intel-x58	Intel DX58 with ALC889
  asus-p5q	ASUS P5Q-EM boards
  mb31		MacBook 3,1
  sony-vaio-tt  Sony VAIO TT
Reply With Quote
  #6  
Old 9th May 2012, 07:00 PM
Donald Winslow Offline
Registered User
 
Join Date: Feb 2009
Posts: 72
linuxfirefox
Re: Muting the speakers when headphones are plugged in (Intel HDA)

I have the opposite problem. The sound plays over the headphones, but I can't figure out how to get it over the speaker.
Reply With Quote
  #7  
Old 9th May 2012, 08:44 PM
PercentSevenC Offline
Registered User
 
Join Date: Mar 2011
Posts: 4
windows_7firefox
Re: Muting the speakers when headphones are plugged in (Intel HDA)

Quote:
Originally Posted by gagou7 View Post
I don't know how to mute automatically speaker when headphones are plugged. But you can do it manually. I'm on Debian and I just have to go to "Sound parameters" and in the tab "Output" I can choose "Analog Speaker" or "Headphones". Juste select "Analog Speaker" and check the mute case, then select "Headphones" and adjust the sound level as you want.
Unfortunately, that didn't work for me. IIRC, the "headphones" setting does nothing, and the "analog speaker" setting mutes both the speakers and the headphones. Or maybe it was the other way around. I no longer have Linux installed on this machine so I can't readily check. I can try messing around with a live CD later this evening, though.

Quote:
Originally Posted by Cygn View Post
try one of these instead of 6stack-dig:
I tried all of those, or at least almost all of them (it looks like there are a few more added since then, or maybe my memory is just bad). Nothing changed no matter which one I picked (yes, I rebooted each time). Oh, and "auto" didn't work, either.

Last edited by PercentSevenC; 9th May 2012 at 08:56 PM.
Reply With Quote
  #8  
Old 9th May 2012, 09:01 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: Muting the speakers when headphones are plugged in (Intel HDA)

on mine, (00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)) I have an automute switch in alsamixer.

When it is set to "Disabled" I get sounds from both the speakers and headphones. When set to "Enabled" I get sound from the speakers when headphones are unplugged, and from the headphones when they are plugged in and the speakers are muted.
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2012-05-09 14:57:47.png
Views:	187
Size:	34.4 KB
ID:	23056  
Reply With Quote
  #9  
Old 10th May 2012, 12:51 AM
Donald Winslow Offline
Registered User
 
Join Date: Feb 2009
Posts: 72
linuxfirefox
Re: Muting the speakers when headphones are plugged in (Intel HDA)

I fixed my issue just as soon as I posted. In KDE System Settings, under Multimedia, I set the output to speakers.
Reply With Quote
  #10  
Old 10th May 2012, 08:31 PM
johnlvs2run Offline
Registered User
 
Join Date: Jul 2008
Location: western u.s.
Posts: 147
linuxfirefox
Re: Muting the speakers when headphones are plugged in (Intel HDA)

I always use the headphones, and leave the speakers unplugged.

Turning them off would have the same effect except use more energy.
__________________
biostar a870u3 / amd athlonII x2 regor250 3.0ghz am3 65w / gskill sniper 2x4gb ddr3 1333
evga 512-P3-1311-KR geforce 210 32bit ddr3 pci express hdcp video card / fedora 16 64 lxde
nvidia onboard / seagate barracuda 7200 250gb 3gbs hard drive / hannsg hw192 / earthwatts psu
Reply With Quote
  #11  
Old 11th May 2012, 08:10 PM
PercentSevenC Offline
Registered User
 
Join Date: Mar 2011
Posts: 4
linuxfedorakonqueror
Re: Muting the speakers when headphones are plugged in (Intel HDA)

Well, whatever the problem was, it seems to have been fixed in the Fedora 17 beta. The latest Ubuntu works as well. Good enough for me.
Reply With Quote
Reply

Tags
hda, headphones, intel, muting, plugged, speakers

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Headphones don't mute the speakers! thesun Hardware & Laptops 8 31st March 2014 10:44 AM
ALSA not muting speakers when headphones plugged in bbecker Fedora 13 Development Branch 9 18th May 2010 07:24 PM
Headphones not overriding speakers shortcut144 Using Fedora 20 3rd August 2009 03:33 PM
Headphones but no speakers SomeDamFool Hardware & Laptops 16 3rd March 2009 01:50 AM
audio from speakers and headphones Jaylor Hardware & Laptops 0 16th June 2008 12:55 AM


Current GMT-time: 04:16 (Tuesday, 23-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat