Fedora Linux Support Community & Resources Center
  #1  
Old 7th May 2012, 03:53 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
macosfirefox
nVidia drivers, mode setting and graphics...

At a LONG last I was able to get Fedora 16 running on my Mac 7,1.

Everything works alright, provided the right drivers are in place (WL for the Broadcom WLAN). Everything except for the graphics, once the nVidia drivers are installed. Since I boot with the EFI Stub, I am still learning about how to properly configure the boot process.

Once the drivers are installed, I can boot in single user or text mode just fine, alas, with modesetting still active, which, AFAIK is what causes the nvidida driver hiccups to start X, so I was wondering how to effectively turn modesetting off?

Parsing the rdblacklist=nouveau and modset=0 to the kenel through the refind_linux.conf doesn't seem to do the trick. I'm not sure if the initramfs image is actually stripped from the nouveau, however lspci -vv in single user mode lists 'nvidia' as the currently used driver, and both nvidia and nouveau as the available kernel modules.

In the mean time, I'll keep searching and reading...
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
Reply

Tags
drivers, graphics, mode, nvidia, setting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F12, two graphics cards and nVidia binary drivers eoghan Using Fedora 0 14th April 2010 06:24 PM
After Nvidia Driver install, cannot activate accelarated graphics mode bigred Using Fedora 0 2nd January 2010 12:47 AM
Unable to install Fedora 9 - sets nvidia Graphics mode to 81.3KHz/65Hz [SOLVED] fballem Installation, Upgrades and Live Media 5 15th October 2008 12:14 AM
Installing Nvidia Drivers: No Nvidia Graphics Driver Found! unholy1 Hardware & Laptops 9 6th April 2005 08:50 PM
Nvidia graphics drivers, won't install Bitmappity Hardware & Laptops 7 15th March 2005 03:13 PM


Current GMT-time: 14:01 (Saturday, 20-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat