Fedora Linux Support Community & Resources Center
  #1  
Old 6th May 2012, 03:00 PM
sdlor Offline
Registered User
 
Join Date: Mar 2008
Location: The Great Inland Northwest
Posts: 214
linuxchrome
Pluma (under Mate) will not open.

Hi All,

Up until just a couple days ago, I have been using (and liking) the Pluma text editor (for weeks). But, now it will not open.. Have removed and re-installed it twice; still no joy. It appears in the Applications menu (under accessories) and also in the the context (drop down) menus. But when clicked I just get the "spinning prompt" for a few seconds, and then it just gives up. Has anybody got any suggestions? My thanks, in advance.
__________________
F19-PAE, 32 bit; GeForce GT 430
Reply With Quote
  #2  
Old 6th May 2012, 03:02 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,170
linuxfirefox
Re: Pluma (under Mate) will not open.

Try opening it in a terminal to see the errors. If it's in the applications menu, simply opening a terminal and typing "pluma" should get results.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #3  
Old 6th May 2012, 03:26 PM
sdlor Offline
Registered User
 
Join Date: Mar 2008
Location: The Great Inland Northwest
Posts: 214
linuxchrome
Re: Pluma (under Mate) will not open.

Thanks for the quick reply!
Code:
[root@Rock /]# pluma
Illegal instruction
...hmmm
__________________
F19-PAE, 32 bit; GeForce GT 430

Last edited by sdlor; 6th May 2012 at 03:28 PM.
Reply With Quote
  #4  
Old 6th May 2012, 04:01 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,170
linuxfirefox
Re: Pluma (under Mate) will not open.

Oh jeez, now we've gotta turn you in.

Sadly, I'm not familiar with the package at all. Might be a different command to launch it properly.
Edit: Nope, went into MATE and while I did have some glitches with other things, pluma came up properly and launched correctly from terminal as "pluma". All my updates are current as of this morning, btw. Sorry, but I can't be of more help. You MIGHT want to mention this on the MATE Guide Raveit65 keeps pretty close watch on that one.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.

Last edited by bob; 6th May 2012 at 04:08 PM.
Reply With Quote
  #5  
Old 6th May 2012, 04:17 PM
sdlor Offline
Registered User
 
Join Date: Mar 2008
Location: The Great Inland Northwest
Posts: 214
linuxchrome
Re: Pluma (under Mate) will not open.

Thanks Bob,
Will probably do just that. Also seeing some other strange behavior; may be related to Mate..
I had just updated to new kernel. But, went back and loaded the old one.. Same problem.
Sure appreciate your replies.
__________________
F19-PAE, 32 bit; GeForce GT 430
Reply With Quote
  #6  
Old 7th May 2012, 11:18 PM
sdlor Offline
Registered User
 
Join Date: Mar 2008
Location: The Great Inland Northwest
Posts: 214
linuxchrome
Re: Pluma (under Mate) will not open.

Oh, all right.. I'll dust off my own thread.. (for the Mate users)
Review: Can't get Pluma and Caja to work now. Strange, but chronologically it seems to be related to when I installed and tested WordPress. Another response I'm seeing in the cli:
Code:
[root@Rock /]# pluma
No protocol specified
(pluma:6034): Gtk-WARNING **: cannot open display: :0.0
[root@Rock /]#
Anybody have any idea how to fix 'em? ..
Maybe a kindly Admin would be willing to move this to the "Mate" guide? Though, I've been told that questions don't belong in the guides ..(there are several (questions) in that one). Don't want to be accused of "double-posting".
__________________
F19-PAE, 32 bit; GeForce GT 430
Reply With Quote
  #7  
Old 7th May 2012, 11:45 PM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
If you run MATE as a regular user, there is no sensible reason why to run in root from the command line... Try running it as a regular user from a shell. IIRC, Fedora had banned for some time now the use of X and some programs to the root user when running in a root-less environment thus improving security.

So, unless you run MATE as root, it is best off to using a regular user account.

Maybe that's what's giving you the second error, root user cannot gain access to the X display 0.

Sent on the move
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.

Last edited by Thetargos; 7th May 2012 at 11:47 PM.
Reply With Quote
  #8  
Old 8th May 2012, 12:12 AM
sdlor Offline
Registered User
 
Join Date: Mar 2008
Location: The Great Inland Northwest
Posts: 214
linuxchrome
Re: Pluma (under Mate) will not open.

Doesn't matter how I try, just can' t get it to open.
Code:
[duke@Rock Desktop]$ pluma
Illegal instruction
[duke@Rock Desktop]$
I can try to open it from the Applications menu, or from a context menu. Just will not open. It used to work fine.
__________________
F19-PAE, 32 bit; GeForce GT 430
Reply With Quote
  #9  
Old 8th May 2012, 12:31 AM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,843
linuxfirefox
Re: Pluma (under Mate) will not open.

Just collecting some information - what is the output of

Code:
which pluma
Is it possible that the link to binary is broken? May be reinstall pluma?

Code:
yum reinstall pluma
Reply With Quote
  #10  
Old 8th May 2012, 12:51 AM
sdlor Offline
Registered User
 
Join Date: Mar 2008
Location: The Great Inland Northwest
Posts: 214
linuxchrome
Re: Pluma (under Mate) will not open.

Code:
[duke@Rock Desktop]$ which pluma
/usr/bin/pluma
Have already removed and re-installed twice (three times now)
Still no joy..
But, thanks just the same!
__________________
F19-PAE, 32 bit; GeForce GT 430
Reply With Quote
  #11  
Old 8th May 2012, 12:59 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
Search for a .pluma directory in your home directory. Chances are a preferences setting or some other configuration is interfering. In nautilus use ctrl+H to toggle show of hidden files and directories (which dot files are in Linux). Since i'm unfamiliar with MATE's file manager, I don't know if it is the same, though that short cut is pretty much universal (across dolphin, konqueror, xfce and Nautilus, anyway)

Sent on the move
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.

Last edited by Thetargos; 8th May 2012 at 01:04 AM.
Reply With Quote
  #12  
Old 13th May 2012, 05:27 PM
sdlor Offline
Registered User
 
Join Date: Mar 2008
Location: The Great Inland Northwest
Posts: 214
linuxchrome
Re: Pluma (under Mate) will not open.

Hi All,

Re: Post # 11:
Thanks for the suggestion Thetargos, but there is no .pluma (or .caja) directory in my home directory. (I don't think there ever was, even when pluma and caja were working). There is also no .gedit or .nautilus directories either, but they both (gedit and nautilus) work fine (fortunately).
I suspect my problem is related to the Mate desktop manager.

Administrators: Can this thread be closed? Or moved to the Mate guide thread? Or, can I pose a (new) question in the Mate guide thread, without crossing the dreaded "double-posting" threshold ? ...
__________________
F19-PAE, 32 bit; GeForce GT 430
Reply With Quote
  #13  
Old 13th May 2012, 06:11 PM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
linuxfirefox
Re: Pluma (under Mate) will not open.

Just installed MATE to try a fresh GNOME 2.x environment, nice indeed!

Since Pluma (pen) in Spanish is the substitute for Gedit, you will find its configuration and settings under what used to be .gconf, so it should now be .mateconf/apps/pluma... I should have seen this comming, and instead direct you to search for the directory rather than "statitcally" tell you where it was... A simple

Code:
find . -iname pluma
Did the trick. Deleting that directory should be enough to wipe all configurations for pluma from your session and you should be able to start it again.
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
  #14  
Old 13th May 2012, 06:51 PM
sdlor Offline
Registered User
 
Join Date: Mar 2008
Location: The Great Inland Northwest
Posts: 214
linuxchrome
Re: Pluma (under Mate) will not open.

Re: Post # 12
Thank you sir, I'll certainly give it a try..

---------- Post added at 10:49 AM ---------- Previous post was at 10:14 AM ----------

Re: Posts 13 and 14..

(I assume you meant the pluma directory (under .mateconf/apps) ?
Made no difference ... But, thank you so much.. I suspect I might best delete MATE-Desktop,
and start over again.. Nothing I've tried makes any difference.. Can't seem to get caja or pluma to work.

---------- Post added at 10:51 AM ---------- Previous post was at 10:49 AM ----------

Whoops, I meant that last edit to be a new post..
__________________
F19-PAE, 32 bit; GeForce GT 430
Reply With Quote
  #15  
Old 13th May 2012, 07:00 PM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
linuxfirefox
Re: Pluma (under Mate) will not open.

The forums append new posts as edits, depending on the time between the posts, and if no one has replied

Hmmm... In that case, it would be best to wipe all mate's configuration:

Code:
rm -rf .mate*
Log out and then back in.

WARNING! All you configurations will be lost when doing this, resulting in Mate starting with defaults, it might pick up from Shell, Cinnamon or other DE!

Forgot to mention, the other common location for configurations (for future reference) is .config/<app_name>, and indeed there is a .config/pluma and .config/caja directories!
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.

Last edited by Thetargos; 13th May 2012 at 07:05 PM.
Reply With Quote
Reply

Tags
mate, open, pluma

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MATE-Desktop for fedora raveit65 Guides & Solutions (No Questions) 332 12th September 2014 05:58 PM
MATE desktop available for F16! tsorvoja Using Fedora 0 27th January 2012 06:01 PM
Mate Desktop Environment is977 Using Fedora 8 14th December 2011 08:23 PM
Red Hat 8 Wireless On Acer T-Mate 2423 Studio bl Hardware & Laptops 1 27th May 2006 05:33 PM
Compro TV Mate GOLD problem balcinus Hardware & Laptops 0 8th August 2005 03:24 AM


Current GMT-time: 10:04 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Marmaris Photos on Instagram - Colonia Travel Photos - Saint-Louis Travel Photos on Instagram