Fedora Linux Support Community & Resources Center
  #1  
Old 4th May 2012, 03:22 PM
geolab Offline
Registered User
 
Join Date: Nov 2008
Posts: 119
linuxchrome
rc.local not starting anymore

systemctl enable rc-local.service
Warning: unit files do not carry install information. No operation executed

... what does it mean?


sytemctl status rc-local.service
rc-local.service - /etc/rc.d/rc.local Compatibility
Loaded: loaded (/usr/lib/systemd/system/rc-local.service; static)
Active: failed (Result: exit-code) since Fri, 04 May 2012 16:19:58 +0200; 25s ago
Process: 1823 ExecStart=/etc/rc.d/rc.local start (code=exited, status=203/EXEC)
CGroup: name=systemd:/system/rc-local.service

this is my rc.local
#!/bin/sh
echo 2 > /sys/module/hid_apple/parameters/fnmode
Reply With Quote
  #2  
Old 4th May 2012, 04:10 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,525
linuxfirefox
Re: rc.local not starting anymore

Make sure the #!/bin/sh is at the very top--that is, make sure there is no blank line (or lines) at the top.

Make sure it's still mode 755

Both of those have caused me problems in the past through carelessness on my part.
Reply With Quote
  #3  
Old 5th May 2012, 08:17 AM
geolab Offline
Registered User
 
Join Date: Nov 2008
Posts: 119
linuxfirefox
Re: rc.local not starting anymore

you're right! it was second line!
Reply With Quote
  #4  
Old 5th May 2012, 12:11 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,525
linuxchrome
Re: rc.local not starting anymore

Glad to help. Aggravating, isn't it? In my case, I kept looking and looking before I realized it.
Reply With Quote
Reply

Tags
anymore, rclocal, starting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Client xx rejected from local host (when starting bacula's bat monitor) ddeutsch Using Fedora 0 29th March 2009 10:20 PM
UDev not starting RAID arrays anymore HishnGA Using Fedora 0 14th May 2008 08:03 PM
How to block all local IP and allow certain local IP using IPTABLES to connect inet? laluvirtual Security and Privacy 5 29th June 2007 01:07 PM
Gnome not starting anymore tsorvoja Using Fedora 3 3rd June 2005 07:44 AM
eclipse not starting anymore since installation of matrox g450 ascheucher Hardware & Laptops 1 1st March 2005 08:54 PM


Current GMT-time: 07:59 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Chak Azam Saffo Travel Photos on Instagram - Yashiro - Aracruz Travel Photos on Instagram