Fedora Linux Support Community & Resources Center
  #16  
Old 27th April 2012, 01:44 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,764
windows_xp_2003firefox
Re: Issues connecting to smb NAS

I'm not familiar with Samba4. Maybe there are major differences between it and its predecessor.

You should be looking at the log files for clues.
Code:
/var/log/samba/
/var/log/secure
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #17  
Old 27th April 2012, 02:03 PM
sea Online
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Re: Issues connecting to smb NAS

I dont think samba4 is required, as it had listed/shown:
Quote:
Originally Posted by sea's smbclient -L
Domain=[OCEAN] OS=[Unix] Server=[Samba 3.5.6]
It was my bad that i had installed samba4

There are no logs in /var/log/samba/ and ...*/old
the logs in /var/log/secure show only what i have entred on consle, no error messages.
The only 'helpfull' entry i had found was that i had gained access to firewall..
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot
Reply With Quote
  #18  
Old 28th April 2012, 04:57 AM
Doug G Offline
Registered User
 
Join Date: Jul 2005
Posts: 640
linuxfirefox
Re: Issues connecting to smb NAS

One wild guess, check that port 445 is open through your firewall. It should be if you enabled smb networking but I think I had to manually open this port on some version of Fedora once. SMB networking uses ports 135-137, 139, 445 and probably some more. MS has a KB article of all their port usage, you can find the requirements for SMB in the article. I would guess your NAS device conform to the same port usage.

http://support.microsoft.com/kb/832017
__________________
======
Doug G
======
Reply With Quote
  #19  
Old 28th April 2012, 08:02 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,764
linuxfirefox
Re: Issues connecting to smb NAS

I *think* I've seen posts where Samba4 wasn't being too friendly quite yet. I wonder if it would be worth reverting to the previous version of Samba.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #20  
Old 28th April 2012, 08:08 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,889
linuxfirefox
Re: Issues connecting to smb NAS

Howdy,

I think you got to decide what exactly you want to do:
Connect to a remote samba server or
run your own samba server.

You don't need to run samba in order to connect to another samba server.
Reply With Quote
  #21  
Old 28th April 2012, 06:28 PM
sea Online
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
windows_7firefox
Re: Issues connecting to smb NAS

@flyingfsck: So i can 'savely' remove the "samba*" packages? But to keep the cifs-utils?
As the topic of this thread is: issues connecting to my NAS, its given fact i dont want to run another samba server

@Doug G: I dont trust a GUI where i had the green 'check' in the samba boxes.
I had green-checked all samba boxes in the firewall gui, one of these items had port 445 listed.

How would i recognize that these ports are raelly open on CLI, using sudo iptables -L?
Because, on page 1 of this thread, i have an output of iptables (is that the same as the GUI of system-config-firewall??), but didnt see any port numbers there, which is quite confusing to me as of now.

However, the most confusing part to me is this:
List dirs on the NAS: works
Mount dirs on the NAS to local: dont

EDIT:
Guess its another time to re-setup my machine from scratch, as i have like 3 incomplete systems installed
Everything i had found, and what was suggested in this thread, doesnt work as expected/ it should.
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot

Last edited by sea; 28th April 2012 at 06:32 PM.
Reply With Quote
  #22  
Old 28th April 2012, 07:39 PM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,889
linuxfirefox
Re: Issues connecting to smb NAS

Howdy,

You can connect to a remote samba server, just with Nautilus, Dolphin or Konqueror and the cifs and smbclient utilities.

Note that if you cannot figure out how to connect with smbclient, then you won't be able to connect any other way either.

As a first step, I always try to browse the remote server with something like this, to get a list of shares:
smbclient -L //serveripaddress -N

Once I can do that, I try to connect to a share with something like:
smbclient //serveripaddress/share -W workgroup -U username%password

Once you got that to work, you can continue and try to connect to the server using Nautilus.

Maybe have a look at this:
http://www.aeronetworks.ca/howtos/sa...bug-howto.html

Hope that helps!

F.

Last edited by flyingfsck; 28th April 2012 at 07:47 PM.
Reply With Quote
  #23  
Old 28th April 2012, 08:01 PM
RHamel Offline
Registered User
 
Join Date: Sep 2004
Location: Denver, Colorado
Posts: 560
linuxfirefox
Re: Issues connecting to smb NAS

Code:
iptables -L -n
Will show the actual port numbers.
Reply With Quote
  #24  
Old 30th April 2012, 06:19 PM
sea Online
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Re: Issues connecting to smb NAS

Ok, there's now some kind of piece in my mind...
The issue is NOT the firewall/ports, but most likely the uid,pw,domai/workgroup thing.

As i assumed previuosly, as i could list the paths on the NAS, this veryfies the plain 'accessibility'.
However, the error message i get, an error with either username, password, or workgroup/domain.

Given the fact that, for testing purposes only, i had set username and pw the same as my laptop, the issue 'must' be the domain or workgroup.

As i am NOT running a samba server, i guess the following output is irrelevant:
Code:
$ ps -e | grep smbd
$ ps -e | grep nmbd
As they both remain empty, since these services are not installed.

But once more, the HOWTO refers to smbmount, which Fedora doesnt seem to know.
Code:
# yum provides smbmount
Allthough i have "samba" installed for the smbclient, it doesnt know smbmount.
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot
Reply With Quote
  #25  
Old 30th April 2012, 06:50 PM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,889
linuxfirefox
Re: Issues connecting to smb NAS

Yup, smbmount has been obsoleted a long time ago.

Note that if you cannot connect with smbclient, then you will not be able to connect any other way either. The advantage of smbclient is that you get some error messages.

So try something like:
smbclient -L //serveripaddress -N

If you get a result, try to use authentication:
smbclient -L //serveripaddress -U username%password

whether the above works or not, try to add the workgroup (domain) into the mix:
smbclient -L //serveripaddress -W workgroup -U username%password

and finally if the above works try to connect to a share:
smbclient //serveripaddress/share -W workgroup -U username%password

Paste the error messages here and someone may be able to give you a clue.

BTW, do yourself a favour and read the smbclient man page.
Reply With Quote
  #26  
Old 1st May 2012, 12:48 PM
sea Online
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Re: Issues connecting to smb NAS

Geesh, i have found the errors:
1) I tried to connect to my NAS, while keep using the -L swtich..
2) Havent edited /etc/samba/smb.conf properly, syntax was ok, but the values wrong...
3) while i had not used the -L, the conf file was wrong, or vice-versa...
/solved

-----------------------------------------------------------------
Something i'd like to share, as i wrote it for 'easier debuging' and hope it may help others:

Bash-Script (php tags are only for better reading):
PHP Code:
#!/bin/bash
# |
# |    Samba Debug and Config Tool, 2012.Mai.01 by sea
# |    To create the 'config' files, it needs to be run as root
# |    To debug only, it could be run as any user
# |    That way, the credentials may only be access with sufficant rights
# |
# | Defaults
    #
    # Change your personal default values here
    #
    
readonly SMB_DEFAULT_IP=192.168.10.110
    readonly SMB_DEFAULT_NAME
=ocean
    readonly SMB_DEFAULT_WKGRP
=ogog
    readonly SMB_DEFAULT_DOMAIN
=ogog
    test 
root $USER && readonly SMB_DEFAULT_USR=$USER
# |
# | Variables
    #
    # str_smb is only for the debug config file
    # while smb_str_* will be for the real smb.conf (much, much later, if ever)
    #
    
tmpfile=/tmp/smb.tmp
    readonly SAMBA_DEBUG_CONFIG
=/etc/samba/smb-debug.conf
    readonly SAMBA_CREDENTIALS
=/etc/samba/smb.cred
    readonly STR_SMB_IP
="samba_ip"
    
readonly STR_SMB_NAME="samba_device_name"
    
readonly STR_SMB_WKGRP="samba_workgroup"
    
readonly STR_SMB_USR="samba_user"
    
readonly STR_SMB_DOM="samba_domain"
    
readonly SMBC="$(which smbclient)"
# |
# | Subs
    
liner() { echo "----------------------------"; }
    
press() { read -"Press [ENTER] to continue" buffer; }
    
test_samba_debug_config() { # Tests if the file is present, if not, asks to complete it
        
if [ ! -f $SAMBA_DEBUG_CONFIG ]
        
then    echo "Did not found $SAMBA_DEBUG_CONFIG, do you want to create it?"
            
select filldebug in yes no;do test "$filldebug"no" && return || break;done
            read 
-"$STR_SMB_IP? ($SMB_DEFAULT_IP): " var_smb_ip
            read 
-"$STR_SMB_NAME?: " var_smb_name
            read 
-"$STR_SMB_WKGRP?: " var_smb_wkgrp
            read 
-"$STR_SMB_USR? ($SMB_DEFAULT_USR): " var_smb_usr
            read 
-"$STR_SMB_DOM?: " var_smb_dom

            
#
            # Check for empty variables, and fill with default values
            #
            
test "" "$var_smb_ip&& var_smb_ip=$SMB_DEFAULT_IP
            test 
"" "$var_smb_usr&& var_smb_ip=$SMB_DEFAULT_USR
            test 
"" "$var_smb_name&& var_smb_ip=$SMB_DEFAULT_NAME
            test 
"" "$var_smb_wkgrp&& var_smb_ip=$SMB_DEFAULT_WKGRP
            test 
"" "$var_smb_dom&& var_smb_ip=$SMB_DEFAULT_DOMAIN
            
            
#
            # Fill the samba debug config
            #
            
printf "$STR_SMB_IP=$var_smb_ip\n$STR_SMB_NAME=$var_smb_name\n$STR_SMB_WKGRP=$var_smb_wkgrp\n$STR_SMB_USR=$var_smb_usr\n$STR_SMB_DOM=$var_smb_dom\n" $SAMBA_DEBUG_CONFIG && \
                echo 
"Successfully saved $SAMBA_DEBUG_CONFIG|| echo "Not enough permission"

            
#
            # Fill samba - credentials
            #
            
if [ ! -f $SAMBA_CREDENTIALS ]
            
then    echo "If you want to create a samba credentials file, please provide the password:"
                
read -"Password: " var_smb_pw
                printf 
"username = $var_smb_usr\npassword = $var_smb_pw\ndomain = $var_smb_dom\n" $SAMBA_CREDENTIALS
            fi
        fi
        
return 0
    
}
# |
# | Output
    
clear
    
echo "Samba Debuging tool by (sea)"
    
liner
    
echo "Testing for $SAMBA_DEBUG_CONFIG..."
    
press
    test_samba_debug_config 
&& source $SAMBA_DEBUG_CONFIG

    liner
    
echo
    echo 
"Testing $samba_ip"
    
press
    ping 
-c 1 $samba_ip

    liner
    
echo
    echo 
"Testing Firewall"
    
press
    iptables 
--n

    liner
    
echo
    echo 
"Testing: samba share fusefs"
    
press
    getsebool samba_share_fusefs

    liner
    
echo
    echo 
"Testing: /etc/smb.conf using testparm"
    
press
    testparm

    liner
    
echo
    echo 
"List Services for samba server (only required for samba server!)"
    
press
    ps 
-grep smbd
    ps 
-grep smbd

    liner
    
echo
    echo 
"List logfiles in /var/log/samba/"
    
press
    ls 
"/var/log/samba/*" --color=auto

    liner
    
echo
    if [ ! -
f $SAMBA_CREDENTIALS ]
    
then    echo "Testing $SMBC with $samba_device_name as $samba_user"
        
press
        $SMBC 
-L $samba_device_name -U $samba_user $tmpfile
    
else    echo "Testing $SMBC with $SAMBA_CREDENTIALS"
        
cat $SAMBA_CREDENTIALS && echo "----------------------------"
        
press
        $SMBC 
-L $samba_device_name -A $SAMBA_CREDENTIALS $tmpfile
    fi
    cat $tmpfile

    liner
    
echo
    
read -"Connect to $samba_device_name? (y/n)" -n1 smb_conn
    
if [ "y" "$smb_conn]
    
then    shares=$(cat $tmpfile|grep Disk|awk '{print $1}')
        
printf "\nPlease select the share you want to connect:\n"
        
select this_share in $shares; do break;done
        cmds
="$SMBC //$samba_device_name/$this_share -A $SAMBA_CREDENTIALS"
        
echo "For later usage: $cmds"
        
$cmds
    fi 
Possible output:
Code:
[simon@l670 /]$ smb-debug

Samba Debuging tool by (sea)
----------------------------
Testing for /etc/samba/smb-debug.conf...
Press [ENTER] to continue
----------------------------

Testing 192.168.10.110
Press [ENTER] to continue
PING 192.168.10.110 (192.168.10.110) 56(84) bytes of data.
64 bytes from 192.168.10.110: icmp_req=1 ttl=64 time=3.81 ms

--- 192.168.10.110 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 3.818/3.818/3.818/0.000 ms
----------------------------

Testing Firewall
Press [ENTER] to continue
iptables v1.4.12: can't initialize iptables table `filter': Permission denied (you must be root)
Perhaps iptables or your kernel needs to be upgraded.
----------------------------

Testing: samba share fusefs
Press [ENTER] to continue
samba_share_fusefs --> off
----------------------------

Testing: /etc/smb.conf using testparm
Press [ENTER] to continue
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[printers]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
	workgroup = OCEAN
	server string = Samba Server Version %v
	log file = /var/log/samba/log.%m
	max log size = 50
	idmap config * : backend = tdb
	cups options = raw

[homes]
	comment = Home Directories
	read only = No

[printers]
	comment = All Printers
	path = /var/spool/samba
	printable = Yes
	print ok = Yes
	browseable = No
----------------------------

List Services for samba server (only required for samba server!)
Press [ENTER] to continue
----------------------------

List logfiles in /var/log/samba/
Press [ENTER] to continue
ls: cannot access /var/log/samba/*: Permission denied
----------------------------

Testing /usr/bin/smbclient with /etc/samba/smb.cred
username = simon
password = <<password>>
domain = ogog
----------------------------
Press [ENTER] to continue
Domain=[OGOG] OS=[Unix] Server=[Samba 3.5.6]
Domain=[OGOG] OS=[Unix] Server=[Samba 3.5.6]

	Sharename       Type      Comment
	---------       ----      -------
	IPC$            IPC       IPC Service (Iomega StorCenter ix2-200)
	priv            Disk      
	pub             Disk      
	TimeMachine     Disk      
	Pictures        Disk      
	Music           Disk      
	Movies          Disk      
	Linux           Disk      
	Backups         Disk      

	Server               Comment
	---------            -------
	OCEAN                Iomega StorCenter ix2-200

	Workgroup            Master
	---------            -------
	OGOG                 OCEAN
----------------------------

Connect to ocean? (y/n)y
Please select the share you want to connect:
1) priv		3) TimeMachine	5) Music	7) Linux
2) pub		4) Pictures	6) Movies	8) Backups
#? 6
For later usage: /usr/bin/smbclient //ocean/Movies -A /etc/samba/smb.cred
Domain=[OGOG] OS=[Unix] Server=[Samba 3.5.6]
smb: \> 
smb: \> ls
  .                                   D        0  Sun Feb 19 19:02:26 2012
  ..                                  D        0  Thu Apr 26 14:25:14 2012
  DefaultPicture.png                        4735  Sun Feb  5 13:13:38 2012
  honey2-english.mp4                  A 1175164011  Sun Oct 30 22:12:37 2011
  ManFromEarth.mp4                    A 713662277  Wed Aug 31 06:19:02 2011
  PREDATORS.avi                       A 723514156  Mon Jan 30 23:42:03 2012
  ResidentEvil1.mp4                   A 640234883  Mon Aug 29 15:55:30 2011
  ResidentEvil2.mp4                   A 576071587  Mon Aug 29 17:37:08 2011
  ResidentEvil4.mp4                   A 552054097  Mon Aug 29 04:20:58 2011
  The last Samurai (deutsch).mp4      A 505413632  Tue Dec 13 02:12:15 2011
  the6thsense.mp4                     A 914751488  Sat Jan 21 12:36:18 2012
  THE_SCORPION_KING_3.avi               724151152  Sun Feb 19 19:01:51 2012

		58307 blocks of size 16777216. 56350 blocks available
smb: \> q
[simon@l670 /]$
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot

Last edited by sea; 1st May 2012 at 01:00 PM.
Reply With Quote
  #27  
Old 1st May 2012, 05:37 PM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,889
linuxfirefox
Re: Issues connecting to smb NAS

Congrats!

I must say I much prefer NFS, since it is way easier to configure than Samba.
Reply With Quote
  #28  
Old 1st May 2012, 05:49 PM
sea Online
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Re: Issues connecting to smb NAS

Thank you.

Well, i'm using samba because "ES Explrorer" of my Android showed the smb:// prefix when accessing the NAS.
So i thought its the 'best' way to make it work, as its linux too.
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot
Reply With Quote
Reply

Tags
connecting, issues, nas, smb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Network connecting issues/annoyances zKarp Using Fedora 2 29th February 2012 07:05 AM
issues connecting to wireless router antikythera Servers & Networking 3 5th May 2010 05:06 AM
Issues connecting to interent Kironos Using Fedora 3 28th June 2008 05:57 AM
SSH issues when connecting from outside LAN fedoraguy123 Security and Privacy 1 20th December 2006 11:03 PM
SSH/Connecting issues Otter Servers & Networking 21 17th May 2005 09:19 PM


Current GMT-time: 00:03 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Panshi - Dumraon - Kairouan Photos