Fedora Linux Support Community & Resources Center
  #1  
Old 22nd April 2012, 04:23 PM
benjamindaines Offline
Registered User
 
Join Date: Apr 2012
Location: USA
Posts: 15
linuxfirefox
Firefox UI Rendering Issues

I've noticed a bunch of strange UI element rendering issues while using firefox on f16 with a ATI Mobility X1600 (Gallium 0.4 on ATI RV530 driver). I've attached some screen shots. There doesn't seem to be any kind of pattern as to when these things happen. I've only noticed it in firefox, but I don't know if that means it's an issue with firefox or whether it's the only window I have open (apart from thunderbird minimized all the time) long enough to exibit any kind of issue. It doesn't happen immediately when opening FF, but after it's been running a while.

Any one have any ideas on this one? Thanks.

I will update this post as more UI glitches happen.
Attached Thumbnails
Click image for larger version

Name:	Firefox Google Search.png
Views:	67
Size:	4.6 KB
ID:	22973   Click image for larger version

Name:	Firefox Scroll.png
Views:	58
Size:	18.9 KB
ID:	22974   Click image for larger version

Name:	Firefix Forward Inactive.png
Views:	54
Size:	19.1 KB
ID:	22976  
Attached Images
 

Last edited by benjamindaines; 22nd April 2012 at 04:58 PM.
Reply With Quote
  #2  
Old 22nd April 2012, 05:25 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,502
linuxfirefox
Re: Firefox UI Rendering Issues

I have seen such rendering problems with Google chrome for a very short period (may be one or two days) a few months ago. I have not seen these since ... I say google chrome because, it was almost identical to your images.

Curious to know what this is in reality ...
Reply With Quote
  #3  
Old 22nd April 2012, 05:48 PM
benjamindaines Offline
Registered User
 
Join Date: Apr 2012
Location: USA
Posts: 15
linuxfirefox
Re: Firefox UI Rendering Issues

Quote:
Originally Posted by nonamedotc View Post
I have seen such rendering problems with Google chrome for a very short period (may be one or two days) a few months ago. I have not seen these since ... I say google chrome because, it was almost identical to your images.

Curious to know what this is in reality ...
Do you reacall what kernel you were running before and after? Did it go away with a kernel update? I'm hanging back on 3.1 due to an issue with the battery monitory in 3.3.
Reply With Quote
  #4  
Old 23rd April 2012, 05:50 PM
KJG41HES99 Offline
Registered User
 
Join Date: Oct 2010
Location: Chile
Posts: 8
linuxfirefox
Re: Firefox UI Rendering Issues

I have this problem too.

My hardware is similar (ATI Mobility X1400, Gallium 0.4 on ATI RV515). Firefox is the main app affected (well, it's my most used app too), but I saw this issues with Thunderbird and nautilus. Restarting the respective application helps.


F16 with last updates, I don't have a custom xorg.conf file
Code:
$ uname -r
3.3.2-1.fc16.i686.PAE

$ rpm -q xorg-x11-drv-ati
xorg-x11-drv-ati-6.14.3-4.20120201git36c190671.fc16.i686
I will start to look in the xorg logs with time...

Last edited by KJG41HES99; 23rd April 2012 at 05:52 PM.
Reply With Quote
  #5  
Old 23rd April 2012, 10:01 PM
benjamindaines Offline
Registered User
 
Join Date: Apr 2012
Location: USA
Posts: 15
linuxfirefox
Re: Firefox UI Rendering Issues

Upon further review, it seems to be this bug rearing it's ugly face https://bugzilla.redhat.com/show_bug.cgi?id=706761

Hopefully this gets fixed soon so I can show my Fedora rig off without be being a bug fest.
Reply With Quote
  #6  
Old 23rd April 2012, 10:29 PM
caravel Offline
Registered User
 
Join Date: Oct 2006
Posts: 5
linuxiceweasel
Re: Firefox UI Rendering Issues

It may also be the this you're seeing: https://bugs.freedesktop.org/show_bug.cgi?id=47266
Reply With Quote
  #7  
Old 23rd April 2012, 10:31 PM
benjamindaines Offline
Registered User
 
Join Date: Apr 2012
Location: USA
Posts: 15
linuxfirefox
Re: Firefox UI Rendering Issues

Quote:
Originally Posted by caravel View Post
It may also be the this you're seeing: https://bugs.freedesktop.org/show_bug.cgi?id=47266
I have seen that in the past, but it seems to have gone away with changing the gnome shell theme. There was a similar bug posted in the fedora bugzilla, and what was listed as a workaround.
Reply With Quote
  #8  
Old 24th April 2012, 01:00 AM
KJG41HES99 Offline
Registered User
 
Join Date: Oct 2010
Location: Chile
Posts: 8
linuxfirefox
Re: Firefox UI Rendering Issues

Quote:
Originally Posted by benjamindaines View Post
Upon further review, it seems to be this bug rearing it's ugly face https://bugzilla.redhat.com/show_bug.cgi?id=706761

Hopefully this gets fixed soon so I can show my Fedora rig off without be being a bug fest.
Yeah, I see these symptoms too, thanks for pointed out the link. But seeing that the bug has almost a year without aparent work doesn't give me much hope...
Reply With Quote
  #9  
Old 24th April 2012, 01:02 AM
benjamindaines Offline
Registered User
 
Join Date: Apr 2012
Location: USA
Posts: 15
linuxfirefox
Re: Firefox UI Rendering Issues

Quote:
Originally Posted by KJG41HES99 View Post
Yeah, I see these symptoms too, thanks for pointed out the link. But seeing that the bug has almost a year without aparent work doesn't give me much hope...
yup =[ maybe we should put a bounty on it...
Reply With Quote
  #10  
Old 24th April 2012, 07:36 AM
Dutchy Offline
Registered User
 
Join Date: Aug 2011
Posts: 926
linuxsafari
Re: Firefox UI Rendering Issues

What happens when you disable FF's hardware acceleration?
Reply With Quote
Reply

Tags
firefox, gui, issues, rendering

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox slow page rendering guilhermeptrr Using Fedora 0 10th March 2011 08:20 PM
[SOLVED] Font rendering bad only in Firefox trashbird1240 Using Fedora 5 11th June 2010 04:24 PM
Firefox not rendering corectly! cbarmpar Using Fedora 5 20th September 2008 09:52 PM


Current GMT-time: 02:02 (Monday, 21-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat