Fedora Linux Support Community & Resources Center
  #1  
Old 23rd April 2012, 06:14 PM
jello Offline
Registered User
 
Join Date: Apr 2012
Location: Brazil
Posts: 4
linuxfedorakonqueror
keyboard layout

I have a new installation of fedora 15 so far almost everything is working
the problem is i have the system in English but with a Brazilian keyboard
This is not working.
I tried to change the keyboard layout but i cant find it anywhere.
A tutorial on the net talked about

"run the Keyboard Preferences utility by selecting System → Preferences → Keyboard from the panel,"
but it is not there
Reply With Quote
  #2  
Old 23rd April 2012, 06:41 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: keyboard layout

I think it's <your name button> → System Settings, isn't it?
Did your computer come with F15 pre-installed? Because current is F16 and next month F17 is launched.
-edit- I see you're using KDE (the above was for GNOME).
Open the menu and go to 'System Settings' (I'm writing this from memory). Then find which button has the keyboard option (when you hover the mouse over them it shows the options), click on it and change the keyboard for the one from Brazil.
You can change the 'locale' too still keeping the system in English. It's somewhere else in the System Settings app and that will give you a Brazilian calendar and other things like units and how it shows time and date.

You can change a lot of things in KDE. Try exploring all the options in 'System Settings' (without necessarily changing them) so you get acquainted with them.

Last edited by secipolla; 23rd April 2012 at 06:48 PM.
Reply With Quote
  #3  
Old 23rd April 2012, 07:10 PM
jello Offline
Registered User
 
Join Date: Apr 2012
Location: Brazil
Posts: 4
linuxfedorakonqueror
Re: keyboard layout

i went to system systems and then to locale no other gaves me language options but there i can only change the default language no keyboard options. I look at every option in system settings but no option for the keyboard layout
Reply With Quote
  #4  
Old 23rd April 2012, 11:16 PM
JONOR Offline
Registered User
 
Join Date: Aug 2007
Location: Cornwall England
Posts: 333
linuxfirefox
Re: keyboard layout

For Gnome the keyboard layouts are found in system settings > region and language > layouts.
KDE should be fairly similar i imagine.
Reply With Quote
  #5  
Old 24th April 2012, 12:40 AM
jello Offline
Registered User
 
Join Date: Apr 2012
Location: Brazil
Posts: 4
linuxfirefox
Re: keyboard layout

I did a new install this time with kde as default
now in system settings it gives me the option input devices but to be honest i cant the Portuguese keyboard to work.
anyone have any sugestions?
Reply With Quote
  #6  
Old 24th April 2012, 12:46 AM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: keyboard layout

So you were on GNOME before? Using Konqueror?
Did you find the keyboard option in KDE?
Remember you must click 'Apply' after the changes. And there should be a box where you can test the keyboard.
Reply With Quote
  #7  
Old 24th April 2012, 03:36 PM
jello Offline
Registered User
 
Join Date: Apr 2012
Location: Brazil
Posts: 4
linuxfirefox
Re: keyboard layout

I am on kde and there was no keyboard option in the system settings. I did a fresh install this time with Kde as default. Still there is no keyboard option in the system settings however this time there is a input devices option.
but i dont have any luck with that either. I can put the portuguease layout in it as a option but the keyboard does not behaves as it should do?
Reply With Quote
  #8  
Old 25th April 2012, 12:29 AM
JONOR Offline
Registered User
 
Join Date: Aug 2007
Location: Cornwall England
Posts: 333
linuxfirefox
Re: keyboard layout

Just switched to KDE here, there is a keyboard option within input devices on this system.
So : KDE system settings > input devices > keyboard > layouts > configure layouts > add

Last edited by JONOR; 25th April 2012 at 12:32 AM.
Reply With Quote
  #9  
Old 25th April 2012, 12:46 AM
j0534ng31 Offline
Registered User
 
Join Date: May 2011
Location: Gijón, Spain
Age: 42
Posts: 28
linuxfirefox
Re: keyboard layout

Quote:
Originally Posted by jello View Post
I can put the portuguease layout in it as a option but the keyboard does not behaves as it should do?
As I have had almost the same problem (spanish instead ), I suppose you are looking for this:
Code:
$ su -
# system-config-keyboard
Reply With Quote
  #10  
Old 25th April 2012, 08:38 AM
JONOR Offline
Registered User
 
Join Date: Aug 2007
Location: Cornwall England
Posts: 333
linuxfirefox
keyboard layout

Code:
$ su -
# system-config-keyboard
Ha ! first time i've seen a Brazilian keyboard mentioned, not that i would personally need it.
That list is quite different from kde systems settings keyboard layouts and variants.
Reply With Quote
  #11  
Old 25th April 2012, 01:25 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: keyboard layout

I was talking based on my experience with KDE in Debian sid (last I used was 4.7.4). I had my system in en_GB and the locale and keyboard for Brazil and it worked just fine.
Reply With Quote
  #12  
Old 25th April 2012, 02:58 PM
j0534ng31 Offline
Registered User
 
Join Date: May 2011
Location: Gijón, Spain
Age: 42
Posts: 28
linuxfirefox
Re: keyboard layout

Quote:
Originally Posted by JONOR View Post
Code:
$ su -
# system-config-keyboard
Ha ! first time i've seen a Brazilian keyboard mentioned, not that i would personally need it.
That list is quite different from kde systems settings keyboard layouts and variants.
And it's different from gnome list too...

With old Fedora versions I can't remember to have had this problem... but with F17 beta I've used this command to change the keyboard.

Until I did that, all my console windows were using the english keyboard layout.
Reply With Quote
  #13  
Old 31st May 2013, 09:15 PM
ggabriel96 Offline
Registered User
 
Join Date: May 2013
Location: Brazil
Posts: 1
linuxchrome
Re: keyboard layout

Hello guys! I'm new to this forum and I'm desperately looking for a solution.
I live in Brazil and my keyboard is English International on Windows, and it works perfectly. But on Fedora 18, it simply does not work. In none keyboard layout, neither English neither Portuguese (yes, tested them all!) ;x
Oh, and I'm using Gnome.
I need it because of the accents that my language has (é, í, ã...). Some are working with English (International with dead keys), but the c cedilla does not work at all. Additionally I can do things like these: ḿ, ṕ, ẃ, ẽ, ṽ that doesn't exist here >_< (and bothers a lot when writing, because it is not intended ;x)
Reply With Quote
Reply

Tags
keyboard, layout

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard layout drivendemented F15 Development 1 10th May 2011 05:09 PM
Keyboard layout / keyboard selector simpson0107 Using Fedora 0 26th February 2009 04:43 PM
Keyboard Layout Options per Keyboard sgarrity Hardware & Laptops 0 21st August 2008 02:53 PM
KDE Keyboard Layout bowens44 Using Fedora 0 9th March 2008 01:37 AM
FC5 - keyboard layout Trek1701 Using Fedora 0 22nd March 2006 03:23 AM


Current GMT-time: 08:34 (Sunday, 21-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Home Slice Pizza - Istana Maimoon Kerajaan Deli Sumatera Utara Travel Photos - Majestic Elegance Resort, Punta Cana Travel Photos - Flocafe Galatsi