Fedora Linux Support Community & Resources Center
  #1  
Old 10th February 2011, 03:42 AM
gsmith62 Offline
Registered User
 
Join Date: Feb 2011
Posts: 10
linuxfedorafirefox
error installing Usenext.rpm

Hi All,

I have just installed Fedora 14. I don't have a high level of knowledge with linux, and am now moving in grey area's beyond that knowhow.

I'm trying to install the UseNext .rpm file

Initially I tried using the rpm command, and got the following msgs:

usenext-5.27-1.i386 requires mono(gdk-sharp) = 2.10.0.0
usenext-5.27-1.i386 requires unrar
usenext-5.27-1.i386 requires mono(glib-sharp) = 2.10.0.0
usenext-5.27-1.i386 requires mono(gtk-sharp) = 2.10.0.0


I installled unrar and mono using yum

now I still get these msgs:

usenext-5.27-1.i386 requires mono(gdk-sharp) = 2.10.0.0
usenext-5.27-1.i386 requires mono(glib-sharp) = 2.10.0.0
usenext-5.27-1.i386 requires mono(gtk-sharp) = 2.10.0.0



tried this:

rpm -Uvih gtk-sharp2-2.12.10-3.fc14.i686.rpm
Preparing... ########################################### [100%]
package gtk-sharp2-2.12.10-3.fc14.i686 is already installed


I notice the usenext install is looking for 2.10.0.0 and I have installed 2.12.10-3.

Is this my problem?
Is there a workaround?

I'd be grateful for some tips.

Cheers!!

Grant

---------- Post added at 07:42 PM ---------- Previous post was at 03:17 PM ----------

I'm a step further. However it looks to me like the app is not yet supported on Fedora 14.

Thoughs anyone?

---------------------------------
yum install usenext.rpm
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Examining usenext.rpm: usenext-5.27-1.i386
Marking usenext.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package usenext.i386 0:5.27-1 set to be installed
--> Processing Dependency: mono(gdk-sharp) = 2.10.0.0 for package: usenext-5.27-1.i386
--> Processing Dependency: mono(glib-sharp) = 2.10.0.0 for package: usenext-5.27-1.i386
--> Processing Dependency: mono(gtk-sharp) = 2.10.0.0 for package: usenext-5.27-1.i386
--> Finished Dependency Resolution
Error: Package: usenext-5.27-1.i386 (/usenext)
Requires: mono(glib-sharp) = 2.10.0.0
Installed: gtk-sharp2-2.12.10-3.fc14.i686 (@/gtk-sharp2-2.12.10-3.fc14.i686(2))
mono(glib-sharp) = 2.12.0.0
Available: banshee-community-extensions-1.8.0-2.fc14.i686 (fedora)
mono(glib-sharp) = 2.12.0.0
Available: clutter-sharp-0-0.8.20090828.fc14.i686 (fedora)
mono(glib-sharp) = 2.12.0.0
Error: Package: usenext-5.27-1.i386 (/usenext)
Requires: mono(gdk-sharp) = 2.10.0.0
Installed: gtk-sharp2-2.12.10-3.fc14.i686 (@/gtk-sharp2-2.12.10-3.fc14.i686(2))
mono(gdk-sharp) = 2.12.0.0
Error: Package: usenext-5.27-1.i386 (/usenext)
Requires: mono(gtk-sharp) = 2.10.0.0
Installed: gtk-sharp2-2.12.10-3.fc14.i686 (@/gtk-sharp2-2.12.10-3.fc14.i686(2))
mono(gtk-sharp) = 2.12.0.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Last edited by gsmith62; 7th April 2012 at 06:53 AM.
Reply With Quote
  #2  
Old 15th April 2012, 06:05 PM
gsmith62 Offline
Registered User
 
Join Date: Feb 2011
Posts: 10
linuxfirefox
Re: error installing Usenext.rpm

UPDATE:
I have now a fresh install of F16. Have attempted to install "usenext_5.27.rpm" and it is still failing on the following:

error: Failed dependencies:
mono(gdk-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
mono(glib-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
mono(gtk-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386


I've also tried installing the windows version in Wine. but that needs .NET v2 which is not supported on a 64bit system.

I'd be grateful if I caould get some help on either of these.

Cheers!
Grant
Reply With Quote
  #3  
Old 15th April 2012, 06:40 PM
Dutchy Offline
Registered User
 
Join Date: Aug 2011
Posts: 1,100
linuxsafari
Re: error installing Usenext.rpm

Do you need that program for some particular reason?
If you do not then I can recommend Sabnzbd.
It runs great on Linux and on its forum there is someone that has a repository for it.
Reply With Quote
  #4  
Old 15th April 2012, 07:20 PM
gsmith62 Offline
Registered User
 
Join Date: Feb 2011
Posts: 10
linuxfirefox
Re: error installing Usenext.rpm

I have a paid account so I wanted to use it further.
I'll take a look at what you suggested and keep usenext on my missus' pc.

thx
Reply With Quote
  #5  
Old 18th April 2012, 08:17 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,082
linuxfirefox
Re: error installing Usenext.rpm

Did you install the mono libraries?

Code:
yum install mono-core
Then try to install the rpm with something like

Code:
rpm -Uvh filename.rpm
Use force if neccessary ;-)

Hint: Dump this crap and get a real NSP for less than 10 bucks a month or a block account.

Maybe you'll need additional mono files like these:

Code:
Available Packages
mod_mono.x86_64                             2.10-1.fc16                   fedora
mono-basic.x86_64                           2.10-2.fc16                   fedora
mono-basic-devel.i686                       2.10-2.fc16                   fedora
mono-basic-devel.x86_64                     2.10-2.fc16                   fedora
mono-core.i686                              2.10.5-1.fc16                 fedora
mono-core.x86_64                            2.10.5-1.fc16                 fedora
mono-data.x86_64                            2.10.5-1.fc16                 fedora
mono-data-oracle.x86_64                     2.10.5-1.fc16                 fedora
mono-data-postgresql.x86_64                 2.10.5-1.fc16                 fedora
mono-data-sqlite.x86_64                     2.10.5-1.fc16                 fedora
mono-debugger.i686                          2.10-1.fc16                   fedora
mono-debugger.x86_64                        2.10-1.fc16                   fedora
mono-debugger-devel.i686                    2.10-1.fc16                   fedora
mono-debugger-devel.x86_64                  2.10-1.fc16                   fedora
mono-devel.i686                             2.10.5-1.fc16                 fedora
mono-devel.x86_64                           2.10.5-1.fc16                 fedora
mono-extras.x86_64                          2.10.5-1.fc16                 fedora
mono-locale-extras.x86_64                   2.10.5-1.fc16                 fedora
mono-mvc.x86_64                             2.10.5-1.fc16                 fedora
mono-mvc-devel.i686                         2.10.5-1.fc16                 fedora
mono-mvc-devel.x86_64                       2.10.5-1.fc16                 fedora
mono-nunit.x86_64                           2.10.5-1.fc16                 fedora
mono-nunit-devel.i686                       2.10.5-1.fc16                 fedora
mono-nunit-devel.x86_64                     2.10.5-1.fc16                 fedora
mono-tools.x86_64                           2.10-3.fc16                   fedora
mono-tools-devel.i686                       2.10-3.fc16                   fedora
mono-tools-devel.x86_64                     2.10-3.fc16                   fedora
mono-tools-monodoc.x86_64                   2.10-3.fc16                   fedora
mono-wcf.x86_64                             2.10.5-1.fc16                 fedora
mono-web.x86_64                             2.10.5-1.fc16                 fedora
mono-web-devel.i686                         2.10.5-1.fc16                 fedora
mono-web-devel.x86_64                       2.10.5-1.fc16                 fedora
mono-winforms.x86_64                        2.10.5-1.fc16                 fedora
mono-winfx.x86_64                           2.10.5-1.fc16                 fedora
monodoc.x86_64                              2.10.5-1.fc16                 fedora
monodoc-devel.i686                          2.10.5-1.fc16                 fedora
monodoc-devel.x86_64                        2.10.5-1.fc16                 fedora
Reply With Quote
  #6  
Old 18th April 2012, 05:19 PM
gsmith62 Offline
Registered User
 
Join Date: Feb 2011
Posts: 10
linuxfirefox
Re: error installing Usenext.rpm

yep mono is installed, tried with--force still missing the 3 above.

This IS a $10 a month client that I pay for. :o(

How can I get just these 3 installed separately?

rpm -Uvh usenext_5.27.rpm --force
error: Failed dependencies:
mono(gdk-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
mono(glib-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
mono(gtk-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
Reply With Quote
  #7  
Old 18th April 2012, 05:42 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,209
linuxfirefox
Re: error installing Usenext.rpm

Don't put your rpm options at the end..
Code:
rpm --nodeps -ivh usenext_5.27.rpm
Reply With Quote
  #8  
Old 18th April 2012, 06:30 PM
gsmith62 Offline
Registered User
 
Join Date: Feb 2011
Posts: 10
linuxfirefox
Re: error installing Usenext.rpm

Quote:
Originally Posted by PabloTwo View Post
Don't put your rpm options at the end..
Code:
rpm --nodeps -ivh usenext_5.27.rpm
As simple as that!!

AWESOME!!

It now works!

Thanks a TON PabloTwo!!


Cheers!!

Grant
Reply With Quote
Reply

Tags
error, installing, usenextrpm

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while installing YUM ghadagerakesh Using Fedora 17 5th April 2010 08:40 AM
FC6 crc error when installing jjardel EOL (End Of Life) Versions 0 24th April 2007 06:04 PM
Error installing FC5 spool EOL (End Of Life) Versions 4 7th April 2006 10:38 PM
error while installing FC4 kingtron EOL (End Of Life) Versions 0 19th March 2006 05:29 PM
Error installing K-3D. penguinguy Using Fedora 1 11th May 2005 03:51 AM


Current GMT-time: 07:05 (Monday, 22-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Torino Via Sacchi Instagram Photos - Destin Commons Travel Photos - Cesena - Carisport Travel Photos on Instagram